Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
hi I'm having trouble with my Wireless connection I have a router [ Speedtouch 585 ] and I secure my wireless interface with WPA key The problem is I cannot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    18

    WPA key ?


    hi

    I'm having trouble with my Wireless connection

    I have a router [ Speedtouch 585 ]

    and I secure my wireless interface with WPA key

    The problem is I cannot connect to my router with WPA key

    My chip Is [ Intel® PRO/Wireless 3945ABG ]

    I try to remove the WPA key and its work Fine

    but I don't want to make my router Public


    any idea

    and by the way

    I use [ Wireless Assistant 0.5.7 ]
    and if i want to connect to my router it give me this error

    Code:
    ==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
    Using wpa_supplicant driver: ipw
    WPA client started. Waiting for status...
    CONNECTION FAILED.
    disconnect: /sbin/iwconfig eth1 mode managed key off ap off essid off
    Please help me

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It looks like wpa_supplicant is not configured correctly. Or maybe it isn't even installed?
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    18
    Yeah its not installed

    cuz I have problem with [ .config ] File

    I don't how to config it with my chip [ ipw3945 ]

    could you give me some basic ?

    and thank you for reply

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    There are config file examples in the folder /usr/share/doc/packages/wpa_supplicant/examples. Here's one for WPA-PSK-TKIP.
    Code:
    # WPA-PSK/TKIP
    
    ctrl_interface=/var/run/wpa_supplicant
    
    network={
        ssid="example wpa-psk network"
        key_mgmt=WPA-PSK
        proto=WPA
        pairwise=TKIP
        group=TKIP
        psk="secret passphrase"
    }
    You need to change the "example wpa-psk network" and "secret passphrase" to your specific settings, keep the quotation marks around those entries.
    There are other examples in the wpa_supplicant.conf file in /usr/share/doc/packages/wpa_supplicant/.

    Put your file in /etc/wpa_supplicant.conf. When you run wpa_supplicant, point it to that file.
    Code:
     wpa_supplicant -Dipw -ieth1 -c/etc/wpa_supplicant.conf
    Here is a link to your drivers page:
    Intel® PRO/Wireless 3945ABG Driver for Linux
    It says that you need the latest version of wpa_supplicant for it to work.

    There also is the wpa_gui that comes with wpa_supplicant. Type that into a terminal to bring it up.
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #5
    Just Joined!
    Join Date
    Oct 2007
    Posts
    18
    Yeah I read it

    and I want to install WPA_Sublicant

    but every time I want to install it I have problem with [ Make ]

    cuz My [ .config ] File is not Right

    I don't know how to make it right

    any one have it ?

    or basic how i do it

  6. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The exact error that you are getting would be helpful. Try the make command again, this time with debugging enabled:
    Code:
    # make -d
    Copy and post the errors that it gives you.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I had to download and try it myself before I realized what it was you needed. There is a sample config file, named defconfig. Open it up in a text editor and find the line for your driver, and uncomment it.

    Change this:
    Code:
    # Driver interface for Intel ipw2100/2200 driver
    #CONFIG_DRIVER_IPW=y
    To this:
    Code:
    # Driver interface for Intel ipw2100/2200 driver
    CONFIG_DRIVER_IPW=y
    Check the file out to see if there are any other things that you may want to enable or disable. Then save it as .conf (with the "dot" in front).
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #8
    Just Joined!
    Join Date
    Oct 2007
    Posts
    18
    I will try it now

    thanks

  9. #9
    Just Joined!
    Join Date
    Oct 2007
    Posts
    18
    Install done

    thanks to god then you

    But when I run this command

    Code:
    wpa_supplicant -Dipw -ieth1 -c/etc/wpa_supplicant.conf
    Give me this error

    Code:
    Trying to associate with 00:14:7f:11:ac:a7 (SSID='NattyDreed' freq=2412 MHz)
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Authentication with 00:00:00:00:00:00 timed out.
    What wrong ?

    and also I cannot connect ;(

  10. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Checking around for similar errors, I found some that say to use the wext driver in configuring wpa_supplicant. Try this:
    Code:
    # wpa_supplicant -Dwext -ieth1 -c/etc/wpa_supplicant.conf -w -dd
    Also, make sure that eth1 is actually the correct card:
    Code:
    # iwconfig
    And that your wpa_supplicant.conf file is correct.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •