Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all I have googled this issue for a very long time without any luck... so lets have a try here Basically the titles says it, when i try to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    4

    KnetworkManager + WPA-TKIP stuck at 28%


    Hello all

    I have googled this issue for a very long time without any luck... so lets have a try here

    Basically the titles says it, when i try to associate to my Siemens Gigaset SE505 wireless router with WPA+TKIP, KNetworkManager attempts to connect and gets stuck at 28%.

    The wireless card i am using is a buffalo wli-g54a -broadcom chipset 4318 that works nicely without any encryption (for example at my school wlan).

    I have also realized that everytime i reinstall Knetworkmanager + wpasupplicant +networkmanager, I get connected for the first time with encryption, if i disconnect then the 28% problems comes...

    I tried with an usb wlan card and got the same behavior. I experienced this while running kubuntu 7.04 and now when using freespire 2.0.6 on an ibm t30.
    Im running the KNetworkManager v.0.1.

    Any hints? workarounds?

    cheers

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Have you tried connecting using terminal commands like ifup/ifdown? It may then give you more information on why it is hanging up. I don't know if there is a verbose option for those commands (-v), but that would give even more information.

    Since it seems to be an encryption problem, are you sure that the card supports wireless encryption? Also try disabling wpa_supplicant, because I don't believe it is needed with knetworkmanager (I could be wrong). It is needed if you use the ifup/if down commands.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Aug 2007
    Posts
    4
    Hi Paul

    Thanks for your help. I solved the issue anyway.. I just forgot about using knetwork manager, there is a known bug about this (also the other way around, meaning stuck at 28% withouth any encryption).

    So, i basically went some versions down with wpa_supplicant. The latest version would not complete the wpa handshake with my access point. Now I am using wpa_supplicant version 0.4.8-3unbuntu1.1 and the latest ndiswrapper. However, with wpa_supplicant im using the wext driver because with ndiswrapper wpa_supplicant didnt work either... weird stuff but working...

    Thanks a lot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •