Find the answer to your Linux question:
Results 1 to 6 of 6
I'm trying to set up wireless on my desktop, on which I just installed elive, but I'm not sure where I am in the process and why it isn't working. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Location
    Portland
    Posts
    4

    Don't know where I am with rt61 driver and wireless configuring


    I'm trying to set up wireless on my desktop, on which I just installed elive, but I'm not sure where I am in the process and why it isn't working. I was able to set up wireless on this PC when I was running Debian, but I don't remember what I did (I'm taking better notes this time around).

    My understanding of the process is piecemeal and very limited, and I would like to understand it better. I haven't been having much luck getting a cohesive understanding with searching google and reading the iwconfig and ifconfig man pages.

    On to the specifics:

    First of all, my driver seems to show up in iwconfig:
    # iwconfig
    ra0 RT61 Wireless ESSID:""
    Mode:Managed Frequency:2.412 GHz Bit Rate=1 Mb/s
    RTS thr:off Fragment thr:off
    Encryption key:off
    Link Quality:0 Signal level:0 Noise level:113
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    But when I try to update the settings with:

    # iwconfig ra0 mode managed
    # iwvonfig ra0 channel 6 //the correct channel from my router
    # iwconfig ra0 essid MyESSID
    # iwconfig ra0 key myWEPkey

    the changes don't stick. And oftentimes, when I try to make those changes, if I then run iwconfig or ifconfig, the terminal hangs and I have to restart terminal and/or reboot the computer. Furthermore, when I try to bring up the wireless settings:

    #ifdown eth0
    # ifup ra0

    I get the response "Failed to bring up ra0" and the terminal hangs and I have to reboot the computer before ifconfig or iwconfig can do anything again.

    For completeness, here is the output from ifconfig:

    # ifconfig
    eth0 Link encap:Ethernet HWaddr 00:18:F3:A0:57:E4
    inet addr:192.168.2.2 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::218:f3ff:fea0:57e4/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:36 errors:0 dropped:0 overruns:0 frame:0
    TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:10408 (10.1 KiB) TX bytes:2964 (2.8 KiB)
    Interrupt:225 Base address:0xe000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    I've also tried manually modifying my /etc/network/interfaces file but that doesn't seem to affect iwconfig or ifconfig. Here is what my interfaces file looks like:

    iface lo inet loopback
    auto lo
    # Used by ifup(8) and ifdown(8). See the interfaces(5) manpage or
    # /usr/share/doc/ifupdown/examples for more information.

    auto eth0
    iface eth0 inet dhcp

    #auto ra0
    iface ra0 inet static
    address 192.168.1.115
    network 192.168.1.1
    netmask 255.255.255.0
    wireless-essid MyESSID
    wireless-key MyWEPkey
    wireless-channel 6
    wireless-mode managed

    With all of these steps, I'm assuming that the drivers are installed and happy, but I'm not positive that is the case. I've read some tutorials (e.g. at serialmonkey and in the Ubuntu wiki) but I haven't found one that I understand (they are nicely detailed, but that doesn't help me much if I can't figure what or why I'm doing each step, when the steps fail). If someone can point me to a tutorial or wiki that they found helpful, I would be very appreciative.

    That said, it looks like the driver modules are loaded (is that the right way to say it?) based on the following outputs:

    # lspci | grep Ra
    04:09.0 Network controller: RaLink RT2561/RT61 802.11g PCI

    # lsmod | grep rt61
    rt61 221064 0

    # modinfo rt61
    filename: /lib/modules/2.6.18-elive/extra/rt61.ko
    author: http://rt2x00.serialmonkey.com
    description: Ralink RT61 802.11abg WLAN Driver 1.1.0 BETA1 2006/06/18
    license: GPL
    vermagic: 2.6.18-elive SMP preempt mod_unload 386 REGPARM gcc-3.4
    depends:
    alias: pci:v00001814d00000301sv*sd*bc*sc*i*
    alias: pci:v00001814d00000302sv*sd*bc*sc*i*
    alias: pci:v00001814d00000401sv*sd*bc*sc*i*
    parm: ifname:Network device name (default ra%d) (charp)
    parm: debug:Enable level: accepted values: 1 to switch debug on, 0 to switch debug off. (int)

    # dmesg | grep ra0
    ra0 (WE) : Driver using old /proc/net/wireless support, please fix driver !
    (I read that this isn't an important message, but is just telling developers that this is something to update. . . is it true that this message isn't something for me to worry about?)

    I wanted to see where the drivers were on my system, and thought I would post it here in case that's helpful. I saw a few tutorials that recommended making symlinks for the driver in another directory, but I didn't want to do that without knowing that it was something I needed to do.

    # ls /usr/src
    kernel-source-2.6.18-elive
    linux
    modules
    rpm
    rt2500.tar.gz (I think this one is from when I was reading/following a tutorial on installing rt2500 drivers, though I realize that I want the rt61 drivers.)


    # ls /libmodules/2.6.18-elive
    acx100
    extra
    kernel
    linux-wlan-ng
    misc
    modules.alias
    modules.ccwmap
    modules.dep
    modules.ieee1394map
    modules.inputmap
    modules.isapnpmap
    modules.ofmap
    modules.pcimap
    modules.seriomap
    modules.symbols
    modules.usbmap
    net
    nvidia
    shfs
    updates
    usb


    If anyone can tell me what I'm missing in figuring this out I would really appreciate it. I would also appreciate relevant and helpful wiki pages, tutorials, or other forum posts.

    Thank you in advance.

  2. #2
    Just Joined!
    Join Date
    Apr 2007
    Location
    Portland
    Posts
    4
    I forgot to add, I also upgraded wireless-tools
    # aptitude upgrade wireless-tools
    which also set up nvidia-glx.

    That didn't help.

    I also tried to use module-assistant in order to install drivers, but after preparing module-assistant
    # prepare module-assistant
    and installing the drivers
    # module-assistant auto-install rt2500-source (again, not the exact drivers I needed)
    I got the error:
    "Bad luck, the kernel headers for the target kernel version could not be found and you did not specify other valid kernel headers to use."

    When I tried to download the kernel headers
    # aptitude install linux-headers-2.6.18-elive
    I got the following error:
    error: repository.elivecd.net elive/main linux-headers-2.6.18 3.03 Not Found

    So I'm not sure if perhaps I'm missing the necessary kernel headers to build the driver module?

    I've also tried using the network-admin GUI (based on the tutorial at Ubuntu Networking for Basic and Advanced Users -- Debian Admin)
    but I read in the ubuntu forums RaLink RT61 Wireless Solved - Ubuntu Forums that network-admin conflicts with setting up wireless with rt61.

    Again, thank you for the help.

  3. #3
    Just Joined!
    Join Date
    Apr 2007
    Location
    Portland
    Posts
    4
    https://help.ubuntu.com/community/Wi...ver/RalinkRT61 seems like the right idea (following the advice for Fiesty Fawn lower down on the page) but I'm not saavy enough or experienced enough to know if it *is* the right thing for me to do.

    Unfortunately, these directions presuppose that ifconfig shows the wireless card, whereas mine does not. I don't understand why iwconfig shows the wireless card but ifconfig doesn't. I haven't been able to find a website that explains the difference between ifconfig and iwconfig. I didn't find the man pages helfpul. Does anyone have a recommendation?

    I feel like I must be missing something obvious here. . .

    Anyone have any suggestions or ideas?

    Is this the correct forum for these questions?

    Thank you for the help!

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    I don't have much help for you only to say I had very similar problems running a device using the Ralink chipset in CentOS. The configurations to wireless just would not take. I finally narrowed it down to this... I could configure it with WEP or with Essid, but not both together. I had much better luck using Ralink devices in Ubuntu. In the CentOS machine, I finally had to install a wireless device with the Atheros chipset. How does it do when running it without WEP?
    Linux Mint + IceWM Registered:#371367 New Members: click here

  5. #5
    Just Joined!
    Join Date
    Apr 2007
    Location
    Portland
    Posts
    4
    That's a good question, and I should test it out. I can't disable the WEP right now because it would disrupt others in my house (my landlords who live upstairs) but this weekend I could give them warning and play around with it then.

    I am still hoping that I am just being dumb, and that something wrong is discernible from my gibberish above.

  6. #6
    Just Joined!
    Join Date
    Feb 2006
    Posts
    1
    should it be iwconfig key open also?

    how about setting the mtu in iwconfig?

    my router MTU is set to 1432 and my wireless won't find the
    router unless I set the mtu.

    stab in the dark?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •