Find the answer to your Linux question:
Results 1 to 1 of 1
I'm having trouble getting wireless working on a new Debian 4.0 etch install on my Thinkpad T40. The internal Broadcom wireless 4306 wasn't working with the bcm43xx drivers after extracting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Location
    NE Ohio
    Posts
    7

    USB wireless Debian 4.0 etch - no eth device created


    I'm having trouble getting wireless working on a new Debian 4.0 etch install on my Thinkpad T40.

    The internal Broadcom wireless 4306 wasn't working with the bcm43xx drivers after extracting firmware with fwcutter, so I tried ndiswrapper, but nothing worked.

    So I thought I'd try my MyEssentials ME1001-USB, which was working in my Thinkpad 770 with Debian. When that didn't work either, I tried physically removing the internal broadcom and its entry in /etc/udev/rules.d/z25-persistent-net.rules to see if that helped at all, but it didn't.

    When I plug in my wireless USB (MyEssentials ME1001-USB) on my IBM T40, Debian 4.0 etch, I don't get a new ethx, wlanx, wifix, or any other new device.

    After plugging it in and issuing "modeprobe zd1211rw" I have reviewed the following: (eth0 is the wired LAN adapter)
    PHP Code:
    # dmesg
    usb 4-3: new high speed USB device using ehci-hcd and address 3
    usb 4
    -3configuration #1 chosen from 1 choice

    # lsmod | grep "zd"
    zd1211rw            38304  0
    ieee80211softmac    26304  1 zd1211rw
    ieee80211           29416  2 zd1211rw
    ,pcmcia
    usbcode             112644  4 zd1211rw
    ,ehci_hcd,uhci_hcd

    # iwconfig
    lo    no wireless extensions
    eth0  no wireless extensions
    irda0 no wireless extensions
    sit0  no wireless extensions 
    Any ideas what to look for next?

    --Bryan

    Kernel: Linux version 2.6.18-5-686 (Debian 2.6.18.dfsg.1-13)
    Last edited by bryan641; 11-20-2007 at 06:27 PM. Reason: Add kernel version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •