Find the answer to your Linux question:
Results 1 to 3 of 3
I'm using the most recent version of DamnSmallLinux, and when I initially install it to a USB drive it works great. I can modify files, get online via wifi, etc. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    1

    Ndiswrapper works on initial setup, but fails after reboot.


    I'm using the most recent version of DamnSmallLinux, and when I initially install it to a USB drive it works great. I can modify files, get online via wifi, etc. But when I reboot, my network card stops working. Nothing shows up in iwconfig/ifconfig except the loopback and ndiswrapper -l is empty. I'd used the ndiswrapper script that comes with DSL to set up the card initially, but when I do it again with the same exact settings I get 'Connection failed'. Doing it via the script and also doing it manually puts the driver in the 'ndiswrapper -l' list, but it still doesn't show up in iwconfig/ifconfig. Any ideas on what I should do?

  2. #2
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    101
    try:

    Code:
    lsmod | grep ndiswrapper
    to see if the module has been loaded. If not, as root, you can try:

    Code:
    modprobe ndiswrapper
    good luck.
    --Erik

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The best way to set up NDISwrapper is through the good ol' terminal. To see the commands that are available, enter this in a terminal (as root).
    Code:
    # ndiswrapper
    You should get this:
    Code:
    # ndiswrapper
    install/manage Windows drivers for ndiswrapper
    
    usage: ndiswrapper OPTION
    -i inffile       install driver described by 'inffile'
    -a devid driver  use installed 'driver' for 'devid'
    -r driver        remove 'driver'
    -l               list installed drivers
    -m               write configuration for modprobe
    -ma              write module alias configuration for all devices
    -mi              write module install configuration for all devices
    -v               report version information
    
    where 'devid' is either PCIID or USBID of the form XXXX:XXXX,
    as reported by 'lspci -n' or 'lsusb' for the card
    When you install the driver, you should then modprobe all of the choices individually.
    Code:
    # modprobe ndiswrapper
    # modprobe ndiswrapper -m
    # modprobe ndiswrapper -ma
    # modprobe ndiswrapper -mi
    It may still not load after a reboot. Then you may need to add it to a config file that contains the modules that are to be loaded at boot. Which file this is in DSL, I don't know.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •