Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hello, I have just dual booted my HP Pavilion notebook with Windows XP Home Edition and Fedora Core 8. I am not able to activate my wireless LAN card, nor ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    9

    Fedora Core 8-WLAN card not getting activated , wpa_supplicant initialization failing


    Hello,

    I have just dual booted my HP Pavilion notebook with Windows XP Home Edition and Fedora Core 8.

    I am not able to activate my wireless LAN card, nor connect to the internet.

    Also i am getting the following errors at boot time :

    [Failed to initialize wpa_supplicant] and some [Operation not supported] message


    I have tried a lot searching on net and configuring the below mentioned files.But no luck.

    This is the info i can provide:

    Kernel Release
    Code:
    [root@localhost ~]# uname -r
    2.6.23.1-42.fc8
    wpa_supplicant INFO
    Code:
    [root@localhost ~]# rpm -q wpa_supplicant
    wpa_supplicant-0.5.7-15.fc8
    ipw3945 firmware :

    Code:
    [root@localhost ~]# rpm -q iwl3945-firmware
    iwl3945-firmware-2.14.1.5-2
    iwconfig output :

    Code:
    [root@localhost ~]# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wmaster0  no wireless extensions.
    
    wlan0     IEEE 802.11g  ESSID:""  
              Mode:Managed  Frequency:2.437 GHz  Access Point: 00:0F:3D:B9:26:F4   
              Bit Rate=54 Mb/s   Tx-Power=27 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
              Encryption key:off
              Link Quality=78/100  Signal level=-56 dBm  Noise level=-90 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    ifconfig output :

    Code:
    [root@localhost ~]# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:16:D3:09:DD:E3  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:4895 errors:0 dropped:0 overruns:0 frame:0
              TX packets:4895 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:4416576 (4.2 MiB)  TX bytes:4416576 (4.2 MiB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:13:02:AF:5A:2C  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:5 errors:0 dropped:0 overruns:0 frame:0
              TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:800 (800.0 b)  TX bytes:4859 (4.7 KiB)
    
    wmaster0  Link encap:UNSPEC  HWaddr 00-13-02-AF-5A-2C-88-AD-00-00-00-00-00-00-00-00  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    wpa_supplicant log :

    Code:
    No network configuration found for the current AP
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    No network configuration found for the current AP
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    Could not acquire the system bus.
    Associated with 00:0f:3d:b9:26:f4
    Authentication with 00:0f:3d:b9:26:f4 timed out.
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    Associated with 00:0f:3d:b9:26:f4
    Authentication with 00:0f:3d:b9:26:f4 timed out.
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    Could not acquire the system bus.
    Could not acquire the system bus.
    No network configuration found for the current AP
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    No network configuration found for the current AP
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    No network configuration found for the current AP
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    CTRL-EVENT-TERMINATING - signal 15 received
    CTRL-EVENT-TERMINATING - signal 15 received
    Associated with 00:0f:3d:b9:26:f4
    Authentication with 00:0f:3d:b9:26:f4 timed out.
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    Associated with 00:0f:3d:b9:26:f4
    Authentication with 00:0f:3d:b9:26:f4 timed out.
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    CTRL-EVENT-TERMINATING - signal 15 received
    Could not acquire the system bus.
    No network configuration found for the current AP
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    CTRL-EVENT-TERMINATING - signal 15 received
    CTRL-EVENT-TERMINATING - signal 15 received
    Could not request DBus service name: already registered.
    Could not request DBus service name: already registered.
    Could not acquire the system bus.
    Could not acquire the system bus.
    Could not acquire the system bus.
    Could not acquire the system bus.
    Content in /etc/sysconfig/netwrok-scripts/ifcfg-wlan0 :
    Code:
    # Intel Corporation PRO/Wireless 3945ABG Network Connection
    DEVICE=wlan0
    ONBOOT=yes
    BOOTPROTO=dhcp
    HWADDR=00:13:02:af:5a:2c
    NETMASK=
    DHCP_HOSTNAME=
    IPADDR=
    DOMAIN=
    TYPE=Wireless
    ESSID=G604T_WIRELESS
    CHANNEL=1
    MODE=Managed
    RATE=54Mbps
    USERCTL=yes
    IPV6INIT=no
    Content in /etc/sysconfig/wpa_supplicant
    Code:
    INTERFACES="-iwlan0"
    DRIVERS="-Dwext"
    Content in /etc/wpa_supplicant/wap_supplicant.conf

    Code:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=wheel
    
    eapol_version=1
    ap_scan=1
    fast_reauth=1
    
    
    network={
    	ssid="G604T_WIRELESS"
    	key_mgmt=WPA-PSK
    	psk="abc"
    	scan_ssid=1
    }
    Content in /etc/rc.d/rc.local :

    Code:
    touch /var/lock/subsys/local
    /bin/sleep 1
    /sbin/service wpa_supplicant start
    /bin/sleep 2
    /sbin/dhclient wlan0
    Also i have switch on my laptop which is used to start WLAN/Bluetooth on/off, which works fine in Windows but in Linux this
    switch doesn't turn blue and remains red which in Windows indicates that the WLAN/Bluetooth is off.

    Kindly help me out resolving this problem.

    Thanks,
    Jignesh

  2. #2
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3
    Obviously, the wireless encrypted link is not established.

    You should :

    1/ check that the dbus service is started before wpa_supplicant

    2/ some chip dont support scan_ssid=1 ; try replacing it with scan_ssid=0

    Regards,

    Pierre

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    9
    Hi pjuhen,

    Thanks for the reply.
    I will try out the second option.Bue how to check that the dbus service is started before wpa_supplicant and of its not then how to start it.

    Thanks,
    Jignesh

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User glennzo's Avatar
    Join Date
    Sep 2004
    Location
    Salem, Mass
    Posts
    466
    You don't need any of that for the IPW3945 card in Fedora 8. It should work out of the box. Mine does and has for quite some time now. Select System > Administration > Services and start NetWorkManager. An icon should appear in the top panel. Click on it to see wireless access points. Check the box next to NetworkManager so that it starts at boot.
    Glenn
    Powered by Fedora

  6. #5
    Just Joined!
    Join Date
    Oct 2007
    Posts
    9
    Hi glennzo,

    I can see a wireless networks icon on the top of the panel.
    In the list no pre-defined WAPs can be seen.I tried to connect to my wireless network using another option also in that list.
    Its asking for the security key asking me to select a option from the below mentioned security techniques:

    Code:
    a) NONE
    b) WEP-128 bit passphrase
    c) WEP 46/128-bit hexadecimal
    d) WEP 40/128-bit ASCII
    e) LEAP
    f) Dynamic WEP(802.1x)
    g) WPA Pre-Shared Key
    h) WPA and WPA2 Enterprise

    From WINDOWS OS i found that i have the data encryption technique as "WEP" and the key which is used to connect to my G604T_WIRELESS network, i have already mentioned in my /etc/sysconfig/network-scripts/keys-wlan0 file..


    Also changing the scan_ssid to 0 didn't worked and still i am getting the [Failed to initialize wpa_supplicant] and some [Operation not supported] message at boot time.

    Also i have switch on my laptop which is used to start WLAN/Bluetooth on/off, which works fine in Windows but in Linux this
    switch doesn't turn blue and remains red which in Windows indicates that the WLAN/Bluetooth is off.
    Also what is the case with the above mentioned statement and is all the configuration info provided in my first post correct or some
    rectification is needed in them.

    Kindly help me resolving the problems mentioned above.

    Thanks,
    Jignesh

  7. #6
    Linux User glennzo's Avatar
    Join Date
    Sep 2004
    Location
    Salem, Mass
    Posts
    466
    Try the option 'connect to other wireless network', enter the network ssid and passkey. Can't tell you which of the wep options to use. Try them all.
    Glenn
    Powered by Fedora

  8. #7
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3
    If you use WEP, you don't need wpa_supplicant. But don't rely on it for security, it is as resistant as a japanese paper wall.

    I have a G604-T too.

    1/ Kill any dhclient that runs for wlan0, and get rid of your rc.local stuff.

    2/ Using another computer connected to your G604-T , go the web administration, then configuration / Wireless LAN and note the key on a paper (without errors).

    3/ Now on your HP, choose option c and you should be asked for the key. (it will create a wallet/keyring for storing it, with an access password)

    Carefully type the key, it should work.

    Good luck

    Pierre

  9. #8
    Just Joined!
    Join Date
    Oct 2007
    Posts
    9
    Hi pjuhen,

    a) Now there is no content in /etc/rc.d/rc.local : file.
    b) There is following content in /etc/wpa_supplicant/wap_supplicant.conf

    Code:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=wheel
    Also when trying to connect to the wireless the system tries to connect for some time and then suddenly prompts a box with the following contents to be provided:

    Code:
    Title : Secrets required by wireless n/w.
    
    1.Wirless Security : A  drop down having the following options:
    a) WEP-128 bit passphrase
    b) WEP 46/128-bit hexadecimal
    c) WEP 40/128-bit ASCII
    d) LEAP
    e) Dynamic WEP(802.1x)
    
    2. Passphrase : #empty textbox#
         checkbox: Show passphrase
    
    3. Authentication : A  drop down having the following options:
    a) Open System
    b) Shared key
    Again selecting WEP 46/128-bit hexadecimal option and providing my pass key, the system once again tries to connect to the wireless for sometime and then prompts the details mentioned above.And this goes on.

    Note i am successfully able to connect to the wireless n/w from Windows OS.

    Please let me know where i am going wrong.

    Thanks,
    Jignesh

  10. #9
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3
    when asked for the secret, you should :

    1/ choose option b)

    2/ check the box and key in your secret key (verify in on your G604).

    3/ try the 2 options (I guess open will work, but I am not sure)

    After that, ti should work....

    Regards,

  11. #10
    Just Joined!
    Join Date
    Oct 2007
    Posts
    9
    pjuhen,

    I will try that out soon and let you know whatever the outcome.Also i forgot to add this in my earlier post that still in the network devices teh wlan0 's status is shown as inactive.

    Thanks.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •