Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 29 of 29
yeah when i tried to install the nsidwrapper, it gave me some error in the terminal when i did the "make, make file" part it said something about KBUILD like ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Jan 2008
    Posts
    12

    yeah when i tried to install the nsidwrapper, it gave me some error in the terminal when i did the "make, make file" part it said something about KBUILD like i had to set the kernel source in KBUILD or something like that.

  2. #22
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I'm not exactly sure, but I think that error is referring to the programs needed to compile a kernel module. NDISwrapper (and most Linux drivers) are kernel modules.

    The NDISwrapper installation wiki that I linked to before, has the prerequisites listed that are needed to compile it. I understand that the kernel source is no longer included with Fedora 8. You may be able to just install the kernel headers to compile NDISwrapper. You may be able to get YUM to install them using this command (as root).
    Code:
    # yum install kernel-devel
    If that gives you too many files (there should be only one), you will have to specify your kernel version. To find the kernel version, enter this.
    Code:
    uname -rm
    Use that information to install the headers with yum.

    I found a Fedora 8 guide that may help you with some things.
    Personal Fedora 8 Installation Guide
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #23
    Just Joined!
    Join Date
    Jan 2008
    Posts
    12
    so, would i need to download Yums also and for the kernel version, what would i type if the kernel gives me too many files for: # yum install kernel-devel ? like if my kernel was 4 would i type # yum install kernel-devel4 or # yum install kernel-devel 4 ?

  4. $spacer_open
    $spacer_close
  5. #24
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    There is another package that you may need to install, kernel-headers. Install that the same way you installed the kernel-devel package.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #25
    Just Joined!
    Join Date
    Jan 2008
    Posts
    12
    just to make sure, i would do # yum install kernel-devel (by going to link you gave me) then i would do # yum install kernel-header (by going to link you gave me) ? edit: for the devel one, there is i586 and i686...

  7. #26
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I was just checking my Fedora 8 file server. I think that I updated it, so my kernel is 2.6.23.14-107.fc8.i686. So, when I use YUM, I only needed to enter this.
    Code:
    # yum install kernel-devel
    It takes care of the version. If I needed to specify the version, I would enter this.
    Code:
    # yum install kernel-devel-2.6.23.14-107.fc8.i686
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #27
    Just Joined!
    Join Date
    Jan 2008
    Posts
    12
    Ok, i will have to try that.

  9. #28
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I thought that I should try out some of my own advice. So, I installed Fedora 8 on a partition on my laptop.

    I am writing this using Fedora 8 and the wireless in my laptop.

    My laptop uses a Broadcom wireless, so I am currently using the Linux native b43 driver module. I tried to use NDISwrapper, but the module wouldn't load properly. There may be another module besides b43 that is interfering, I'll try again someday.

    I did compile NDISwrapper from source, with no problems. When I installed Fedora 8, I selected most of the programs in the Development section. Upon the initial boot, I upgraded the system with yum.
    Code:
    yum -y upgrade
    I still had a lot of trouble setting up the wireless. Then I found a very helpful guide for Fedora 8.
    Fedora8 - Fedora Guide

    The section on wireless is mostly for Broadcom wireless, but I think that it will be helpful for any wireless on Fedora 8. Here is the section on NDISwrapper. I haven't tried it yet.
    Fedora8 - Fedora Guide

    It says to download NDISwrapper binary from a repository. Maybe you should try that method, it just may work ok. It will be a bit easier too.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #29
    Just Joined!
    Join Date
    Jan 2008
    Posts
    22
    Quote Originally Posted by waterhead View Post
    Download the stable version. Uncompress the file by first directing the terminal to the folder where it is.
    Code:
    cd /folder_where_ndiswrapper_is
    Then uncompress.
    Code:
    tar xvfz ndiswrapper-1.51.tar.gz
    Now compile and install it with these commands.
    Code:
    cd /ndiswrapper-1.51
    make distclean
    make
    Now log in as superuser (su)
    Code:
    su
    password:<enter password>
    Then install
    Code:
    make install
    Once again, be sure that you have all of the prerequisites installed first.
    Hi Paul!

    I'm having the same problem and I'm trying to get to the directory where the tarball is located (my thumbdrive- in windows it's F: )
    I typed the following command in root:
    cd /F:
    but it replied: "No such file or directory"

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •