Find the answer to your Linux question:
Results 1 to 7 of 7
Hi Am trying out Debian and having no joy getting my Belkin wireless card (Ralink RT2561/RT61 802.11g PCI) to work. Have tried using ndiswrapper (but can't get past being told ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5

    Belkin wireless G FD57010 ver 6 on Debian Etch


    Hi

    Am trying out Debian and having no joy getting my Belkin wireless card (Ralink RT2561/RT61 802.11g PCI) to work.

    Have tried using ndiswrapper (but can't get past being told I have an invalid driver); and also tried installing the Ralink r61 driver - which the system now asks me to replace - and configuring my set-up. But without joy.

    The attachment contains an outline of what I have tried to do, following some of the vast amounts of free advice that some of you people kindly provided; together with some details from iwconfig etc.

    Be really grateful if anyone can help me. Should explain that I am clueless about computers (normally I just USE the internet and a word-processor on windows). Be nice to be able to use Linux instead, but I'm struggling!

    Thanks

  2. #2
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5

    Further details 1

    The attachment doesn't seem to have stuck so here's details of what I tried so far

    (a) Installed ndiswrapper. Ultimately pointed it at the unzipped driver. Was told Error 2 - invalid driver. Started reading posts telling me maybe I needed to compile source code. [????] Ran "make" on the files in the driver folder. This just produced a message saying there was "nothing to be done for them.")

    (b) lspci tells me that the network controller is Ralink RT2561/RT61 802.11g PCI. Therefore tried installing Ralink Linux driver for rt61.

    After much reading, I eventually (or so I think):
    (a) installed the Linux-headers using synaptic
    (b) installed tofrodos
    (c) unzipped the drivers folder.
    (d) Followed instructions for compiling the driver source code.
    ` (e) Got relevant stuff over to a directory, /etc/Wireless/RT61STA
    as directed by the guidance notes.
    (f) Copied the driver to the kernel directory.
    (g) Disabled the ethernet; loaded the driver; activated ra0.
    (h) Scanned with "iwlist" and then tried to configure the SSID, mode, channel and key.

    Cannot guarantee this all went as intended; it wasn't quite the orderly process it might sound (took a ridiculously long time). (Remember I know NOTHING).

    Having done this, I did get some life into the card: I could scan it - which I couldn't always; and the first green light was on briefly if never again. But I'm not connected to the internet.

    On the desktop networking utility, it still appeared as unconfigured after doing this. (and I entered the addresses etc over there to see if it helped but it didn't). The SSID and key details then turned up in one of the etc/ files , though they have gone since I tried again with a DHCP connetion.

    (I also tried installing wifi radar as I read that this had sorted some people's
    problems out, but I can't get that to run either).

    (On installation, "DHCP" wasn't recognised; and I left setup until later.)

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5

    Problem Fixed -Thanks

    Hi Everyone

    Have finally managed to sort the problem - using the other drivers (Main Page - Rt2x00Wiki).

    And then installing Rutilt. (which was a saga - for any other neophyte who is trying in addition to everything else they tell you about you seem to need to install build-essentials and g++ - and I am sure this will seem self-evident to many).

    Finally online on the Debian side. (Now all I have to do is to make myself able to wander around and connect at work etc....)

    Apologies for bothering you all with the pleas for help - but it has taken me a little over a week to sorting this out; and I was getting a little desperate.

    Thanks to all those who wrote all those guidance notes out there - they may be a nightmare to find, and may rather underestimate the degree of my ignorance. But it's an experience, right? (I can go back to learning Linux basics now; and then it's the camera).

    Take care

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It looks like you were able to figure things out by yourself. Congratulations! I think that you will make a very good Linux user.

    To connect to my wireless access points in Ububntu, I have used the Wireless Manager. I don't know if there is any reason that it wouldn't work for the RaLink. It makes connecting very simple.
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #5
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5
    Thanks for the tip (and noticing the thread). I couldn't get the wireless manager to work, but the rutilt application seems great - very easy to use.

  6. #6
    Just Joined!
    Join Date
    Apr 2008
    Posts
    1
    Hi I have a card like yours and I'm having troubles with it on xubuntu. What exactly did you do to fix it? I was able to compile the drivers from that wiki you posted the link to, but I can't compile the qmake program needed to compile the configuration utility that came with it.

  7. #7
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5
    Hi

    [First: apologies if this message appears twice - my reply doesn't seem to have stuck first time round.]

    I didn't have too much trouble configuring the utility once I had got the right thing up and running, so don't have a good note of what I did. Sorry....

    I initially tried to configure it using an adaptation of the instructions pasted below.
    But I seem to remember that I actually got it working through the Rutilt Utility itself. I use DCHP and think I just had to set the settings through the profile tab (adding a new profile and going on through to set the details).
    I seem to remember some trouble over running the thing as root and maybe I launched it the first times through the command line as root.
    On someone's advice, I had uninstalled network manager and installed wireless tools at a fairly early stage in the process though I don't know if this is necessary.

    I have a set of notes (basically copies of relevant guidance stuff) that I collected as I went along and it contains everything that I will have known when I got it up and running. If you let me have an email address, I can send you through copies.

    If none of that works for you, let me know and I will try to remember further. Sorry not to be more definitive.

    Step #7: Configure card

    Next logical step is to load the device driver. If you have Ethernet card disable
    to avoid problems:

    # ifconfig eth0 down
    # modprobe rt61
    Once driver is loaded, you can activate interface called ra0. With ifconfig command:

    # ifconfig ra0 192.168.1.2 up
    To configure a wireless network interface you need to use iwconfig command.
    This command is part of wireless-tools package.
    If wireless-tools is not installed use apt-get or yum to install it:

    # apt-get install wireless-tools
    Now make sure you know the ssid / essid. If you have turned on encryption,
    you must use the same encryption type and key on both desktop system and
    the wireless router. You can obtain necessary settings using iwlist command:

    # iwlist ra0 scanning
    Output:

    ra0 Scan completed :
    Cell 01 - Address: 00:12:39:6C6:8A
    ESSID:"nixcraft"
    Mode:Managed
    Channel:6
    Encryption key:on
    Step #1: Set SSID/ESSID
    You need to set ssid/essid. My SSID is nixcraft.
    The SSID/ESSID is used to identify cells which are part of the same virtual
    (wireless) network:

    # iwconfig ra0 essid nixcraft
    Step #2: Set mode
    You need to set the operating mode of the PCI card. Use Managed mode that node
    connects to a network composed of many Access Points (wireless router).

    # iwconfig ra0 mode Managed
    Step 3: Setup channel
    Set the operating frequency or channel in the device.

    # iwconfig ra0 channel 6
    Step 4: Setup key
    Used to manipulate encryption or scrambling keys and security mode
    (you can obtain security key by opening your web browser and type your
    routers IP address into address bar):

    # iwconfig ra0 key 47b1122774d1xy55a1194lchjk6
    You can now ping to wireless router or browser internet and rest of network (if connected).

    Step #8: Configure rt61 driver auto-load at boot time
    #1: Configure ra0 interface so that it can activated after reboot.
    Create a wlan.up and wlan.down helper scripts.
    Download these scripts and copy to /etc/Wireless directory.

    #2: Make sure wireless kernel modules (rt61) to load at boot time.
    Open config file /etc/modules (this file contains the names of kernel modules
    that are to be loaded at boot time, one per line.):

    # vi /etc/modules
    Append rt61 module:

    rt61
    Close and save the file.

    #3: Configure ra0 ip address:
    Open /etc/network/interfaces file:

    # vi /etc/network/interfaces
    Make sure ra0 interface look like as follows (static IP configuration):

    auto ra0
    iface ra0 inet static
    name Wireless LAN card
    address 192.168.1.2
    netmask 255.255.255.0
    broadcast 192.168.1.255
    network 192.168.1.0
    gateway 192.168.1.1
    post-up /etc/Wireless/wlan.up
    post-down /etc/Wireless/wlan.down
    Save the file and reboot the system.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •