Find the answer to your Linux question:
Results 1 to 4 of 4
Fact 1: My laptop's wireless card is an Intel Pro Wireless 3945ABG, and the operating system on the laptop is Ubuntu Linux 7.1 Fact 2: I am able to access ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Lich's Avatar
    Join Date
    Feb 2008
    Posts
    30

    Ubuntu 7.10 Open Wireless Anomoly


    Fact 1: My laptop's wireless card is an Intel Pro Wireless 3945ABG, and the operating system on the laptop is Ubuntu Linux 7.1

    Fact 2: I am able to access any secure wireless network I want as long as I have the password, and I am able to browse once connected. I am also able to access any open wireless network I wish, and browse the net once connected to those... except for one... the Bismarck State College Open Wireless.

    Fact 3: My ifconfig and iwconfig look to be in solid order. Here are the outputs:

    mitch@mitch-laptop:~$ ifconfig
    eth0 Link encap:Ethernet HWaddr 00:E0:B8:C5:0C:05
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:17

    eth1 Link encap:Ethernet HWaddr 00:192:67:ED:31
    inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::219:d2ff:fe67:ed31/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:8748 errors:77 dropped:6527 overruns:0 frame:0
    TX packets:7296 errors:0 dropped:1 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:13843794 (13.2 MB) TX bytes:2493940 (2.3 MB)
    Interrupt:16 Base address:0xe000 Memory:d6000000-d6000fff

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    mitch@mitch-laptop:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 IEEE 802.11g ESSID:"linksys"
    Mode:Managed Frequency:2.437 GHz Access Point: 00:1A:70:E4:86:99
    Bit Rate:24 Mb/s Tx-Power:15 dBm
    Retry limit:15 RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality=48/100 Signal level=-81 dBm Noise level=-81 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:6468 Missed beacon:0
    Now, to expand upon fact 2 for a moment, I am technically able to connect to BSC's open wireless. The network manager indicates I am connected, and I am receiving an IP address from the DHCP. However, I can't ping any websites (which of course means that opening a browser results in a "the page cannot be found" message, regardless of the URL).

    The head of the Information Services department at BSC actually removed all access controls from all the BSC networks for the simple sake of making sure nothing - according to him - could be blocking me. The results were the same though.

    Considering that I can connect anywhere else, it would seem there is something on BSC's side that isn't allowing me past their router. On the other side of the coin, the fact that all network access controls were removed, it would seem to be a setting on my end.

    I've considered the possibility that it is a driver issue because the 3945ABG Intel card I have uses a proprietary driver, BUT it is enabled via the restricted drivers manager. I would think if that were the issue, I wouldn't be able to connect anywhere - and that is not the case.


    So I'd like some assistance troubleshooting this issue. If anyone has any info, I would appreciate it.

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Since you haven't received any replies, I'll try.

    You may need to use wpa_supplicant. You would have to make a config file containing the info needed to connect to this network.

    Linux WPA Supplicant (IEEE 802.1X, WPA, WPA2, RSN, IEEE 802.11i)

    Looking over the supported cards list, I don't see Intel listed, unless you are using the ipw2100/ipw2200 driver. If you used NDISwrapper for the driver, that too is supported.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined! Lich's Avatar
    Join Date
    Feb 2008
    Posts
    30
    Quote Originally Posted by waterhead View Post
    Since you haven't received any replies, I'll try.

    You may need to use wpa_supplicant. You would have to make a config file containing the info needed to connect to this network.

    Linux WPA Supplicant (IEEE 802.1X, WPA, WPA2, RSN, IEEE 802.11i)

    Looking over the supported cards list, I don't see Intel listed, unless you are using the ipw2100/ipw2200 driver. If you used NDISwrapper for the driver, that too is supported.
    I appreciate the reply. I'm going to look over the info you gave me, and tinker for a few days. I won't be back up to the campus until next week, so I'll have to get back to you with results.

    Thank you.

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I'll post my wpa_supplicant.conf file (with confidential info removed). It will help to see an example.
    Code:
    # WPA AES encryption
        ctrl_interface=/var/run/wpa_supplicant
        network={
            ssid="your_network"
            key_mgmt=WPA-PSK
            proto=WPA
            pairwise=CCMP TKIP
            group=CCMP TKIP WEP104 WEP40
            psk="your_password"
            priority=2
        }
    There are also examples in the /usr/share/doc/wpa_supplicant folder. Running the wpa_supplicant -h command will give some info too.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •