Find the answer to your Linux question:
Results 1 to 10 of 10
Hello, I just recentally instaled Ubuntu and am having trouble settinng up a wireless network. I'm was using a SWL - 2300U wireless adapter to connect with Windows, and upon ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18

    Help With Wireless Connection


    Hello, I just recentally instaled Ubuntu and am having trouble settinng up a wireless network. I'm was using a SWL - 2300U wireless adapter to connect with Windows, and upon switching to Linux I've realized that it can not recognize any drivers for this. I later got an Intel Anypoint wireless || network adapter, but that isn't compatiable with Linux either.

    My questions are: What would I need to get to have a wireless internet connection with Linux, could I get it cheap anywhere, and is it possible to somehow get Linux to recognize either one of my adapters. I'm really at a loss, and would very much like to use Linux, but simply don't have any use for it if I can't even get online. Thank you for your time in reading this, and I would really appreciate any help.

  2. #2
    Just Joined!
    Join Date
    Jun 2007
    Posts
    71
    I've used TP Link. They are pretty low priced, but work well in Ubuntu. Ubuntu has a built in driver for that one.

  3. #3
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    Thanks, I'll try that.

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    In Linux, the wireless drivers are written for the boards' chipsets. It is important to know the model and manufacturer of the chipsets. To find out this info, type this into a terminal.

    For a PCI or built in card
    Code:
    ls pci
    For a USB card
    Code:
    ls usb -v
    Look for information about the wireless and post it here.
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #5
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    When I type either one into the terminal I get a "No such file or directory'. But it seems I got lucky anyway, I ordered one, and tried it out, it gave me a little trouble as all technology seems to do, but I've got it to work.

  6. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Sorry, the commands should have looked like this:
    Code:
    lspci
    lsusb -v
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #7
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    Well, an interesting stuation has arrised. I was streaming a movie, and all the sudden it was getting all choppy, then when I tryed to move the mouse the movement was all choppy, and when I tryed to exit my window nothing happened, and I couldn't even move my curor. So I shut off my computer. When I turned it back on my wifi card no longer works...I'm not entirely sure how I got it to work last time either. I have the driver for it, but everything on the disk is in .exe format so I don't think it's any good. How I did it last time was, just stick the card in press a few buttons and eventually it work, but this time it's not working...the "Statue" light turn on but that's about all it does.

    Any help would be greatly appreciated.

  8. #8
    Just Joined!
    Join Date
    Feb 2008
    Posts
    18
    Disregard that, I unplugged and re-plugged the card about 6times, and eventually it started working again.

  9. #9
    Just Joined!
    Join Date
    Apr 2008
    Posts
    1
    I'm having the very same problem with the very same WLAN adapter - SWL-2300U. For reasons of abject poverty, I can't afford to buy a different adapter - heck, I'm writing this over my neighbor's unsecured wifi, on my girlfriend's computer. So I'm trying to figure out how to use the one I've got. I ran lsusb -v as suggested above, and the relevant line read:

    Bus 003 Device 002: ID 055d:b230 Samsung Electro-Mechanics Co.

    And then the rest of the adapter's info from there on. I'm running absolutely vanilla Ubuntu 7.10, in fact just installed it a couple of days ago. I like Ubuntu a lot so far, but it's tough to get an idea if I can use it day-to-day without connecting it to the internet. If anybody has any suggestions, it'd be really appreciated. Thanks!

  10. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    To see if there is a native Linux driver loading, enter this command and post the output.
    Code:
    lsmod
    You may need to use NDISwrapper. You would then need to remove and blacklist any native driver.

    Here are some commands to try.

    sudo ifconfig wlan0 down
    sudo iwconfig wlan0 ap any
    sudo iwconfig wlan0 essid any
    sudo ifconfig wlan0 up
    sudo dhclient wlan0
    sudo iwevent

    Watch for the events. If that does not work, set your access point to your router's MAC manually, e.g.:

    sudo iwconfig wlan0 ap 00:60:1D:01:23:45 (change this to match your access point)

    I got this info from the Ubuntu forums
    Please Help - I Can't connect to wireless router - Page 2 - Ubuntu Forums
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •