Find the answer to your Linux question:
Results 1 to 5 of 5
So I just got my old Dell Latitude CPx out and am trying to set up wifi on it.I have a U.S Robots USR5410 Wifi Card. When going to the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    32

    Question How do I get my Wifi Card Drivers ???


    So I just got my old Dell Latitude CPx out and am trying to set up wifi on it.I have a U.S Robots USR5410 Wifi Card. When going to the manufacturers website, they claim they have a linux compatible driver and then point me to DriverLoader. Here: USRobotics Support: Model 5410 - 5410

    So I tried to install DriverLoader with a .deb package that I put on the computer (from my flash drive, since I don't have internet access) The .deb package opens up, and then gives me an error that I don't have my Kernel Headers and Source installed. However, I noticed that the .deb pakcage also said that I already had the package DriverLoader installed. When I run "driverloader" in the terminal, nothing happens. But sure enough, there's a "driverloader" folder in /etc.

    My Question is, how do I run driverloader, and how do I install drivers? (Note: I don't have the install disc, since my friend gave me this old laptop a few days ago, and he didn't have the disc)

    Thanks for all your help guys

    ------------------------------------

    Edit: Also, Debian seems to at least recognize the card in lspci, although the LEDS aren't active or anything like that.

    It's under lspci as "Network controller: Texas Instruments ACX 111 54mbps Wireless Interface"

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It looks like DriverLoader is similar to NDISwrapper, in that it uses the Windows driver to connect. I would just use NDISwrapper instead.

    There is a chance that you can use a native Linux driver for this card. To find out, you first need to know the make of the chipset on the card. To find the info, enter this command in a terminal and post the output.
    Code:
    lspci -nn
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Never mind the lspci -nn, I didn't see your edit at the bottom of your post.

    There is a Linux driver for this chipset:
    The ACX100/ACX111/TNETW1450 wireless network driver project (Linux, BSD)
    ACX - ACX100/ACX111 wireless network driver project

    It only supports WEP encryption, and not WPA. You may also be able to use NDISwrapper, which uses the WinXP driver. It appears that the Windows driver supports WPA encryption, so that MAY work with NDISwrapper.
    WPA - ACX100/ACX111 wireless network driver project
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. #4
    Just Joined!
    Join Date
    Jan 2007
    Posts
    32
    thanks waterhead I recall you helping me fix my troubles with Linux networking a long time ago. I'll go try out those open source drivers and let you know how it goes. Thanks again for the help

  5. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    32
    So I found a solution, I simply installed Ubuntu Gutsy, and although this still did not work at first, once I set it to a manual configuration the internet worked fine. Thanks for all the help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •