Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Broadcom BCM4303 Problem

    I am totally new to Linux, but have bought a laptop to dedicate my learning more about this distro. I have an Intel P4 3.20GHz with a 60Gb HDD partitioned between Win XP Pro and OpenSuse 10.3 in dual boot mode. RAM only 512Mb and Graphics ATI Radeon RS300 5835 (according to YAst).

    When Suse boots up, the wireless card light does not show on the laptop and when I right click on KNetwork Manager it cannot identify any wireless network. I can get online via the hard ethernet connection though. I have studied the YAst2 Hardware and the details for the wireless LAN are: Broadcom BCM4303 802.11b (eth0).

    I have tried configuring the device in YAst2 'Network Settings'. 'General tab' - Activate Device: At Boot Time... Operating Mode: Managed... Network Name (ESSID): BTHomeHub-xxxx... Authn Mode: WEP-Open... Key Input Type: xxxxxxxxxx (I entered my WEP security key here)... clicked NEXT and FINISH.

    I then rebooted and still the wireless indicator light didn't come on, nor would KNetwork Manager identify my BT Home Hub.

    Any help would be appreciated... but not an urgent query folks as I can still get online via my Win XP or via my full desktop PC.

    many regards.

  2. #2
    The bcm4303 chip may not be fully supported with the native Linux driver.
    b43 - Linux Wireless

    Anyway, for it to work at all, you need firmware installed. If you take a look at the output of this command, it may actually tell you what is wrong.
    Here are the instructions for installing the firmware.
    b43 - Linux Wireless

    To determine the firmware that you need, first find out which driver your system is using.
    Look for either bcm43xx or b43, and then follow the instructions on the Linux Wireless page link above.

    Now, if you find that it doesn't support your wireless, you can use NDISwrapper. This may be your best bet anyway. Just make sure that the native driver (bcm43xx or b43) is not loaded, and then you need to blacklist it to keep it from loading at boot. I'll help you on this when you need it.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Thanks ever so much for your advice and time replying. I'm afraid after spending a number of hours troubleshooting the problem and not really understanding the coding instructions within YAst (despite researching the issue), I finally lost patience and uninstalled Suse. It probably won't be my last try with Linux, but for the time being I'll just have to renew my curiosity with this quite complex (in my opinion) Distro. regards

  4. $spacer_open
  5. #4
    I'm sorry that I didn't see your post earlier, I may have prevented you from giving up.

    openSUSE is a feature rich Linux distribution that usually is easy to configure. You had trouble with one of the sticky points in Linux. Wireless drivers are usually closed source, and not included in any free distro. Because they are closed source, there also is little or no development of drivers by the Linux community. But, there are still ways to get things to work.

    There are some wireless devices that are open source, and then work "out-of-the-box" in Linux. Most usually require a little bit of terminal work to detect and set up.

    One of the other sticky points can be video drivers and audio/video codecs, but this problem is correctable too.

    I encourage you to try Linux again, when you are ready. And please post for help in these and other Linux forums. Most of us are happy to help, if it will gain us another happy Linux user.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts