Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
I'm trying to switch over to Linux right now, so I am new to how everything works. I am having trouble with my wireless card (WMP54G) in Fedora 8. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    8

    Fedora 8 and Linksys WMP54G help


    I'm trying to switch over to Linux right now, so I am new to how everything works. I am having trouble with my wireless card (WMP54G) in Fedora 8. I have used ndiswrapper and installed the driver from the disk, but I dont know where to go from here. Fedora 8 is on a dual boot set up with Windows XP, where the card works just fine.

    Thanks for you patience in dealing with my Linux ignorance

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Ok. You've installed the driver. You shouldn't have to do anything else. What method did you use to install the driver?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    8
    ndiswrapper -i /media/WMP54G/Drivers/bcmwl5.inf
    from the disk
    I used ndiswrapper -l to see what I had after and it displyed bcmwl5.inf

    When I go to add another connection Fedora says that I have no wireless cards installed

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by melog625 View Post
    ndiswrapper -i /media/WMP54G/Drivers/bcmwl5.inf
    from the disk
    I used ndiswrapper -l to see what I had after and it displyed bcmwl5.inf

    When I go to add another connection Fedora says that I have no wireless cards installed
    I'm not sure if this is strictly necessary, but after I do an install, I always write to the modules as well with:

    Code:
    ndiswrapper -ma
    ndiswrapper -mi
    Then reboot.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  6. #5
    Just Joined!
    Join Date
    Apr 2008
    Posts
    8
    Thanks the card is working now!

  7. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I think that the step that you missed was this:
    Code:
    modprobe ndiswrapper
    This would load the module, it also was loaded after a reboot.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #7
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    Post the output of
    Code:
    ndiswrapper -l
    lsmod | grep ndiswrapper 
    lsmod | grep b44
    lsmod | grep ssb
    iwconfig
    lspci | grep Network
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  9. #8
    Just Joined!
    Join Date
    Apr 2008
    Posts
    8
    So I removed the driver from ndiswrapper and started over, here is the output of what happened:

    [root@localhost ~]# ndiswrapper -i /media/WMP54G/Drivers/bcmwl5.inf
    installing bcmwl5 ...
    forcing parameter IBSSGMode from 0 to 2
    forcing parameter IBSSGMode from 0 to 2
    forcing parameter IBSSGMode from 0 to 2
    forcing parameter IBSSGMode from 0 to 2
    [root@localhost ~]# ndiswrapper -l
    bcmwl5 : driver installed
    device (14E4:4320) present (alternate driver: ssb)
    [root@localhost ~]# modprobe ndiswrapper

    ****Rebooted the System****

    [root@localhost ~]# ndiswrapper -l
    bcmwl5 : driver installed
    device (14E4:4320) present (alternate driver: ssb)
    [root@localhost ~]# lsmod | grep ndiswrapper
    [root@localhost ~]# lsmod | grep b44
    [root@localhost ~]# lsmod | grep ssb
    ssb 29893 1 b43
    [root@localhost ~]# iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:""
    Mode:Managed Channel:0 Access Point: Not-Associated
    Tx-Power=0 dBm
    Retry min limit:7 RTS thr:off Fragment thr=2346 B
    Encryption key:off
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    [root@localhost ~]# lsmod | grep Network


    I can't see the card when I go to add a network connection. Linux gives me the option for "Other wireless device" which is just a list of Ethernet drivers

  10. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I thought that you said that it was working?

    If it isn't working with ndiswapper, it most likely is because a native Linux driver is loading first, and grabbing control of the wireless. It says that the alternate driver is ssb. Take a look at this thread.
    http://www.linuxforums.org/forum/red...tallation.html

    Please post the entire output of this command
    Code:
    /sbin/lsmod
    And this:
    Code:
     /sbin/lspci -nn | grep Network
    Last edited by waterhead; 04-29-2008 at 11:00 PM. Reason: Changed lspci command to grep
    Please do not send Private Messages to me with requests for help. I will not reply.

  11. #10
    Just Joined!
    Join Date
    Apr 2008
    Posts
    8
    I followed the directions on the other thread (rmmod everything then modprobe it) and a wireless connection appeared with the device wlan0 as the connector. But there is no wlan0 on the hardware list of the network config, and when I try to activate the connection I get:

    SIOCSIFLAG: No file or directory

    Determning IP for wlan0...failed

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •