Find the answer to your Linux question:
Results 1 to 7 of 7
I installed an RALink RT2561/RT61 on my Debian Etch desktop, using the drivers available here . The card is recognised by the computer no problem, but it won't connect to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    8

    Debian wireless


    I installed an RALink RT2561/RT61 on my Debian Etch desktop, using the drivers available here. The card is recognised by the computer no problem, but it won't connect to my router. I've tried using both DHCP and static, both to no avail. Up until now, I've been using a network bridge on my Windows laptop, but I'd rather remove the Microsoft link from the chain, if possible. I know the hardware is installed properly, because Kwifimanager can bring up a list of access points, and my router appears there, it just won't connect.

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Try using KNetworkManager instead. After it is installed, right-click on the icon in the system tray and put a check in the box next to "Enable Wireless".

    I used to use KWifiManager, but it didn't work in the newer distros. You do need wpa_supplicant installed for KWifiManager to handle WPA encryption. You are better off just using KNetworkManager instead, wpa_supplicant doesn't seem to be needed.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    8
    Okay, I installed KNetworkManager, but wireless was enabled by default, and I still can't connect. My router uses WEP, by the way. Any other ideas?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Check the output of this command for any error messages concerning the wireless.
    Code:
    dmesg
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Apr 2008
    Posts
    8
    Code:
    ra0 (WE) : Driver using old /proc/net/wireless support, please fix driver !
    RT61: RfIcType= 3
    NET: Registered protocol family 10
    lo: Disabled Privacy Extensions
    IPv6 over IPv4 tunneling driver
    ra0: no IPv6 routers present
    Last edited by frozenjakalope; 05-11-2008 at 04:54 PM. Reason: Missed a line

  7. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Check the output of ifconfig and iwconfig ra0. Is it getting an address through DHCP?

    You may need to configure it using the iwpriv commands. Here is a post in the Ubuntu forums about that.
    Ubuntu Forums - View Single Post - RaLink RT61 Wireless Solved

    Here's the entire thread:
    RaLink RT61 Wireless Solved - Ubuntu Forums
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The web site for the driver:
    Main Page - Rt2x00Wiki
    Has a link for setting up the rt61 in Ubuntu. Since that is Debian, it may be relevant.
    https://help.ubuntu.com/community/Wi...ver/RalinkRT61

    You may not need to install the driver from source, but it may be needed. If you run this command:
    Code:
    lsmod
    Is the driver listed as rt61pci? If so this would need to be removed (and blacklisted) before building the new driver.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •