Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
I used Wubi to install Ubuntu so i can have 2 os's on the same pc/laptop Everything went well, when i started up ubuntu the wireless hardware was not detected ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    S_U
    S_U is offline
    Just Joined!
    Join Date
    Jan 2008
    Posts
    9

    Wireless Hardware problems on Wubi Ubuntu


    I used Wubi to install Ubuntu so i can have 2 os's on the same pc/laptop

    Everything went well, when i started up ubuntu the wireless hardware was not detected and then i went to the driver list and it was empty

    Also i tried to enter wireless info for my home wireless network but it did not connect. Iv been trying for hours to get it working but no luck!

    I tried installing various apps but still didn't help, please and i ask please can someone help me

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Windows doesn't automatically support all wireless cards, so why would you expect Linux to do it?

    Actually some cards work almost without any configuration, but most require some configuring. I don't have a clue to what "Wubi" is, except that you don't need a special program to make a dual boot PC.

    You will need to get some information to diagnose how to make your wireless work. First what type is it? USB or PCI card or built-in? Enter these commands in a terminal and post the output. Remember that Ubuntu requires the "sudo" command to precede some commands.

    If it is a built-in or PCI wireless, use this command to determine the card info:
    Code:
    lspci -nn
    If it is a USB wireless, use this command. It will not give as much info as for a PCI card, but it is useful anyway:
    Code:
    lsusb
    To see a list of all driver modules that your system is loading, use this command. I usually can spot a wireless driver in the list:
    Code:
    lsmod
    To see any error codes that your system may have generated concerning the wireless, enter this command.
    Code:
    dmesg
    I think that I should post this as a stickie, as I am always repeating these steps.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    S_U
    S_U is offline
    Just Joined!
    Join Date
    Jan 2008
    Posts
    9

    Ouput

    I got all the neccessary output and added it onto a pastebin link

    here it is

    Nopaste - Output linux wireless

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    OK, Here is your wireless, it is a Broadcom:
    Code:
    04:00.0 Network controller [0280]: Broadcom Corporation BCM94311MCG wlan mini-PCI [14e4:4311] (rev 01)
    This is the Linux driver module that is loading for it:
    Code:
    b43                   126760  0
    And this is what you need to do to make it work:
    Code:
    [  104.278881] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found or load failed.
    [  104.278889] b43-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Drivers/b43#devicefirmware and download the correct firmware (version 4).
    More information on the b43 driver can be found here:
    b43 - Linux Wireless

    You have to download the firmware file and the b43-fwcutter application. Use b43-fwcutter to extract the firmware from the file, and put the firmware in the /lib/firmware/ folder.
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #5
    S_U
    S_U is offline
    Just Joined!
    Join Date
    Jan 2008
    Posts
    9
    The whole page is unclear and theres so much to do yet the packages and stuff are hard to find

    Could you please write a guide on exactly what to do and links to files, id appreciate it so much and may help others in future

  6. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The instructions for your firmware start here:
    b43 - Linux Wireless

    If you have never done anything through a Linux terminal before, that is about to change. Some commands are done as a user (you), others require root privileges. In Ubuntu, this is done by preceding the command with sudo (super user do).

    First, you want to create a folder to download everything to. Do this in your home directory. I will use su as the user, change it to whatever you are logged in as. In a terminal, enter this to create a folder (b43 in this example).
    Code:
    mkdir /home/su/b43
    Now, you need to change the directory that the terminal is "in". This is done with the cd command (Change Directory), we want to go to the folder that you just created.
    Code:
    cd /home/su/b43
    Now I will use the instructions that I linked to above.

    1) Use version 011 of b43-fwcutter. Download, extract the b43-fwcutter tarball and build it:

    You will use the command wget to download the b43-fwcutter file, it is a compressed file. You need to have wget installed, if you don't you will get an error.
    Code:
    wget http://bu3sch.de/b43/fwcutter/b43-fwcutter-011.tar.bz2
    This will be downloaded to the current folder. You uncompress it with this command:
    Code:
    tar xjf b43-fwcutter-011.tar.bz2
    This creates a folder named b43-fwcutter-011. You can move to that folder with this simple command.
    Code:
    cd b43-fwcutter-011
    Now you need to build the b43-fwcutter binary (called an "executable" in Windows) with this command.
    Code:
    make
    Now return the terminal to the original b43 folder, with this command
    Code:
    cd /home/su/b43
    2) Use version 4.80.53.0 of Broadcom's proprietary driver. Download and extract the firmware from this driver tarball:

    Setup the installation directory for the firmware.
    Code:
    export FIRMWARE_INSTALL_DIR="/lib/firmware"
    Now download the driver that contains the needed firmware.
    Code:
    wget http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2
    And uncompress it.
    Code:
    tar xjf broadcom-wl-4.80.53.0.tar.bz2
    Now move the terminal to the /kmod folder in the new uncompressed folder
    Code:
    cd broadcom-wl-4.80.53.0/kmod
    Now you will extract the firmware. Since the b43-fwcutter binary is in a different folder than the /kmod folder, you need to list the entire path to it in the command. You need to do this as root, so use sudo.
    Code:
    sudo /home/su/b43/b43-fwcutter-011/b43-fwcutter -w "FIRMWARE_INSTALL_DIR" wl_apsta.o
    The firmware should now be installed. You can see for yourself, look before you run the command and again after.

    Not to confuse you, but I usually don't use the "FIRMWARE_INSTALL_DIR" as part of the installation. I just use /lib/firmware instead. You then don't need to follow the step that says export FIRMWARE_INSTALL_DIR="/lib/firmware". The install command would then look like this.
    Code:
    sudo /home/su/b43/b43-fwcutter-011/b43-fwcutter -w /lib/firmware wl_apsta.o
    I would now reboot, and then setup the wireless connection. In Ubuntu use:
    System-->Administration-->Network.
    Then set up an access point connection with NetworkManager.

    Here's hoping that you now have wireless.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #7
    S_U
    S_U is offline
    Just Joined!
    Join Date
    Jan 2008
    Posts
    9
    Wow, youve been so helpful to me and im unbelievably grateful truly

    Although at step 1) where it says type make to make executable etc.

    I get a whole bunch of errors

    heres the paste

    Nopaste - Make Errors

  8. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You are most likely missing some programs needed. I must have missed this sentence at the beginning of the instructions.
    Note: You need to have a compiler and headers for libc installed. If you don't know what this means, why are you not using your distribution's packages?
    Well, since you are using Ubuntu, you could use the Synaptic Package Manager to find the 011 version of fw-cutter. Or, it is possible that it is already installed. Run this command without a path and with the option -v, if you have it, it will list the version.
    Code:
    b43-fwcutter -v
    You may be able to install it with apt, I tried with my Mythbuntu 7.10 and it couldn't find it.
    Code:
    sudo apt-get install b43-fwcutter
    I was able to build it on Mythbuntu, so if you want to try and compile it try installing these files:
    Code:
    sudo apt-get install g++
    And this
    Code:
    sudo apt-get install linux-libc-dev
    And also this
    Code:
    sudo apt-get install libc6 libc6-dev
    Apt may add some files for dependency reasons. After apt is done, try the make command again.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It just occurred to me, without a working wireless you may not have internet access. I hope that you can connect with a wired connection until the wireless is working.

    I found a post that said you need to install this program in order to make b43-fwcutter:
    Code:
    sudo apt-get install build-essential
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #10
    S_U
    S_U is offline
    Just Joined!
    Join Date
    Jan 2008
    Posts
    9

    Not working

    The wired connections not working

    Also all those commands i enter i get a "Package not found"

    im getting worried this isnt ever going to work

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •