Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 30
You need to be in the main folder of the kernel sources. There should be a file called "Makefile" there. The command that I use when compiling a kernel is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    You need to be in the main folder of the kernel sources. There should be a file called "Makefile" there. The command that I use when compiling a kernel is this.
    Code:
    make modules_install
    You may want to try the command that they list in the README file first.
    Code:
    make modules modules_install
    Or try them separately.
    Code:
    make modules
    make modules_install
    This last one makes the most sense to me, so try the two separate commands. You will need to wait for the "make modules" command to finish it's business before entering the "make module_install" command.
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #12
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Try cd /usr/src/kernels/2.6.24.7-92.fc8-i686
    make && make modules_install
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #13
    Linux Newbie
    Join Date
    May 2007
    Location
    Maldives
    Posts
    126
    Hi!
    I have tried all the commads above and they keep giving me the same error, mabe im missing something

    [root@localhost 2.6.24.7-92.fc8-i686]# make modules modules_install
    CHK include/linux/version.h
    CHK include/linux/utsrelease.h
    make[1]: *** No rule to make target `missing-syscalls'. Stop.
    make: *** [prepare0] Error 2


    Any ideas what i should do next?

    Nabaachy

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    To do kernel compiling you should have gcc 3.2 installed.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #15
    Linux Newbie
    Join Date
    May 2007
    Location
    Maldives
    Posts
    126
    Ooopss, now installing compat-gcc-34 and compat-gcc-34-c++

    Nabaachy

  7. #16
    Linux Newbie
    Join Date
    May 2007
    Location
    Maldives
    Posts
    126
    Hi
    Still the same error shows up. rpm -qa | grep gcc shows:
    gcc-4.1.2-33
    compat-gcc-34-c++-3.4.6-8
    compat-gcc-34-3.4.6-8
    libgcc-4.1.2-33

    is there any other package that i nedd to install?

    Nabaachy

  8. #17
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Make sure you have kernel-headers and kernel-devel installed too.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  9. #18
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I think that it won't work because there is no .config file yet. In the same folder, enter this command.
    Code:
    make menuconfig
    This is where you would change the options before compiling a kernel. You don't need to do anything, just exit and say yes to saving the file. The .config file is hidden, and you need to set your file manager to show hidden files if you want to see it (not necessary).

    Now try again (fingers crossed).
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #19
    Linux Newbie
    Join Date
    May 2007
    Location
    Maldives
    Posts
    126
    Hi waterhead and MikeTbob!

    I have given up hope for my d-link dwl-g650, it was giving me all kinds of errors. and today when i was going through my stuff, i found a d-link dwl-g630 card and a belkin card. For my surprise, as soon as i poped g630 into my lappy, it recognised the card and striaght away i could use it. Its chipset was RaLink RT2561/RT61. but i think the signal strength of this card weaker than the intel card i have. but the belkin card was useless, it had the mimo chipset.

    I wanted to thank both of you for your advice and effort to help me, really much appriciated. ::respect::

    Nabaachy

  11. #20
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Glad you got it working, and I'm sure after playing with Linux for awhile, you'll probably get them all working with Linux. Enjoy
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •