Find the answer to your Linux question:
Results 1 to 9 of 9
Hi guys, I just have obtained my first wireless router. I have never done anything with wireless before so I could use some pointers. My wireless access point is set ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416

    first steps with wireless - some advice needed


    Hi guys,

    I just have obtained my first wireless router. I have never done anything with wireless before so I could use some pointers.
    My wireless access point is set up correctly and I am connected as you can see.

    I am not sure whether I am setup in the best way as I have to take a few manual steps.

    Here is how it works for me.

    I boot up FC8 and goes through its startup. wlan0 is set to dhcp but it fails.
    Once I log on I check iwconfig and no ESSID or MAC address for access point is detected.

    I then run the following command: sudo wpa_supplicant -i wlan0 -D wext -c /etc/wpa_supplicant/wpa_supplicant.conf

    When I run iwconfig again my ESSID is detected as well as my access point.
    I restart the network service and behold I am connected

    There must be an easier way. How can I get Fedora to pick up my IP address on boot rather than failing?


    Also, are there any GUI available? What about picking up access points automatically, i.e. in a hotel or airport?

    Cheers
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    It's not a gui tool, but the easiest and quickest way I've found to detect access points is to use iwlist. You'd go from the command line:
    Code:
    iwlist wlan0 scan
    Try it and see. On getting connected at startup, no sure. I've gotten away from Fedora. If a better idea doesn't come up, you could try adding sudo wpa_supplicant -i wlan0 -D wext -c /etc/wpa_supplicant/wpa_supplicant.conf to /etc/profile.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I am using Fedora 8 on my laptop. I no longer use wpa_supplicant to connect to my access point, as it wasn't working anymore anyway.

    I use the NetworkManager daemon (aka KNetworkManager) to connect to all networks, wired and wireless. You can enable it by going into the services section on the main menu, or by entering this command.
    Code:
    system-config-services
    Put a check in the box next to NetworkManager and NetworkManagerDispatcher and start them, then save the configuration. There now will be a NetworkManager icon in the system tray. Right click on that icon and make sure that there is a check in the box net to "Enable Wireless".

    Now, left clicking on that same icon should show the available networks. If you try to connect to one that is encrypted, an "enter password" box will pop up. The password is saved by the keyring manager, which is itself protected by a password.

    When I boot at home, the wireless does not automatically connect, because a password is required. Once the desktop is started, and my network is detected, the keyring manager login pops up. Here you enter the keyring manager password, not the network password. This gives you access to all saved passwords (including the network), so you don't need to enter them individually.

    If NetworkManager is not showing any available networks, click on "Connect to Other Wireless Network..." and enter the required info.

    I don't take my laptop to many places, but NetworkManager has detected available wireless networks in the places that I have taken it.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    Just before I read your post a colleague of mine told me all about Networkmanager and that is probably what I am after. It picks up the networks that are available here at work.

    I am still running wpa_supplicant. It was my understanding I had to. Is that not the case?
    It contains the settings for my home network so will need to test when I get home.

    As I am typing this I am testing networkmanager. I have two here that are not encrypted but I can't seem to connect to any. Any ideas?
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  6. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Are the networks that you are trying to connect to truly open? Wireless connections can be filtered by MAC address, allowing only the pre-approved ones to connect.

    Are the networks showing up in NetworkManager? I haven't been able to connect to hidden networks/accesspoints with NetworkManager.

    As for wpa_supplicant, it is my understanding that it is not needed. I actually have it, because it was set up for older distro versions. I started using NetworkManager because wpa_supplicant and Kwifi wouldn't work for me anymore.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #6
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    yep, there are two open for anyone at work but I don't seem to be able to connect.


    Anyway, tested network manager at home and that works sweet. Just have to enter the keyring password each time I log on. Hopefully that can be automized.

    As far as wpa goes, it needs to be installed. Networkmanager needs it as a dependency but there does not seem to be a need to configure its config file when using NetworkManager
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  8. #7
    Just Joined!
    Join Date
    Jun 2008
    Posts
    4
    can't you write a bash script and put it on your desktop, which automaticly runs then required actions?

  9. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Quote Originally Posted by Allblack;595671t.
    Just have to enter the keyring password each time I log on. Hopefully that can be automized.
    This is a security feature, as the keyring manager can contain many different types of passwords. I don't know if you really want to disable it. The other option is to not use the keyring manager, and manually enter the network password every time.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    More on disabling the keyring manager login prompt.

    If you feel like experimenting, take a look at these posts and see if you can come up with anything.

    Howto: Get Network Manager to stop asking you for your keyring password (pam_keyring) - Ubuntu Forums
    Heka Networks, LLC :: PAM_KEYRING

    Let us know how it works out. Of course, if you really want to defeat all of the security in Linux, just install Windows.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •