Find the answer to your Linux question:
Results 1 to 7 of 7
I like Linux i do, but today its starting to get on my bad side! Ok, so i have a Dell Latitude C610 laptop running Fedora 7. Everything else works, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52

    Why wont this work?!


    I like Linux i do, but today its starting to get on my bad side!

    Ok, so i have a Dell Latitude C610 laptop running Fedora 7.

    Everything else works, Ethernet/USB/Sound/Even my built in mouse. And it was fantastic until i tried to get my wireless card working. So this is the result from /sbin/lspci

    Code:
    Network controller: Broadcom Corporation BCM4311 [AirForce 54g] 802.11a/b/g PCI Express Transceiver (rev 02)
    I have done every single step i have seen online. First i tried to use ndiswrapper, turns out its useless for this distro. Then i switched back over to the native bcm43xx-fwcutter driver. I've installed it, i've put the files in /lib/firmware and i've set my modprobe.conf like this

    Code:
    alias wlan0 bcm43xx
    And the /sbin/modprobe -r command. All the way down to adding new hardware which it notices wlan0 as new hardware. But wen i try to activate the wireless card in Network
    Configuration i get this error...

    Code:
    SIOCSIFFLAGS: No such file or directory
    Error for wireless request "Set Mode" (8B06) :
        SET failed on device wlan0 ; Invalid argument.
    
    Determining IP information for wlan0.
    My lord, can anyone tell me what this means and how do i fix it, actually how do i get my wireless working! Im so exhausted over this whole ordeal. Any suggestions would be helpful. Would be nice to hear from people with past experience with Fedora 7 and with the same BCM4311 wireless card that i have that has _successfully_ gotten it to work. Thanx in advance, if im not providing some info i'll give more details. Thanx in advance!

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I have that chipset on a wireless card, and it is running Fedora Core 7. The native driver in that older distro is indeed the bcm43xx. That driver is inferior, so I use NDISwrapper. My card is a Buffalo PCI card, and I used a WinXP driver that I got from the manufacturer's web site. There were quite a few drivers in one package, and I had to try a lot of them until I found the right one.

    When you use NDISwrapper, you have to remove the bcm43xx driver module:
    Code:
    /sbin/modprobe -r bcm43xx
    You then need to prevent it from loading at boot. Do this by adding it to the file /etc/modprobe.d/blacklist, at the bottom of the page add this:
    Code:
    blacklist bcm43xx
    The best WinXP driver to use is the one supplied by the manufacturer of your card. If that won't work, then start trying others that have been reported as working. If you need more specific info on my setup, it will have to wait until tomorrow, as that PC is out in the garage.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    Quote Originally Posted by waterhead View Post
    If you need more specific info on my setup, it will have to wait until tomorrow, as that PC is out in the garage.
    Go get it! lol Sorry to be so forward but i've been using Ethernet since i installed FC7 3 weeks ago =/

    But if you have the _very_ same card on the _very_ same distro, i would really really REALLY appreciate your version of a step-by-step way to get it working. What i dont understand is that i keep hearing that ndiswrapper doesnt work for Fedora 7 but then i see vids like this where that guy clearly got it working on a dell, not exactly the same model as mine but i think all dells use the same Broadcom wireless card. Anyway, if you could get back to me with your specific details on how you got your Fedora 7 working with BCM4311 i'll be your personal body guard for a year. jk But i'll be greatful Thanx in advance!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    If anyone would like to share some helpful feed back please dont hesitate! Im desparate here, im on the verge of reinstalling XP cause im tired of the Ethernet usage =/

  6. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I just checked my garage PC, and it looks like I was wrong on both counts. Here is the relevant system secs:

    Fedora Core release 6 (Zod)
    kernel: 2.6.20-1.2948.fc6
    Wireless Model: Buffalo Wireless-G High Speed PCI Adapter
    Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

    $ /usr/sbin/ndiswrapper -l
    netg54s : driver installed
    device (14E4:4318) present (alternate driver: bcm43xx)

    The driver that I am using is netg54s. This card is not available anymore in the USA because of a patent infringement lawsuit against Buffalo.

    I still think that I can help you get NDISwrapper setup. The first thing that I usually do is install a different package manager. I use the Smart Package Manager. It has a nice GUI that makes it easy to compare different versions of packages. It also allows you to search for packages. It can be installed with yum (as root).
    Code:
    yum install smart smart-gui
    After installing, you should add the ATrpms repository to Smart.
    ATrpms - installation instructions
    After that run the Update Channels selection. At this time you may want to upgrade to the latest available kernel. After that, search for ndiswrapper in Smart. You should install the latest version of ndiswrapper, and also the kernel module that matches the kernel that you are running, and the version NDISwrapper that you have installed. If you don't know the kernel version, run this command:
    Code:
    uname -r
    The NDISwrapper kernel module will have a slightly different name, depending on the repository that it comes from. Here are some:
    ndiswrapper-kmdl-<kernel version>
    kmod-ndiswrapper-<kernel version>

    After NDISwrapper is installed, you can install the WinXP driver with it. You need to use a driver that you know works with WinXP. Like I said before, the one that came with the wireless is usually the best to try first. Sometimes it is in an .exe file, these can be extracted. Let me know if you need to do this.

    You will need to tell NDISwrapper exactly where the driver is. For example, I will use the netg54s driver that my wireless uses. Let's say that it is in my home directory, in a folder called wireless. NDISwrapper needs the .inf file that is with the WinXP driver. So I would enter this (as root):
    Code:
    /usr/sbin/ndiswrapper -i /home/paul/wireless/netg54s.inf
    If there are no errors, I check to see if it is installed with this command:
    Code:
    /usr/sbin/ndiswrapper -l
    I would get this output:
    Code:
    netg54s : driver installed
            device (14E4:4318) present (alternate driver: bcm43xx)
    Then run these commands, one at a time:
    Code:
    /usr/sbin/ndiswrapper -m
    /usr/sbin/ndiswrapper -ma
    /usr/sbin/ndiswrapper -mi
    You now should have the wireless configured to use NDISwrapper. You should then reboot, and then configure your wireless connection. Enter this command, as root, to bring up the configuration GUI:
    Code:
    /usr/bin/system-config-network
    I use the NetworkManager to connect to the wireless. This is enabled by going to the main menu and selecting System-->Sevices. Put a check next to NetworkManager and NetworkManagerDispatcher. Start them and save the new configuration. There should now be an icon in the system tray for NetworkManager. Right click on that icon and make sure that there is a check in the box next to Enable Wireless. You now should be able to left click the icon to see available wireless networks.

    When you click on one to connect, it will ask for the connection info (encryption type and password). After entering this it should ask if you want to save this info. It will use either Kwallet or Keyring Manager to save the password. It will then ask for you to enter a password for your newly created wallet/keyring. You now will be able to save all wireless passwords, and access them all with only one password.

    Go as far as you can, and post back when you have problems.

    Remember, you need to first disable and remove the bcm43xx driver first.

    Good Luck
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #6
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    Omg Thanx so much dude! I thought i would NEVER get this to work! I swear im not updating the kernel/OS from now on unless i get a new lappy. After i followed your instruction i rebooted and used the device manager. I had to /sbin/ifdown eth0 and then the wireless started to work. I stand corrected everyone, ndiswrapper does work, patients is really all you need. And believe me i was Patient!

    Anyway, thanx again waterhead you were a big help

  8. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You're welcome.

    I'm happy that you now can fully enjoy your laptop with Linux. I hope that it is a long relationship.

    I would suggest that planning on installing a newer version of Fedora would be a good idea. Fedora Core 7 may not be supported for much longer. I think that it will be supported until Fedora 10 comes out (10-28-2008).

    The newer versions of Fedora have the b43 driver module instead of bcm43xx. This is a much improved driver for Broadcom wireless. I use the b43 driver in my laptop running Fedora 8.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •