Find the answer to your Linux question:
Results 1 to 4 of 4
I'm having an issue getting my new zonet zew1630 to work. I heard this card works out of the box with most distros, and I wanted to set it up ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! TuxXin's Avatar
    Join Date
    Apr 2008
    Posts
    23

    Zew1630 wireless pci adapter not working


    I'm having an issue getting my new zonet zew1630 to work. I heard this card works out of the box with most distros, and I wanted to set it up on my computer, so I could move it into the next room. My computer is running archlinux. I've tired running the rt61 drivers, which the archwiki and a few other sites say is the correct driver. After installing the rt61 module I ran:
    Code:
     modprobe rt61
    Running iwlist scanning shows two routers:

    Code:
    # iwlist scanning
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    wmaster0  Interface doesn't support scanning.
    
    wlan0     Scan completed :
              Cell 01 - Address: 00:12:17:0A:18:EB
                        ESSID:"TRAINSTATION"
                        Mode:Master
                        Channel:6
                        Frequency:2.437 GHz (Channel 6)
                        Quality=51/100  Signal level=-52 dBm  
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
                        Extra:tsf=00000022a659def0
              Cell 02 - Address: 00:90:4C:7E:00:10
                        ESSID:"FRITZ"
                        Mode:Master
                        Channel:11
                        Frequency:2.462 GHz (Channel 11)
                        Quality=46/100  Signal level=-80 dBm  
                        Encryption key:off
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
                        Extra:tsf=00000083ded322b1
    I want to connect to the router called 'TRAINSTATION', and I know the wep key.

    Code:
    iwconfig wlan0 essid TRAINSTATION key **********
    dhcpcd wlan0
    (The wep key is stared out, that isn't what I actually put in)

    If I run iwconfig I get this:

    Code:
     iwconfig 
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wmaster0  no wireless extensions.
    
    wlan0     IEEE 802.11g  ESSID:"TRAINSTATION"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: 00:12:17:0A:18:EB   
              Bit Rate=54 Mb/s   Tx-Power=27 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
              Encryption key:****-****-**
              Link Quality=71/100  Signal level=-50 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    I can't access the internet with my wireless connection though. I'm not very good with linux, so if someone could help me with this, I would appreciate it.

  2. #2
    Just Joined! TuxXin's Avatar
    Join Date
    Apr 2008
    Posts
    23
    Update:

    Quote Originally Posted by zouzou85

    what is dmesg after you modprobe the rt61. please post that.
    also, what is the encryption type of the network you are trying to access WEP or WPA?
    also post the output of lspci here.

    EDIT: i did some research and it seems that your card should work perfectly with linux because the ralink driver is fully integrated with the linux kernel.
    try installing wicd. It will simplify your search.
    ArchWiki :: Wicd - ArchWiki

    Last edited by zouzou85 (Today 13:12:23)
    Quote Originally Posted by tuxxin
    The encryption is WEP.
    Code:
    lspci
    00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
    00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
    00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
    00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
    00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
    00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
    00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
    00:09.0 Network controller: RaLink RT2600 802.11 MIMO
    00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
    00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
    00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
    00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
    00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
    00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
    01:00.0 VGA compatible controller: nVidia Corporation GeForce 7600 GT (rev a2)
    Code:
     dmesg
    Linux version 2.6.25-ARCH (root@architect) (gcc version 4.3.0 (GCC) ) #1 SMP PREEMPT Fri May 16 14:29:57 CEST 2008
    Command line: root=/dev/sda3 ro
    BIOS-provided physical RAM map:
     BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
     BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
     BIOS-e820: 00000000000e6000 - 0000000000100000 (reserved)
     BIOS-e820: 0000000000100000 - 000000003ffc0000 (usable)
     BIOS-e820: 000000003ffc0000 - 000000003ffce000 (ACPI data)
     BIOS-e820: 000000003ffce000 - 000000003fff0000 (ACPI NVS)
     BIOS-e820: 000000003fff0000 - 0000000040000000 (reserved)
     BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
     BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
    Entering add_active_range(0, 0, 159) 0 entries of 256 used
    Entering add_active_range(0, 256, 262080) 1 entries of 256 used
    end_pfn_map = 1043969
    DMI 2.3 present.
    ACPI: RSDP 000F88B0, 0014 (r0 ACPIAM)
    ACPI: RSDT 3FFC0000, 0030 (r1 A M I  OEMRSDT   1000715 MSFT       97)
    ACPI: FACP 3FFC0200, 0084 (r2 A M I  OEMFACP   1000715 MSFT       97)
    ACPI: DSDT 3FFC0400, 3BDB (r1  12345 12345123      123 INTL 20051117)
    ACPI: FACS 3FFCE000, 0040
    ACPI: APIC 3FFC0390, 006C (r1 A M I  OEMAPIC   1000715 MSFT       97)
    ACPI: OEMB 3FFCE040, 0060 (r1 A M I  AMI_OEM   1000715 MSFT       97)
    Entering add_active_range(0, 0, 159) 0 entries of 256 used
    Entering add_active_range(0, 256, 262080) 1 entries of 256 used
    early res: 0 [0-fff] BIOS data page
    early res: 1 [6000-7fff] SMP_TRAMPOLINE
    early res: 2 [200000-686c4b] TEXT DATA BSS
    early res: 3 [37f2e000-37fefb89] RAMDISK
    early res: 4 [9fc00-a0bff] EBDA
    early res: 5 [8000-afff] PGTABLE
     [ffffe20000000000-ffffe200001fffff] PMD ->ffff810001200000 on node 0
     [ffffe20000200000-ffffe200003fffff] PMD ->ffff810001600000 on node 0
     [ffffe20000400000-ffffe200005fffff] PMD ->ffff810001a00000 on node 0
     [ffffe20000600000-ffffe200007fffff] PMD ->ffff810001e00000 on node 0
     [ffffe20000800000-ffffe200009fffff] PMD ->ffff810002200000 on node 0
     [ffffe20000a00000-ffffe20000bfffff] PMD ->ffff810002600000 on node 0
     [ffffe20000c00000-ffffe20000dfffff] PMD ->ffff810002a00000 on node 0
    Zone PFN ranges:
      DMA             0 ->     4096
      DMA32        4096 ->  1048576
      Normal    1048576 ->  1048576
    Movable zone start PFN for each node
    early_node_map[2] active PFN ranges
        0:        0 ->      159
        0:      256 ->   262080
    On node 0 totalpages: 261983
      DMA zone: 56 pages used for memmap
      DMA zone: 1167 pages reserved
      DMA zone: 2776 pages, LIFO batch:0
      DMA32 zone: 3527 pages used for memmap
      DMA32 zone: 254457 pages, LIFO batch:31
      Normal zone: 0 pages used for memmap
      Movable zone: 0 pages used for memmap
    ACPI: PM-Timer IO Port: 0x808
    ACPI: Local APIC address 0xfee00000
    ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
    Processor #0 (Bootup-CPU)
    ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
    Processor #1
    ACPI: LAPIC (acpi_id[0x03] lapic_id[0x82] disabled)
    ACPI: LAPIC (acpi_id[0x04] lapic_id[0x83] disabled)
    ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
    IOAPIC[0]: apic_id 2, address 0xfec00000, GSI 0-23
    ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
    ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 low level)
    ACPI: IRQ0 used by override.
    ACPI: IRQ2 used by override.
    ACPI: IRQ9 used by override.
    Setting APIC routing to flat
    Using ACPI (MADT) for SMP configuration information
    PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
    PM: Registered nosave memory: 00000000000a0000 - 00000000000e6000
    PM: Registered nosave memory: 00000000000e6000 - 0000000000100000
    Allocating PCI resources starting at 50000000 (gap: 40000000:bec00000)
    SMP: Allowing 4 CPUs, 2 hotplug CPUs
    PERCPU: Allocating 34152 bytes of per cpu data
    Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 257233
    Kernel command line: root=/dev/sda3 ro
    Initializing CPU#0
    PID hash table entries: 4096 (order: 12, 32768 bytes)
    TSC calibrated against PM_TIMER
    time.c: Detected 3199.957 MHz processor.
    Console: colour VGA+ 80x25
    console [tty0] enabled
    Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
    Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
    Checking aperture...
    Calgary: detecting Calgary via BIOS EBDA area
    Calgary: Unable to locate Rio Grande table in EBDA - bailing!
    Memory: 1025676k/1048320k available (2447k kernel code, 21580k reserved, 922k data, 276k init)
    CPA: page pool initialized 1 of 1 pages preallocated
    SLUB: Genslabs=12, HWalign=64, Order=0-1, MinObjects=4, CPUs=4, Nodes=1
    Calibrating delay using timer specific routine.. 6409.51 BogoMIPS (lpj=10677616)
    Security Framework initialized
    Capability LSM initialized
    Mount-cache hash table entries: 256
    CPU: Trace cache: 12K uops, L1 D cache: 16K
    CPU: L2 cache: 1024K
    CPU: Physical Processor ID: 0
    CPU: Processor Core ID: 0
    CPU0: Thermal monitoring enabled (TM1)
    ACPI: Core revision 20070126
    ACPI: Checking initramfs for custom DSDT
    Using local APIC timer interrupts.
    APIC timer calibration result 12499849
    Detected 12.499 MHz APIC timer.
    Booting processor 1/2 APIC 0x1
    Initializing CPU#1
    Calibrating delay using timer specific routine.. 6402.75 BogoMIPS (lpj=10666802)
    CPU: Trace cache: 12K uops, L1 D cache: 16K
    CPU: L2 cache: 1024K
    CPU: Physical Processor ID: 0
    CPU: Processor Core ID: 1
    CPU1: Thermal monitoring enabled (TM1)
                  Intel(R) Pentium(R) D CPU 3.20GHz stepping 04
    checking TSC synchronization [CPU#0 -> CPU#1]: passed.
    Brought up 2 CPUs
    net_namespace: 1016 bytes
    Booting paravirtualized kernel on bare hardware
    NET: Registered protocol family 16
    ACPI: bus type pci registered
    PCI: Using configuration type 1
    ACPI: EC: Look up EC in DSDT
    ACPI: Interpreter enabled
    ACPI: (supports S0 S1 S3 S4 S5)
    ACPI: Using IOAPIC for interrupt routing
    ACPI: PCI Root Bridge [PCI0] (0000:00)
    ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
    ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
    ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 *10 11 12 14 15)
    ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 10 *11 12 14 15)
    ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 *5 6 7 10 11 12 14 15)
    ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
    ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
    ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
    ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
    ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
    ACPI Warning (tbutils-0217): Incorrect checksum in table [OEMB] -  74, should be 67 [20070126]
    Linux Plug and Play Support v0.97 (c) Adam Belay
    pnp: PnP ACPI init
    ACPI: bus type pnp registered
    pnp: PnP ACPI: found 13 devices
    ACPI: ACPI bus type pnp unregistered
    PCI: Using ACPI for IRQ routing
    PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
    NetLabel: Initializing
    NetLabel:  domain hash size = 128
    NetLabel:  protocols = UNLABELED CIPSOv4
    NetLabel:  unlabeled traffic allowed by default
    PCI-GART: No AMD northbridge found.
    ACPI: RTC can wake from S4
    system 00:08: ioport range 0xa00-0xa0f has been reserved
    system 00:08: ioport range 0x290-0x29f has been reserved
    system 00:08: ioport range 0xa20-0xa2f has been reserved
    system 00:08: ioport range 0xa30-0xa3f has been reserved
    system 00:08: ioport range 0xa40-0xa4f has been reserved
    system 00:09: ioport range 0x3e0-0x3e7 has been reserved
    system 00:09: ioport range 0x4d0-0x4d1 has been reserved
    system 00:09: ioport range 0x800-0x87f has been reserved
    system 00:09: ioport range 0x400-0x41f has been reserved
    system 00:0a: iomem range 0xfec00000-0xfec00fff could not be reserved
    system 00:0a: iomem range 0xfee00000-0xfee00fff could not be reserved
    system 00:0c: iomem range 0x0-0x9ffff could not be reserved
    system 00:0c: iomem range 0xc0000-0xcffff has been reserved
    system 00:0c: iomem range 0xe0000-0xfffff could not be reserved
    system 00:0c: iomem range 0x100000-0x3fffffff could not be reserved
    system 00:0c: iomem range 0xff380000-0xffffffff has been reserved
    PCI: Bridge: 0000:00:01.0
      IO window: disabled.
      MEM window: 0xf3e00000-0xf7efffff
      PREFETCH window: 0x00000000d3d00000-0x00000000f3cfffff
    PCI: Setting latency timer of device 0000:00:01.0 to 64
    NET: Registered protocol family 2
    IP route cache hash table entries: 32768 (order: 6, 262144 bytes)
    TCP established hash table entries: 131072 (order: 9, 2097152 bytes)
    TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
    TCP: Hash tables configured (established 131072 bind 65536)
    TCP reno registered
    Unpacking initramfs... done
    Freeing initrd memory: 774k freed
    VFS: Disk quotas dquot_6.5.1
    Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
    Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
    io scheduler noop registered
    io scheduler anticipatory registered
    io scheduler deadline registered
    io scheduler cfq registered (default)
    PCI: VIA PCI bridge detected. Disabling DAC.
    pci 0000:00:11.0: Bypassing VIA 8237 APIC De-Assert Message
    pci 0000:01:00.0: Boot video device
    Linux agpgart interface v0.103
    Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing disabled
    serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    00:0b: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    input: Macintosh mouse button emulation as /class/input/input0
    PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
    PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp
    serio: i8042 KBD port at 0x60,0x64 irq 1
    mice: PS/2 mouse device common for all mice
    cpuidle: using governor ladder
    cpuidle: using governor menu
    TCP cubic registered
    NET: Registered protocol family 1
    NET: Registered protocol family 17
    registered taskstats version 1
    Freeing unused kernel memory: 276k freed
    No dock devices found.
    SCSI subsystem initialized
    input: AT Translated Set 2 keyboard as /class/input/input1
    libata version 3.00 loaded.
    pata_via 0000:00:0f.1: version 0.3.3
    ACPI: PCI Interrupt 0000:00:0f.1[A] -> GSI 20 (level, low) -> IRQ 20
    scsi0 : pata_via
    scsi1 : pata_via
    ata1: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xfc00 irq 14
    ata2: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xfc08 irq 15
    Switched to high resolution mode on CPU 1
    Switched to high resolution mode on CPU 0
    ata1.00: ATAPI: ATAPI   DVD A  DH20A4P, 9P57, max UDMA/66
    ata1.01: ATAPI: TSSTcorpCD-R/RW SH-R522C, TS05, max UDMA/33
    ata1.00: limited to UDMA/33 due to 40-wire cable
    ata1.00: configured for UDMA/33
    ata1.01: configured for UDMA/33
    ata2.00: ATA-6: ST380013A, 3.06, max UDMA/100
    ata2.00: 156301488 sectors, multi 16: LBA48 
    ata2.00: configured for UDMA/100
    scsi 0:0:0:0: CD-ROM            ATAPI    DVD A  DH20A4P   9P57 PQ: 0 ANSI: 5
    scsi 0:0:1:0: CD-ROM            TSSTcorp CD-R/RW SH-R522C TS05 PQ: 0 ANSI: 5
    scsi 1:0:0:0: Direct-Access     ATA      ST380013A        3.06 PQ: 0 ANSI: 5
    sata_via 0000:00:0f.0: version 2.3
    ACPI: PCI Interrupt 0000:00:0f.0[b] -> GSI 20 (level, low) -> IRQ 20
    sata_via 0000:00:0f.0: routed to hard irq line 5
    scsi2 : sata_via
    scsi3 : sata_via
    ata3: SATA max UDMA/133 cmd 0xec00 ctl 0xe880 bmdma 0xe400 irq 20
    ata4: SATA max UDMA/133 cmd 0xe800 ctl 0xe480 bmdma 0xe408 irq 20
    ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    ata3.00: ATA-7: WDC WD800JD-60LSA5, 10.01E03, max UDMA/100
    ata3.00: 156301488 sectors, multi 16: LBA48 
    ata3.00: configured for UDMA/100
    ata4: SATA link down 1.5 Gbps (SStatus 0 SControl 300)
    scsi 2:0:0:0: Direct-Access     ATA      WDC WD800JD-60LS 10.0 PQ: 0 ANSI: 5
    usbcore: registered new interface driver usbfs
    usbcore: registered new interface driver hub
    usbcore: registered new device driver usb
    USB Universal Host Controller Interface driver v3.0
    ACPI: PCI Interrupt 0000:00:10.0[A] -> GSI 21 (level, low) -> IRQ 21
    uhci_hcd 0000:00:10.0: UHCI Host Controller
    uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 1
    uhci_hcd 0000:00:10.0: irq 21, io base 0x0000dc00
    usb usb1: configuration #1 chosen from 1 choice
    hub 1-0:1.0: USB hub found
    hub 1-0:1.0: 2 ports detected
    Driver 'sr' needs updating - please use bus_type methods
    sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
    Uniform CD-ROM driver Revision: 3.20
    sr 0:0:0:0: Attached scsi CD-ROM sr0
    Driver 'sd' needs updating - please use bus_type methods
    sr1: scsi3-mmc drive: 52x/52x writer cd/rw xa/form2 cdda tray
    sr 0:0:1:0: Attached scsi CD-ROM sr1
    sd 1:0:0:0: [sda] 156301488 512-byte hardware sectors (80026 MB)
    sd 1:0:0:0: [sda] Write Protect is off
    sd 1:0:0:0: [sda] Mode Sense: 00 3a 00 00
    sd 1:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    sd 1:0:0:0: [sda] 156301488 512-byte hardware sectors (80026 MB)
    sd 1:0:0:0: [sda] Write Protect is off
    sd 1:0:0:0: [sda] Mode Sense: 00 3a 00 00
    sd 1:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
     sda: sda1 sda2 sda3 sda4
    sd 1:0:0:0: [sda] Attached SCSI disk
    sd 2:0:0:0: [sdb] 156301488 512-byte hardware sectors (80026 MB)
    sd 2:0:0:0: [sdb] Write Protect is off
    sd 2:0:0:0: [sdb] Mode Sense: 00 3a 00 00
    sd 2:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    sd 2:0:0:0: [sdb] 156301488 512-byte hardware sectors (80026 MB)
    sd 2:0:0:0: [sdb] Write Protect is off
    sd 2:0:0:0: [sdb] Mode Sense: 00 3a 00 00
    sd 2:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
     sdb: sdb1 sdb2 < sdb5 >
    sd 2:0:0:0: [sdb] Attached SCSI disk
    ACPI: PCI Interrupt 0000:00:10.4[C] -> GSI 21 (level, low) -> IRQ 21
    ehci_hcd 0000:00:10.4: EHCI Host Controller
    ehci_hcd 0000:00:10.4: new USB bus registered, assigned bus number 2
    ehci_hcd 0000:00:10.4: irq 21, io mem 0xf7ff7c00
    ehci_hcd 0000:00:10.4: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
    usb usb2: configuration #1 chosen from 1 choice
    hub 2-0:1.0: USB hub found
    hub 2-0:1.0: 8 ports detected
    ACPI: PCI Interrupt 0000:00:10.1[A] -> GSI 21 (level, low) -> IRQ 21
    uhci_hcd 0000:00:10.1: UHCI Host Controller
    uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 3
    uhci_hcd 0000:00:10.1: irq 21, io base 0x0000d880
    usb usb3: configuration #1 chosen from 1 choice
    hub 3-0:1.0: USB hub found
    hub 3-0:1.0: 2 ports detected
    ACPI: PCI Interrupt 0000:00:10.2[b] -> GSI 21 (level, low) -> IRQ 21
    uhci_hcd 0000:00:10.2: UHCI Host Controller
    uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 4
    uhci_hcd 0000:00:10.2: irq 21, io base 0x0000d800
    usb usb4: configuration #1 chosen from 1 choice
    hub 4-0:1.0: USB hub found
    hub 4-0:1.0: 2 ports detected
    ACPI: PCI Interrupt 0000:00:10.3[b] -> GSI 21 (level, low) -> IRQ 21
    uhci_hcd 0000:00:10.3: UHCI Host Controller
    uhci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 5
    uhci_hcd 0000:00:10.3: irq 21, io base 0x0000d480
    usb usb5: configuration #1 chosen from 1 choice
    hub 5-0:1.0: USB hub found
    hub 5-0:1.0: 2 ports detected
    hub 2-0:1.0: unable to enumerate USB device on port 2
    kjournald starting.  Commit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    usb 1-2: new full speed USB device using uhci_hcd and address 2
    rtc_cmos 00:02: rtc core: registered rtc_cmos as rtc0
    rtc0: alarms up to one year, y3k
    usb 1-2: configuration #1 chosen from 1 choice
    via-rhine.c:v1.10-LK1.4.3 2007-03-06 Written by Donald Becker
    ACPI: PCI Interrupt 0000:00:12.0[A] -> GSI 23 (level, low) -> IRQ 23
    eth0: VIA Rhine II at 0x1ee00, 00:16:ec:d7:33:31, IRQ 23.
    eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
    ACPI: PCI Interrupt 0000:00:11.5[C] -> GSI 22 (level, low) -> IRQ 22
    PCI: Setting latency timer of device 0000:00:11.5 to 64
    input: Power Button (FF) as /class/input/input2
    ACPI: Power Button (FF) [PWRF]
    input: Sleep Button (CM) as /class/input/input3
    ACPI: Sleep Button (CM) [SLPB]
    input: Power Button (CM) as /class/input/input4
    ACPI: Power Button (CM) [PWRB]
    ACPI: ACPI0007:00 is registered as cooling_device0
    ACPI: Processor [CPU1] (supports 16 throttling states)
    ACPI: ACPI0007:01 is registered as cooling_device1
    ACPI: Processor [CPU2] (supports 16 throttling states)
    sr 0:0:0:0: Attached scsi generic sg0 type 5
    sr 0:0:1:0: Attached scsi generic sg1 type 5
    sd 1:0:0:0: Attached scsi generic sg2 type 0
    sd 2:0:0:0: Attached scsi generic sg3 type 0
    agpgart: Detected VIA VT3314 chipset
    agpgart: AGP aperture is 64M @ 0xf8000000
    pci_hotplug: PCI Hot Plug PCI Core version: 0.5
    shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
    ACPI: PCI Interrupt 0000:00:09.0[A] -> GSI 17 (level, low) -> IRQ 17
    PCI: Disallowing DAC for device 0000:00:09.0
    phy0: Selected rate control algorithm 'pid'
    nvidia: module license 'NVIDIA' taints kernel.
    input: PC Speaker as /class/input/input5
    lp: driver loaded but no devices found
    usbcore: registered new interface driver hiddev
    input: Logitech USB Gaming Mouse as /class/input/input6
    PPP generic driver version 2.4.2
    input,hidraw0: USB HID v1.11 Mouse [Logitech USB Gaming Mouse] on usb-0000:00:10.0-2
    hiddev0hidraw1: USB HID v1.11 Device [Logitech USB Gaming Mouse] on usb-0000:00:10.0-2
    usbcore: registered new interface driver usbhid
    drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
    ppdev: user-space parallel port driver
    rt61: 1.1.0 CVS 2008061023 http://rt2x00.serialmonkey.com
    IT8705 SuperIO detected.
    parport_pc 00:07: reported by Plug and Play ACPI
    parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
    ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
    NVRM: loading NVIDIA UNIX x86_64 Kernel Module  169.12  Thu Feb 14 17:51:09 PST 2008
    lp0: using parport0 (interrupt-driven).
    EXT3 FS on sda3, internal journal
    kjournald starting.  Commit interval 5 seconds
    EXT3 FS on sda4, internal journal
    EXT3-fs: mounted filesystem with ordered data mode.
    Adding 530136k swap on /dev/sda2.  Priority:-1 extents:1 across:530136k
    eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
    agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
    agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode
    NVRM: bad caching on address 0xffff81003e050000: actual 0x173 != expected 0x17b
    NVRM: please see the README section on Cache Aliasing for more information
    NET: Registered protocol family 10
    lo: Disabled Privacy Extensions
    eth0: no IPv6 routers present
    npviewer.bin[3423]: segfault at 4 ip f7b800da sp ff8c9b30 error 4 in libgobject-2.0.so.0.1600.3[f7b73000+38000]
    npviewer.bin[3443]: segfault at 1 ip f7afc61b sp ff9b3800 error 4<6>npviewer.bin[3460]: segfault at 1 ip f7afc61b sp f5c5fc20 error 4 in libglib-2.0.so.0.1600.3[f7aa5000+b3000] in libglib-2.0.so.0.1600.3[f7aa5000+b3000]
    
    npviewer.bin[3480]: segfault at f77dee68 ip f7ae04c5 sp f5c42be0 error 7 in libglib-2.0.so.0.1600.3[f7a88000+b3000]
    npviewer.bin[3500]: segfault at f7743efa ip f7a454c5 sp f5ba7ca0 error 7 in libglib-2.0.so.0.1600.3[f79ed000+b3000]
    npviewer.bin[3547]: segfault at f77efecb ip f7af14c5 sp f5c53ca0 error 7<6>npviewer.bin[3530]: segfault at 74646977 ip f7af061b sp fffa7df0 error 4 in libglib-2.0.so.0.1600.3[f7a99000+b3000]
     in libglib-2.0.so.0.1600.3[f7a99000+b3000]
    npviewer.bin[3762]: segfault at 36 ip f7b0a61b sp f5c6dcf0 error 4<6>npviewer.bin[3745]: segfault at 633eae18 ip f7809f77 sp ffcc3a8c error 6 in libglib-2.0.so.0.1600.3[f7ab3000+b3000]
     in libgdk_pixbuf-2.0.so.0.1200.9[f77f4000+19000]
    npviewer.bin[3799]: segfault at f774ce68 ip f7a4e4c5 sp f5bb0ca0 error 7<6>npviewer.bin[3782]: segfault at 6f6c6f63 ip f7a4d61b sp fff07550 error 4 in libglib-2.0.so.0.1600.3[f79f6000+b3000]
     in libglib-2.0.so.0.1600.3[f79f6000+b3000]
    npviewer.bin[4127]: segfault at 7265702d ip f7a54667 sp f5bd8d78 error 4 in libglib-2.0.so.0.1600.3[f7a1e000+b3000]
    npviewer.bin[4147]: segfault at 90c35d00 ip f7ba0789 sp f5c7ed30 error 4 in libgobject-2.0.so.0.1600.3[f7b7c000+38000]
    npviewer.bin[4167]: segfault at e8f85d89 ip f7b69789 sp f5c47d30 error 4 in libgobject-2.0.so.0.1600.3[f7b45000+38000]
    npviewer.bin[4170]: segfault at e8f85d89 ip f7bae789 sp ffce1440 error 4 in libgobject-2.0.so.0.1600.3[f7b8a000+38000]
    npviewer.bin[4207]: segfault at 36 ip f7b0a44a sp f5bfad60 error 4 in libgobject-2.0.so.0.1600.3[f7af8000+38000]
    npviewer.bin[4210]: segfault at 1 ip f7b57b16 sp ff89e850 error 4 in libgobject-2.0.so.0.1600.3[f7b48000+38000]
    npviewer.bin[4231]: segfault at 1 ip f7ad561b sp fff8cdd0 error 4<6>npviewer.bin[4248]: segfault at 1 ip f7ad561b sp f5c38c20 error 4 in libglib-2.0.so.0.1600.3[f7a7e000+b3000] in libglib-2.0.so.0.1600.3[f7a7e000+b3000]
    
    npviewer.bin[4251]: segfault at 1 ip f7af361b sp ffbac9f0 error 4<6>npviewer.bin[4268]: segfault at 1 ip f7af361b sp f5c56c20 error 4 in libglib-2.0.so.0.1600.3[f7a9c000+b3000]
     in libglib-2.0.so.0.1600.3[f7a9c000+b3000]
    npviewer.bin[4305]: segfault at 65480068 ip f7a78667 sp ff9525e8 error 4 in libglib-2.0.so.0.1600.3[f7a42000+b3000]
    ADDRCONF(NETDEV_UP): wlan0: link is not ready
    eth0: link down
    wlan0: Initial auth_alg=0
    wlan0: authenticate with AP 00:12:17:0a:18:eb
    wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
    wlan0: RX authentication from 00:12:17:0a:18:eb (alg=0 transaction=2 status=0)
    wlan0: authenticated
    wlan0: associate with AP 00:12:17:0a:18:eb
    wlan0: RX AssocResp from 00:12:17:0a:18:eb (capab=0x431 status=0 aid=1)
    wlan0: associated
    ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    wlan0: no IPv6 routers present
    wlan0: Initial auth_alg=0
    wlan0: authenticate with AP 00:12:17:0a:18:eb
    wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
    wlan0: RX authentication from 00:12:17:0a:18:eb (alg=0 transaction=2 status=0)
    wlan0: authenticated
    wlan0: associate with AP 00:12:17:0a:18:eb
    wlan0: mismatch in privacy configuration and mixed-cell disabled - abort association
    wlan0: Initial auth_alg=0
    wlan0: authenticate with AP 00:12:17:0a:18:eb
    wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
    wlan0: RX authentication from 00:12:17:0a:18:eb (alg=0 transaction=2 status=0)
    wlan0: authenticated
    wlan0: associate with AP 00:12:17:0a:18:eb
    wlan0: mismatch in privacy configuration and mixed-cell disabled - abort association
    wlan0: Initial auth_alg=0
    wlan0: authenticate with AP 00:12:17:0a:18:eb
    wlan0: RX authentication from 00:12:17:0a:18:eb (alg=0 transaction=2 status=0)
    wlan0: authenticated
    wlan0: associate with AP 00:12:17:0a:18:eb
    wlan0: mismatch in privacy configuration and mixed-cell disabled - abort association
    wlan0: Initial auth_alg=0
    wlan0: authenticate with AP 00:12:17:0a:18:eb
    wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
    wlan0: RX authentication from 00:12:17:0a:18:eb (alg=0 transaction=2 status=0)
    wlan0: authenticated
    wlan0: associate with AP 00:12:17:0a:18:eb
    wlan0: mismatch in privacy configuration and mixed-cell disabled - abort association
    wlan0: Initial auth_alg=0
    wlan0: authenticate with AP 00:12:17:0a:18:eb
    wlan0: RX authentication from 00:12:17:0a:18:eb (alg=0 transaction=2 status=0)
    wlan0: authenticated
    wlan0: associate with AP 00:12:17:0a:18:eb
    wlan0: mismatch in privacy configuration and mixed-cell disabled - abort association
    eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    UDF-fs: No VRS found
    ISO 9660 Extensions: Microsoft Joliet Level 3
    ISOFS: changing to secondary root
    npviewer.bin[5660]: segfault at 36 ip f7ac561b sp ffb7d290 error 4<6>npviewer.bin[5677]: segfault at 59350168 ip f77c4f77 sp f5c28d7c error 6 in libgdk_pixbuf-2.0.so.0.1200.9[f77af000+19000]
     in libglib-2.0.so.0.1600.3[f7a6e000+b3000]
    npviewer.bin[6077]: segfault at f7838efe ip f7b18cfd sp ffdf3590 error 7<6>npviewer.bin[6094]: segfault at 65786970 ip f78af4b8 sp f5c9cc8c error 4 in libc-2.7.so[f783e000+13a000] in libglib-2.0.so.0.1600.3[f7ae2000+b3000]
    
    npviewer.bin[6515]: segfault at 1 ip f7ac2ac7 sp ffc75b74 error 4 in libglib-2.0.so.0.1600.3[f7a67000+b3000]
    npviewer.bin[6552]: segfault at ffffffec ip f7ba89e6 sp f5c9bd80 error 6 in libgobject-2.0.so.0.1600.3[f7b99000+38000]
    npviewer.bin[6555]: segfault at 36 ip f7a6261b sp fff19e30 error 4 in libglib-2.0.so.0.1600.3[f7a0b000+b3000]
    UDF-fs: No VRS found
    ISO 9660 Extensions: Microsoft Joliet Level 3
    ISOFS: changing to secondary root
    eth0: link down
    eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    npviewer.bin[6990]: segfault at f77dae68 ip f7adc4c5 sp ffe92d60 error 7<6>npviewer.bin[7007]: segfault at 6f6c6f63 ip f7adfac7 sp f5c3ecd4 error 4 in libglib-2.0.so.0.1600.3[f7a84000+b3000]
     in libglib-2.0.so.0.1600.3[f7a84000+b3000]
    npviewer.bin[7027]: segfault at 558b18ec ip f7ad2667 sp f5c56d78 error 4 in libglib-2.0.so.0.1600.3[f7a9c000+b3000]
    kjournald starting.  Commit interval 5 seconds
    EXT3 FS on sdb1, internal journal
    EXT3-fs: mounted filesystem with ordered data mode.
    wlan0: Initial auth_alg=0
    wlan0: authenticate with AP 00:12:17:0a:18:eb
    wlan0: RX authentication from 00:12:17:0a:18:eb (alg=0 transaction=2 status=0)
    wlan0: authenticated
    wlan0: associate with AP 00:12:17:0a:18:eb
    wlan0: mismatch in privacy configuration and mixed-cell disabled - abort association
    eth0: link down
    eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    npviewer.bin[7681]: segfault at 10004 ip f7a89d0e sp f5c0dd70 error 6 in libglib-2.0.so.0.1600.3[f7a53000+b3000]
    npviewer.bin[8881]: segfault at f7781efe ip f7a61cfd sp f5be5d70 error 7 in libglib-2.0.so.0.1600.3[f7a2b000+b3000]
    npviewer.bin[8864]: segfault at 65786970 ip f7a86ac7 sp fff3c634 error 4 in libglib-2.0.so.0.1600.3[f7a2b000+b3000]
    npviewer.bin[8901]: segfault at f7800efe ip f7ae0cfd sp f5c64d70 error 7<6>npviewer.bin[8884]: segfault at 65786970 ip f7b0161b sp ffbbae10 error 4 in libglib-2.0.so.0.1600.3[f7aaa000+b3000] in libglib-2.0.so.0.1600.3[f7aaa000+b3000]
    
    npviewer.bin[8904]: segfault at 36 ip f7b1c61b sp fffd66f0 error 4<6>npviewer.bin[8921] general protection ip:f781bf36 sp:f5c7fd7c error:0 in libgdk_pixbuf-2.0.so.0.1200.9[f7806000+19000] in libglib-2.0.so.0.1600.3[f7ac5000+b3000]
    Quote Originally Posted by tuxxin
    Quote Originally Posted by zouzou85
    EDIT: i did some research and it seems that your card should work perfectly with linux because the ralink driver is fully integrated with the linux kernel.
    try installing wicd. It will simplify your search.
    ArchWiki :: Wicd - ArchWiki
    Ya, that's what I thought. I read somewhere before I bought it that the drivers are intergrated into the linux kernel.
    I tried using the tool you suggested, but it still doesn't work. It says I am connected, but I don't obtain an ip. Setting a static ip doesn't help either
    Quote Originally Posted by zouzou85

    wlan0: associate with AP 00:12:17:0a:18:eb
    wlan0: mismatch in privacy configuration and mixed-cell disabled - abort association

    This seems to be the problem.
    try doing:
    Code:

    # modprobe -r r61

    Code:

    # modprobe r61

    then post:
    Code:

    $ dmesg |tail

    to see if the driver loaded as it should.
    Quote Originally Posted by tuxxin
    Code:
    dmesg |tail
    wlan0: authenticate with AP 00:12:17:0a:18:eb
    wlan0: RX authentication from 00:12:17:0a:18:eb (alg=0 transaction=2 status=13)
    wlan0: AP denied authentication (auth_alg=0 code=13)
    wlan0: authenticate with AP 00:12:17:0a:18:eb
    wlan0: RX authentication from 00:12:17:0a:18:eb (alg=0 transaction=2 status=13)
    wlan0: AP denied authentication (auth_alg=0 code=13)
    wlan0: authenticate with AP 00:12:17:0a:18:eb
    wlan0: RX authentication from 00:12:17:0a:18:eb (alg=0 transaction=2 status=13)
    wlan0: AP denied authentication (auth_alg=0 code=13)
    wlan0: authentication with AP 00:12:17:0a:18:eb timed out
    Quote Originally Posted by zouzou85
    Did you install the driver using pacman or you are using the in-kernel driver?
    Quote Originally Posted by tuxxin
    No, I didn't install the driver with pacman.
    Quote Originally Posted by zouzou85

    do you have rt2x00-rt61-fw installed?

    Code:

    # pacman -Q rt2x00-rt61-fw

    if not do :
    Code:

    # pacman -S rt2x00-rt61-fw

    also post:

    Code:

    # lsmod |grep rt

    Last edited by zouzou85 (Today 14:25:46)
    Quote Originally Posted by tuxxin
    Code:
     lsmod |grep rt
    rt61                  220424  0 
    rt2500                208872  0 
    rt2500pci              19840  0 
    parport_pc             39624  1 
    parport                38064  3 parport_pc,ppdev,lp
    rt61pci                24576  0 
    rt2x00pci               9472  2 rt2500pci,rt61pci
    rt2x00lib              22784  3 rt2500pci,rt61pci,rt2x00pci
    rfkill                  7712  1 rt2x00lib
    input_polldev           4624  1 rt2x00lib
    crc_itu_t               2688  1 rt2x00lib
    mac80211              146316  2 rt2x00pci,rt2x00lib
    eeprom_93cx6            2944  2 rt2500pci,rt61pci
    gameport               13200  1 snd_via82xx
    snd_mpu401_uart         8704  1 snd_via82xx
    snd_rawmidi            23936  1 snd_mpu401_uart
    snd                    61000  15 snd_via82xx,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
    rtc_cmos               10552  0 
    rtc_core               19268  1 rtc_cmos
    rtc_lib                 3456  1 rtc_core
    Any ideas? I have to move this tower tonight, so I would like to get this working before then.

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    According to the last lsmod you posted, it looks like you have a duplicate or conflicting module loaded. I believe that the rt61 and rt61pci are different drivers. If I recall correctly, the rt61pci is the native kernel driver. The rt61 is a driver that you compile and add seperately. You may want to remove both of them, and then re-add the one that you want. My guess is the rt61, since it was added later.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! TuxXin's Avatar
    Join Date
    Apr 2008
    Posts
    23
    It's working now. It turns out the driver didn't work. A friend suggested that I install the latest from CVS. I then followed your advise, and removed rt61pci. It's working flawlessly now. I just need to do this on my secondary distro now... :S

    Thanks for the advise

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •