Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Can't connect to the net but card works

    I've been trying to get the wireless connection working for a couple of days now. I've learned a bunch of new things but something gets missed (or messed) in my efforts. Below are some details of my system.

    Computer: IBM ThinkPad 390E
    Wifi card: EDUP 54Mbps/11Mbps PCMCIA card. It has the Ralink RT2500 chip.
    Linux distribution: Damn Small Linux 4.2.5
    Linux kernel: 2.4.31
    Wifi connection type: WEP-encrypted.

    I'm using ndiswrapper for setting up the wifi connection. OK, let's start.
    # ndiswrapper -i /mnt/auto/cdrom/Drivers/Rt2500.INF

    Installs okay and checking with "ndiswrapper -l" it lists it (rt2500: driver installed, hardware present).

    # depmod -a
    # modprobe ndiswrapper

    No errors here, everything goes well.
    Now iwconfig lists the connection wlan0.

    Then I search available Wifi access points using
    # iwlist wlan0 scan
    It outputs a list of APs in a second or so, so it works there flawlessly. Then I attach my WEP-encrypted AP into my wlan0 connection using
    # iwconfig wlan0 essid MY_ESSID key s:MY_KEY

    When I check with iwconfig, the wlan0 connection is attached with my essid.
    After that I give the command
    # ifconfig wlan0 up

    # ifconfig dhclient wlan0

    # ifconfig dhcpcd wlan0

    After that I'm trying the command
    # route
    But it lists no routes.
    Then I tried to enter the command
    # route add default gateway
    The gateway address is taken from my other Linux computer which uses LAN network (used the command route -nee). Well, it outputs this:
    route: SIOC[ADD|DEL]RT: Network is unreachable

    I've checked my /etc/resolv.conf file, it's identical to the one on the LAN machine, like is the /etc/network/interfaces file as well.

    So the card works without a doubt as it can find the APs, but it's not connecting onto the internet. If you have any suggestions of what I should check, please tell me. I'm getting pretty desperate on this.

  2. #2
    Problem solved: don't use ifconfig dhclient wlan0 on Knoppix-based systems, but

    # pump -i wlan0

    That did the trick

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts