Find the answer to your Linux question:
Results 1 to 8 of 8
hi 1st of all i m APPSDBA,i have a network configuration problem @ my work station . i have a one m/c in that i install XP and Linux AS4 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    9

    Unhappy WLAN prob


    hi
    1st of all i m APPSDBA,i have a network configuration problem @ my work station .
    i have a one m/c in that i install XP and Linux AS4 means dual boot.there we r using wireless local area network(using Netgear).

    issue : using XP i can communicate with other machines and i can access the internet also. while i boot into Linux i cant communicate !
    so i tried to configure the network like
    i gave host name @ ]# vi /etc/hosts
    and ]# vi /etc/sysconfig/network-scripts/eth0 (for local WLAN)
    and said ]# service network restart (every thing "ok" here)
    after this i gave ]# ifconfig
    it just showing 127.0.0.1 and some stuff(that i dont know wat those 4 or 5 lines).
    really i shock while i saw it. network saying okey but its not showing IP.

    for XP its fine then wat happen to my Linux(i m not etting wats the prob).

    my system configuration is:
    ==>cpu 2.2 core 2 DUO
    ==>CABINET ATX WITH SMPS
    ==>MBD GIGA BYTE 31
    ==>LAN CARD Wireless Netgear.

    i m not sure wat i m giving the info about netgear but i m giving the thing wat was on bill(while purchase it).
    Netgear - 'WG311-V3'
    54mbps - wirelss
    pci adpater, 32bit pci

    And i m giving some system information [According to that plz suggest me wat to do for this Prob]

    [root@localhost sbin]# ifconfig -a
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1866 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1866 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:1980638 (1.8 MiB) TX bytes:1980638 (1.8 MiB)

    sit0 Link encap:IPv6-in-IPv4
    NOARP MTU:1480 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    [root@localhost sbin]# iwconfig
    lo no wireless extensions.

    sit0 no wireless extensions.

    [root@localhost sbin]# cat /etc/sysconfig/network
    NETWORKING=yes
    HOSTNAME=localhost.localdomain

    [root@localhost network-scripts]# cat /etc/sysconfig/network-scripts/ifcfg-eth0 DEVICE=eth0
    ONBOOT=yes
    BOOTPROTO=static
    IPADDR=192.168.2.98
    NETMASK=255.255.255.0

    [root@localhost sbin]# lsmod
    Module Size Used by
    parport_pc 27905 1
    lp 15405 0
    parport 37641 2 parport_pc,lp
    autofs4 22085 0
    i2c_dev 14273 0
    i2c_core 25921 1 i2c_dev
    sunrpc 137637 1
    dm_mod 57157 0
    button 10449 0
    battery 12869 0
    ac 8773 0
    md5 8001 1
    ipv6 238817 10
    uhci_hcd 32729 0
    ehci_hcd 31813 0
    floppy 58065 0
    ext3 118473 3
    jbd 59481 1 ext3

    [root@localhost sbin]# lspci
    00:00.0 Host bridge: Intel Corp.: Unknown device 29c0 (rev 02)
    00:02.0 VGA compatible controller: Intel Corp.: Unknown device 29c2 (rev 02)
    00:1b.0 Class 0403: Intel Corp.: Unknown device 27d8 (rev 01)
    00:1c.0 PCI bridge: Intel Corp.: Unknown device 27d0 (rev 01)
    00:1c.1 PCI bridge: Intel Corp.: Unknown device 27d2 (rev 01)
    00:1d.0 USB Controller: Intel Corp.: Unknown device 27c8 (rev 01)
    00:1d.1 USB Controller: Intel Corp.: Unknown device 27c9 (rev 01)
    00:1d.2 USB Controller: Intel Corp.: Unknown device 27ca (rev 01)
    00:1d.3 USB Controller: Intel Corp.: Unknown device 27cb (rev 01)
    00:1d.7 USB Controller: Intel Corp.: Unknown device 27cc (rev 01)
    00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev e1)
    00:1f.0 ISA bridge: Intel Corp.: Unknown device 27b8 (rev 01)
    00:1f.2 IDE interface: Intel Corp.: Unknown device 27c0 (rev 01)
    00:1f.3 SMBus: Intel Corp.: Unknown device 27da (rev 01)
    02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.: Unknown device 8168 (rev 02)
    03:00.0 Ethernet controller: Marvell Technology Group Ltd.: Unknown device 1faa (rev 03)

    [root@localhost sbin]# cat /etc/modprobe.conf
    alias usb-controller ehci-hcd
    alias usb-controller1 uhci-hcd

    [root@localhost etc]# cat /etc/modprobe.d/blacklist
    cat: /etc/modprobe.d/blacklist: No such file or directory

    [root@localhost etc]# uname -r
    2.6.9-5.ELsmp

    [root@localhost etc]# getconfig kernel_bits
    getconfig.pl: Version 1.0.
    getconfig.pl: Xorg Version: .
    getconfig.pl: 23 built-in rules.
    getconfig.pl: Evaluated 23 rules with 0 errors.
    getconfig.pl: Weight of result is 0.


    hope this info is enough to analyze this prob and to give the solution.

  2. #2
    Linux Enthusiast deltaflyer's Avatar
    Join Date
    May 2005
    Posts
    577
    hmm, that device isn't well supported as it has the Marvell chip-set. your best bet would be to use ndiswrapper
    SLOMO: acer extensa 5235 2.2ghz,2gb ram 160gb hdd wireless
    SPEEDY: homebrew desktop,Amd x2 dualcore,2gb ram,500gb +1tb( 2x500gb) hdd suse 11.3,32mb fibreline
    registered linux user #401845

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    9
    okey i will try to install ndiswrapper soon, if works fine okey, if not will get back to u !

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Your lspci output shows a lot of "Unknown device" tags, too many for my liking. This could be from either using very new hardware, or very old Linux. Since you are running a 2.6.9-5.ELsmp kernel, I would suspect that this would be part of the problem.

    The Linux kernel is constantly evolving to improve it, and to add hardware support. I would recommend that you upgrade to a newer kernel. This can be done using third party repositories, here are two:
    ATrpms
    AdditionalResources/Repositories/CentOSPlus - CentOS Wiki

    You could also download the kernel sources and compile them yourself. If you are trying to learn about Linux, this is a good lesson to learn.
    The Linux Kernel Archives

    The link for the latest stable version is only a patch. I would get the full sources from here, using the linux-2.6.xx title:
    ftp://ftp.kernel.org/pub/linux/kernel/v2.6
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Jul 2008
    Posts
    9
    i m going to upgarade my kernel could u plz tell me the next steps to bring my linux box in to wireless LAN.

    plz respond as soon as u can...

  7. #6
    Just Joined!
    Join Date
    Jul 2008
    Posts
    9
    hi paul
    i download latest kernel version 4m the link.
    it was in .bz2 from
    i tried to unzip with
    ]# bunzip2 patch-2.6.25.10.bz2
    its giving me error.
    i means some 4 lines are coming.
    i think its(kernel version which i downloaded) not sutable for this AS4could u sujest me the Right steps for me , and also give me the next steps to bring this box in to WLAN.

  8. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It seems that you may not be able to upgrade to a newer kernel, as you have found. I looked through the kernels available from the CentOSPlus repository, and the newest one is 2.6.9-67. This most likely is not new enough.

    Mu recommendation is to install a newer version of Linux. If you need to use Red Hat Enterprise, CentOS 5 is a clone of RHEL 5. Even then wireless may not work, because RHEL is meant to be for servers, and severs usually don't need wireless. So you would then need to enable the CentOSPlus repository, and upgrade the kernel with a plus kernel.

    If you don't need RHEL, you could use Red Hat Fedora Linux 9. It is similar to RHEL, but a newer version can be downloaded for free. It also has a much more enhanced kernel, with almost everything enabled in it as modules. Wireless is much easier to get running on this.

    If you must use the version that you have installed, there is one other possibility. You can do as deltaflyer suggested, use NDISwrapper. It will use the WindowsXP driver to enable the wireless card in Linux. It can be installed using the ATrpms repository that I linked to in my previous post. Add it to the list of repositories that are currently enabled in your distro. I don't know what AS4 uses, but it may be YUM, Use the installation instructions found HERE. Replace the Fedora Core name with your distro's name.
    Code:
    yum: Make sure the following lines are included in /etc/yum.conf:
        
        [atrpms]
        name=Red Hat Enterprise Linux $releasever - $basearch - ATrpms
        baseurl=http://dl.atrpms.net/el4-i386/atrpms//stable
        gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms
        gpgcheck=1
    I modified it for you, see if it will work.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I see that the ATrpms repository doesn't have NDISwrapper for your kernel version, so you may still run into problems.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •