Find the answer to your Linux question:
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 33
It is possible that Mepis identified your wireless and then selected NDISwrapper for the driver. NDISwrapper uses the WinXP driver to make the wireless work. This is done if no ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    It is possible that Mepis identified your wireless and then selected NDISwrapper for the driver. NDISwrapper uses the WinXP driver to make the wireless work. This is done if no decent Linux driver is available. You could try it first, but you need a working WinXP driver first.

    If you are not going to use NDISwrapper, you at least have to remove the module:
    Code:
    modprobe -r ndiswrapper
    Then to prevent it from loading at boot, you have to blacklist it. I don't know how to do this in Mepis, but in Fedora you add it to thr blacklist file in /etc/modprobe.d/blacklist.
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #12
    Just Joined!
    Join Date
    Jul 2008
    Posts
    18
    Quote Originally Posted by waterhead View Post
    If you want to try and run the install, then do this:

    Change the terminal window to the folder that the makedrv file is in. To do this you use the cd (change directory) command.
    Code:
    cd /path/to/file
    To install something like a driver, you need root privileges. This is usually done with the su (super user) command.
    Code:
    su <enter>
    Password: <enter root password>
    You then should be able to run the makedrv script by entering this command:
    Code:
    ./makedrv
    If all goes well, you can run the other scripts listed in the README file the same way.
    Okay, I got the terminal window to the right folder, here is the script from running the ./makedrv command:

    HTML Code:
    ./ieee80211/
    ./ieee80211/ieee80211_module.c
    ./ieee80211/ieee80211_rx.c
    ./ieee80211/tags
    ./ieee80211/Makefile
    ./ieee80211/ieee80211_crypt_tkip.c
    ./ieee80211/ieee80211_softmac.c
    ./ieee80211/readme
    ./ieee80211/ieee80211_crypt_ccmp.c
    ./ieee80211/ieee80211.h
    ./ieee80211/ieee80211_tx.c
    ./ieee80211/ieee80211_softmac_wx.c
    ./ieee80211/ieee80211_crypt.h
    ./ieee80211/ieee80211_wx.c
    ./ieee80211/license
    ./ieee80211/ieee80211_crypt_wep.c
    ./ieee80211/ieee80211_crypt.c
    rtl8185/
    rtl8185/README.adhoc
    rtl8185/r8180_sa2400.h
    rtl8185/Makefile
    rtl8185/copying
    rtl8185/README.master
    rtl8185/r8180.h
    rtl8185/install
    rtl8185/r8180_max2820.h
    rtl8185/r8180_max2820.c
    rtl8185/r8180_rtl8225.h
    rtl8185/r8180_wx.h
    rtl8185/authors
    rtl8185/tags
    rtl8185/r8180_pm.c
    rtl8185/r8180_hw.h
    rtl8185/r8180_gct.c
    rtl8185/r8180_gct.h
    rtl8185/r8180_rtl8225.c
    rtl8185/readme
    rtl8185/r8180_93cx6.h
    rtl8185/ieee80211.h
    rtl8185/license
    rtl8185/r8180_pm.h
    rtl8185/changes
    rtl8185/r8180_rtl8225z2.c
    rtl8185/r8180_wx.c
    rtl8185/r8180_rtl8255.c
    rtl8185/r8180_93cx6.c
    rtl8185/r8180_sa2400.c
    rtl8185/r8180_core.c
    rtl8185/r8180_rtl8255.h
    rtl8185/ieee80211_crypt.h
    rm -f *.mod.c *.mod *.o .*.cmd *.ko
    rm -rf /home/luketoney/rtl8185_linux_26.1027.0823.2007/ieee80211/tmp
    make -C /lib/modules/2.6.22-1-mepis64-smp/build M=/home/luketoney/rtl8185_linux_26.1027.0823.2007/ieee80211 CC=gcc modules
    make: *** /lib/modules/2.6.22-1-mepis64-smp/build: No such file or directory.  Stop.
    make: *** [modules] Error 2
    rm -f *.mod.c *.mod *.o .*.cmd *.ko *~
    rm -rf /home/luketoney/rtl8185_linux_26.1027.0823.2007/rtl8185/tmp
    make -C /lib/modules/2.6.22-1-mepis64-smp/build M=/home/luketoney/rtl8185_linux_26.1027.0823.2007/rtl8185 CC=gcc modules
    make: *** /lib/modules/2.6.22-1-mepis64-smp/build: No such file or directory.  Stop.
    make: *** [modules] Error 2

  3. #13
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It seems like it is looking for the kernel sources. I mentioned in my first post that you would need it to compile driver modules.

    It may be available on your Mepis installation CD. If it isn't on there, I don't know where you can get it. If you really have version 5, then you may be stuck. I don't see anything for that version anywhere.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Jul 2008
    Posts
    18
    Quote Originally Posted by waterhead View Post
    It seems like it is looking for the kernel sources. I mentioned in my first post that you would need it to compile driver modules.

    It may be available on your Mepis installation CD. If it isn't on there, I don't know where you can get it. If you really have version 5, then you may be stuck. I don't see anything for that version anywhere.
    Well Paul,

    I think I'm going to take your advice about getting the latest version of Mepis, but instead of using Mepis I'm going to use Ubuntu. I had refrained from using it because the liveCD version of it could never run properly. However, a full install might do the trick. I have it on hand anyway. I'll be back with a report.

    Thanks a ton for your help. Hopefully, being Ubuntu is all new or whatever, it might have most of this stuff on there already right?

  6. #15
    Just Joined!
    Join Date
    Jul 2008
    Posts
    18
    Fart. I'm having the same trouble with Ubuntu that I had when I tried to use the liveCD to boot. It boots me back out to the username login everytime I enter my login information.

  7. #16
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Did you create a user and password during the install? It seems like you are not entering it correctly. There are ways to add a user or change a password, but you need root privileges for that.

    Try using a non-GUI login. Press the Ctrl+Alt+F1 keys, holding them all down. This will bring up a terminal screen where you can try and log in. Take note of any error message it will give you. You can get back to the GUI login with Ctrl+Alt+F7.

    You can change the password by booting the install CD in rescue (or recovery) mode. I don't have the details for that, though. Ubuntu is kind of weird, in that there is no root. The first user created (during the installation) will have root privileges when using the sudo prefix. It is the major reason that I don't like it.

    Are you trying to log in as root? That won't work in Ubunbtu!

    Two things to check.
    1). Ubuntu won't let you log in if you are out of disk space. Is there room on the hard drive?
    2). Did you re-use your home partition without reformatting it? If you then chose the same username, it won't work because that already exists. You could normally log in as root and create a different user, but not in Ubuntu. You will have to do that using the rescue/recovery mode described above.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #17
    Just Joined!
    Join Date
    Jul 2008
    Posts
    18
    I reformatted the partition when installing. I created a username and password when installing and am 100% positive I am entering that information correctly. Back when I was trying to do this with a liveCD I was asking for help on the Ubuntu forums and a couple of people mentioned a monitor or video driver problem that sometimes occurs, showing itself in this same manner. In most cases this appeared to involve an ATI graphics card, which is, indeed, the brand of on board graphics card on my motherboard.

    I went back to the Ubuntu forums after doing this install to ask for help again and someone said to try logging in using ctrl +alt +f2. When I hit ctrl alt f2 the computer freezes, with a couple of jerky lines showing up along the top of the screen.

    I do not believe this to be a login problem. I'm a linux noob, but I know a little about partitions and the like, can follow installation directions to a T, and can type. It appears to accept the login, I don't get any sort of "bad login" message.

    Be that as it may, I will, Of course, try the things you suggest and post my results. I sincerely appreciate your time and help. Thanks for sticking this out with me!

  9. #18
    Just Joined!
    Join Date
    Jul 2008
    Posts
    18
    ctrl alt f1 = frozen computer screen with broken graphics along the top, just like with ctrl alt f2.

    started up in recovery mode. ran xfix. tried login with incorrect login info, get login error message.

    enter correct login info, appears to accept login, screen goes black, kicks back to login screen, as before.

    Has option to run a root shell command or something in recovery mode. I'll try that.
    Last edited by brakoholic; 07-13-2008 at 05:40 PM. Reason: changed "boot" to "root"

  10. #19
    Just Joined!
    Join Date
    Jul 2008
    Posts
    18
    p.s. not only is the screen frozen, but mouse, keyboard, system as a whole.

  11. #20
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I think that you need to change your video driver to vesa. That is a generic driver that will work most of the time. To do this, you would need to not start the desktop, but run in single user mode. My only Ubuntu install is Mythbuntu, so my directions are derived from that.

    When you boot, there will be a short message about pressing the Esc key to show the menu. When the boot menu comes up, there will be a selection with (recovery mode) at the end. Select this and hit enter.

    Edit: I have created a root account on my system, you may not boot into root.

    This will boot Ubuntu as root, with no login needed. There also is no desktop or GUI loaded. From here you need to edit your xorg.conf file. You will use vi to do it, so I'll give all the commands you need.

    First, make a copy of the xorg.conf file:
    Code:
    cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
    This will back up the file before you make any changes. The "X" in X11 is a capitol letter. Now to edit the file:
    Code:
    vi /etc/X11/xorg.conf
    Arrow down to where you see Section "Device". There should be a subsection titled Driver, with your driver in quotes. I don't know what's there, but it could be "radeon" or something. To change it, arrow over and put the curser under one of the letters, and then hit the "x" key to delete it. Do this until the entire driver is deleted. Now hit the "i" key to insert. Enter "vesa" with quotes, then the Shift+ZZ keys to exit and save the file.

    Now reboot to see if it will work. The resolution for the vesa driver is very low, but if it works, your ahead already.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 2 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •