Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
ok to start ill give a bit of background by friend who used to run linux (hates it) gave me the new Ubuntu and dual booted it with windows XP ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    10

    D-Link Wireless Help


    ok to start ill give a bit of background

    by friend who used to run linux (hates it) gave me the new Ubuntu and dual booted it with windows XP

    ok the weird part.. he installed it and everything worked fine, even the internet

    but now i restarted it and my internet isnt working, he has no idea how to fix it cause he 'doesnt do linux'

    everything is set up correctly and it says i am connected, but when i try to load a web page it just loads for 5min and says it cant connect to the server

    please help me out setting up my D-Link DWL-G510 Wireless G Desktop Adapter

    im new to this whole command line thing so a walk through will be greatly appreciated

    P.S. ive been looking around in this forum for about an hour without any clear help for my issue

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Hi dualbootr and welcome to the forums! Did you try to configure your wireless device through the Ubuntu network configuration utility in your menu first? Does everything look okay there? If not, we might need to do further troubleshooting. Open a terminal and do:
    Code:
    sudo lspci | grep Wireless
    It will ask for your password, so just enter it and presss enter. Copy that line down and post it here please. This will allow us to see the exact card, version and chipset you are running so as to better advise you on what to do next.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    10
    ok ill do that next but first:

    i got an error message that i haven't gotten before and thought it might be useful

    "There was an error starting the GNOME Settings Daemon.

    Some things, such as themes, sounds, or background settings may not work correctly.

    The last error message was: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

    GNOME will still try to restart the Settings Daemon next time you log in."

    i have not restarted linux yet, suspecting that the reason this thing cant run is the internet connection

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2008
    Posts
    10
    ok i went into the terminal and typed exactly what you told me to and each time i entered it and hit enter it would come up blank..

  6. #5
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Judt do:
    Code:
    lspci
    ...and find the line about your D-Link wireless device. Copy it down and post it here please.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  7. #6
    Just Joined!
    Join Date
    Jul 2008
    Posts
    10
    ok did that and got something more confusing.. i have three cards hooked up: one on motherboard (broken), landline, and wireless. but thats not the confusing part, windows says they are called completely different things:

    Linux says:
    00:0e.0 Ethernet controller: Atheros Communications, Inc. AR2413 802.11bg NIC (rev 01)

    00:0f.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)

    00:13.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)
    Windows says:
    Local Area Connection - 3Com EtherLink XL 10/100 PCI TX NIC (3C9 OSB-TX)

    Local Area Connection 2 - ASUSTek/Broadcom 440x 10/100 Integrated Controller
    *The one on the motherboard*

    Wireless Network Connection - D-Link AirPlus G DWL-G510 Wireless PCI Adapter(rev.B)

  8. #7
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    As Linux shows, it is an Atheros based card. Unfortunately, there seems to be problems with the newer MadWifi drivers as seen from this ticket. The ticket is for AR 5413 but read down and see where it is reported that the bug also affects AR 2413. A pity because Atheros cards with the MidwiFi drivers have worked very well (at least for me) for some time. The response from MadWifi is to:
    try to install the madwifi-trunk download it from snapshot and then compile it... make make install depmode -ae modprobe ath_pci

    I've the same chipset and works very very well with this trunk... or try to install a svn version 2834...
    ...or maybe an older version. I believe they'll have this sorted in very short time though. I'd bookmark the ticket and see what happens with it.

    Waterhead is really good with wireless. He'll likely see this thread and might know a way to get it operational that I don't know of. Sorry I couldn't help more...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I don't have a lot of experience with Atheros wireless. I do know that there is a new driver being developed, called ath5k, but it doesn't yet appear to support the ar2413 chip.

    The usual suggestion to get this working is to install the latest version from the madwifi website. But if this has a bug in it, I don't have any suggestions, except maybe to use NDISwrapper.

    NDISwrapper uses the WindowsXP driver for a wireless card, and it seems that others have used it with this card/chipset. You can use the driver that came on the driver CD that came with the wireless.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #9
    Just Joined!
    Join Date
    Jul 2008
    Posts
    10
    thanks you guys this has been great help and a great first experience for me using linux. ill try everything i can and keep ya'll posted on my success

    but if it turns out that i cannot get my card to work, can you suggest a cheap yet effective and easy to install wireless card if i have to buy another?

  11. #10
    Just Joined!
    Join Date
    Jul 2008
    Posts
    10
    omfg it WORKS

    im talking to you in ubuntu!!

    thank you guys so much, its been a pleasure

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •