Find the answer to your Linux question:
Results 1 to 2 of 2
Hi All, I have been trying to solve a puzzle for last 15 odd days. I am using WindRiver Linux. I have ppp connection to send data over GPRS. My ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    5

    HTTP POST request over GPRS doesn't work.


    Hi All,

    I have been trying to solve a puzzle for last 15 odd days. I am using WindRiver Linux.

    I have ppp connection to send data over GPRS.

    My client code has been tested on Ethernet. I mean I can send data using HTTP POST request using the client code. I can get response of HTTP GET request as well.

    The same code works well for the HTTP GET request over the GPRS when the connection is established using PPP.

    The only problem I face is that HTTP POST request doesn't go through. The server even doesn't get the request.(I am using the same PPP connection which used during the HTTP GET request).

    I have checked the HTTP POST request syntax. I believe that it is fine since, I can send the same request over the Ethernet and I get the response from the server.



    In short


    1) HTTP POST AND HTTP GET request over ETHERNET works 100% fine.
    2) HTTP GET request over GPRS works fine.
    3) HTTP POST request over GPRS doesn't work.(Even request doesn't reach to the server).


    I tried most of the debugging. The only difference in HTTP GET and HTTP POST request is the size of the data.

    I know that my cmux protocol (gsm0710) doesn't allow to transmit more than 255 bytes at one shot.

    But the GET request is also greater than 255 bytes (Including TCP/IP header overhead)


    Please recommend anything to fix this.

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    5

    Solved

    It was an ISP who was blocking the traffic. I changed the ISP and it worked fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •