Find the answer to your Linux question:
Results 1 to 9 of 9
I have the same problem. I did go to that site and putin the command: [root@localhost ~]# cvs -z3 -d server:anonymous@cvs.sourceforge.net:/cvsroot/madwifi co madwifi : but I get in return: cvs ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    8

    Atheros AR5212 Card


    I have the same problem.
    I did go to that site and putin the command:
    [root@localhost ~]# cvs -z3 -dserver:anonymous@cvs.sourceforge.net:/cvsroot/madwifi co madwifi
    :

    but I get in return:
    cvs [checkout aborted]: connect to [cvs.sourceforge.net]:2401 failed: No route to host
    What am I doing wrong?
    Last edited by devils casper; 07-28-2008 at 04:33 PM.

  2. #2
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    That seems more like a connection problem.

    Site down? Firewall? Port blocked?.
    Can't tell an OS by it's GUI

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    8
    Dies anyone know of a current connection? I am new in Linux and the command line but it seems to me that that connection send the installation package to the root folder.
    Just downloading the file from sourceforge puts the file in my home folder.
    Yes I have an Atheros AR5212 dard and it says disabled in the lspci command.
    I just upgraded to Fedora 8. I get the internet when directly connected.

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You shouldn't have to install the madwifi driver for this card. It uses the new ath5k driver.

    I am using Fedora 8 with the 2.6.23.14-115.fc8 kernel. The ath5k module is compiled into that kernel. It may already be loaded by default, so look for it in the output of this command:
    Code:
    /sbin/lsmod
    If it isn't there, try loading it with this command (as root):
    Code:
    /sbin/modprobe ath5k
    Read through this site on the ath5k driver:
    ath5k - Linux Wireless

    It says to test it with these commands:
    modprobe ath5k (you did this already)
    sudo ip link set wlan%d up
    sudo iwconfig wlan%d essid any
    # Make sure you get auth'd and then assoc'd
    # Then either set an IP manually or get it via DHCP
    ping gw
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #5
    Just Joined!
    Join Date
    Jul 2008
    Posts
    8
    I did try as root
    /sbin/modprobe ath5k
    and it responded
    Fatal: Module ath... not found
    my kernel is 2.6.21.
    I see this module is included in madwifi. when downloading in the GUI it sends it to my home directory. Can I work with it from there?

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by Ganzalles View Post
    I did try as root and it responded my kernel is 2.6.21.
    I see this module is included in madwifi. when downloading in the GUI it sends it to my home directory. Can I work with it from there?
    ath5k is probably not enabled by default in the Linux kernel. So either you can recompile your kernel to include it or you can compile it from source. But it would be way easier to install madwifi using yum:
    Code:
    yum install madwifi
    You must have Internet connectivity for this to work and be logged in as root.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Quote Originally Posted by MikeTbob View Post
    ath5k is probably not enabled by default in the Linux kernel...
    It is in my Fedora 2.6.23 kernel. This is not the original kernel, but one from an update. It can be installed just as easily with YUM.

    It is always recommended to do an upgrade to a newly installed system. This will take care of any security problems and bugs found after the distro's official release. I don't usually upgrade my system after that. You can update the entire system with this command, it may take a long time to do it, so be patient.
    Code:
    yum -y upgrade
    If this is an older system that has been used and modified, then an upgrade is not recommended. Just install the madwifi drivers with YUM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #8
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by waterhead View Post
    It is in my Fedora 2.6.23 kernel. This is not the original kernel, but one from an update. It can be installed just as easily with YUM.
    Good to know, thanks. I just recompiled a Gentoo kernel and I had to manually enable it, that's why I thought maybe it wasn't enabled by default.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  9. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Ya, I checked the kernel source and saw that it is compiled into it as a module. So even though I don't have that type of wireless, I modprobed ath5k and didn't get any errors. When I checked with lsmod, it was loaded.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •