Find the answer to your Linux question:
Results 1 to 3 of 3
Just wondering if others have run into this issue ... I'm running CentOS 4.6 on a ThinkPad T42 w/ Atheros wireless device. Madwifi driver works very well, but when I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Location
    GMT -8 ; northern hemisphere
    Posts
    3

    iwconfig fails with space in essid


    Just wondering if others have run into this issue ...

    I'm running CentOS 4.6 on a ThinkPad T42 w/ Atheros wireless device.
    Madwifi driver works very well, but when I attempt to configure a connection for an AP that has a space in the essid, iwconfig only uses the first word -- even though both are surrounded by double quotes -- and therefore association fails.

    This occurs always, if I'm attempting the configuration on the command line or via a script (tried a variety of methods to escape/quote the space, to no avail).

    Kernel is 2.6.9-67.0.[15|20|22] & madwifi driver v 0.9.3.3/0.9.4 ... any combination ... makes no difference. Wireless-tools are from installation of wireless-tools-28-0.pre16.3.3.EL4.rpm.

    Any thoughts regarding possible resolution would be most welcome.

    Thanks!

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    When entering something like a file name with a space, into a terminal, you add a backslash before the space. This may be all you need to do.

    For example, a title like this:
    How I Met Your Mother

    Would look like this:
    How\ I\ Met\ Your\ Mother
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Location
    GMT -8 ; northern hemisphere
    Posts
    3
    Paul,

    Thanks -- though the single-backslash-escape was just one of the "... variety of methods to escape/quote the space ..." to which I referred, and results in the same response ... including an error message that seems to indicate the second parameter to the essid argument is being parsed (due to the whitespace) as another (unrecognized) argument ...

    Examples:
    [root@mysystem ~]# iwconfig ath0 essid "firstword secondword"
    iwconfig: unknown command "secondword"
    [root@mysystem ~]# iwconfig ath0 essid "firstword\ secondword"
    iwconfig: unknown command "secondword"
    [root@mysystem ~]# iwconfig ath0 essid 'firstword\ secondword'
    iwconfig: unknown command "secondword"
    [root@mysystem ~]# iwconfig ath0 essid firstword\ secondword
    iwconfig: unknown command "secondword"
    [root@mysystem ~]# iwconfig ath0 essid "firstword' 'secondword"
    iwconfig: unknown command "'secondword"

    As the shell seems to be reliably parsing the command line where
    $2 = firstword secondword
    I can only assume it's an issue with the iwconfig+extensions+driver chain ... don't know enough about the internals to hazard a guess where.

    --NoWiz

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •