Find the answer to your Linux question:
Results 1 to 8 of 8
hi any advice on how to get this to work? iv only seen instructions for ubuntu. i am new to linux and would really appreciate any help...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    1

    Huawei E169G and acer aspire one (linpus)


    hi
    any advice on how to get this to work? iv only seen instructions for ubuntu. i am new to linux and would really appreciate any help

  2. #2
    Just Joined!
    Join Date
    Apr 2008
    Posts
    3
    Hi

    For my E220 this worked
    go to https://forge.betavine.net/frs/?grou...release_id=116 and download

    vodafone-mobile-connect-card-driver-for-linux-2.0.beta3-ALL-i386-installer.run

    double clinck on this file and it should start installing. You will get asked for your user name...i think its "user" by defualt. The software should install. start it by typing
    vodafone-mobile-connect-card-driver-for-linux in the terminal. If you have advanced mode on it should be under the internet section. If you get an error message about permissions put "sudo" in front of the command to get administrator privileges.

    I might be getting carried away here. To start the terminal press alt+f2 and type terminal.

    When setting up a connection use any username and password. For the APN I had to put in hs.vodafone.ie as im in ireland. For your APN setting have a look on Huawei E220 wvdial.conf files - Ubuntu Forums. Each network has something slightly different. Its at the bottom of these files.

    Good luck

  3. #3
    Linux Newbie
    Join Date
    Jun 2006
    Location
    Greece, Athens
    Posts
    214
    I tried Huawei E170 on Asus eeePC and it worked without the need for extra drivers. Since Acer Aspire One has a newer kernel, E169 should work out of the box.
    Go to the tool for network connections(don't know which is, as eeepc has xandros and not linpus) and the device Huawei E169 should appear there. Then give the configuration options that your ISP has given you.

  4. #4
    Just Joined!
    Join Date
    Aug 2008
    Posts
    2
    Made a mistake by selecting the modem that came up as recognised (E172) which is correct but did not enter the connection settings manually.

    It now comes up with an "authenticating window" that goes on forever.

    How can I stop it so I can enter the settings manually?

    Cancel doesnt help.

    --------------------------------------------------------------------------

    Hi

    For my E220 this worked
    go to https://forge.betavine.net/frs/?grou...release_id=116 and download

    vodafone-mobile-connect-card-driver-for-linux-2.0.beta3-ALL-i386-installer.run

    double clinck on this file and it should start installing. You will get asked for your user name...i think its "user" by defualt. The software should install. start it by typing
    vodafone-mobile-connect-card-driver-for-linux in the terminal. If you have advanced mode on it should be under the internet section. If you get an error message about permissions put "sudo" in front of the command to get administrator privileges.

    I might be getting carried away here. To start the terminal press alt+f2 and type terminal.

    When setting up a connection use any username and password. For the APN I had to put in hs.vodafone.ie as im in ireland. For your APN setting have a look on Huawei E220 wvdial.conf files - Ubuntu Forums. Each network has something slightly different. Its at the bottom of these files.

    Good luck

  5. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    1
    Hi thanks for this helpful advice- as a complete Linux novice every time I try and download the file I get 'you must be Root' and nothing happens. Any suggestions please?
    Any step by step instructions on how to get the Huawei E169G modem from three UK working on the acer aspire one would be fantastic please?
    Thanks

  6. #6
    Just Joined!
    Join Date
    Sep 2008
    Location
    singapore north east
    Posts
    11
    HI, I am using acer one too, but my modem is hua wei e270, i just get connected at all, there is some light on the modem where i connect to the acer one but on screen it shown no defection of the modem. i been cracking my head to in all areas from setting to connection. even call up my service provider here in singapore but was told thios hua wei e270 do not support linux. any help or advise?

    thanks

  7. #7
    Just Joined!
    Join Date
    May 2009
    Posts
    1

    Wink

    Hi

    The answer to this problem - Connecting the Huawei E169 to the 3 network in the UK (When using an Acer Aspire One with Linpus Lite) is found at http :// www .linux.com /forums/printtopic/2807?theme=print (remove spaces). The answer is in a post by nick34. Nice one Nick.

    In short do a software update. A program called Mobile Partner should now be installed. It is a Huawei program.

    "Once you have run Live Update and downloaded the patch: 1) Shut down the Aspire 2) Plug your modem into the USB port 3) Switch on the Aspire 4) On the 'Connect' Tab click on 'Mobile Partner' 5) It should now detect the modem 6) Click 'Tools' 'Options' 7) Click 'New' Give your profile a name 9) Select 'Static' under the APN tab 10) in the APN box enter three.co.uk 11) In 'Access Number' enter *99# 12) In 'User Name' enter three 13) Password is three 14) Authentication Protocol is 'CHAP' 15) Click 'Save' After doing that I was able to connect from the 'Connection' tab at the top of the screen."

    Now it works beautifully on my wife's computer. :>)

  8. #8
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    To change to root on the Aspire one, open a terminal and type sudo bash then give your root password and run whatever command you need. A tutorial on the Aspire One is available in pdf form from Linux Format magazine website.
    Registered Linux User #420832

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •