Find the answer to your Linux question:
Results 1 to 7 of 7
Hi all, I have ti set up a wi-fi connection on my Debian Etch 4.0 r3. I have a D-Link DWL-G122 H/W Ver.: C1 F/W Ver.: 3.00 usb pen drive. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    4

    wpa_supplicant troubles on Debian Etch


    Hi all, I have ti set up a wi-fi connection on my Debian Etch 4.0 r3. I have a D-Link DWL-G122 H/W Ver.: C1 F/W Ver.: 3.00 usb pen drive.
    I had looked around and I had installed the rt73 driver found here: http://rt2x00.serialmonkey.com/wiki/index.php/Main_Page.

    It works fine, but without encritpion.
    For my wireless connection I use WPA-PSK with TKIP encription, so I had installed the wpa_supplicant package, btu when I try to access to my LAN it gives to me some errors like these:

    rt73: driver version - 1.0.3.6 CVS
    rt73: using net dev supplied MAC addr
    rt73: Active MAC addr: [...]
    rt73 Local MAC = [...]
    ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Invalid argument
    ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Invalid argument
    ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
    Failed to set encryption.
    ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
    Failed to set encryption.
    ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
    Failed to set encryption.
    ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
    Failed to set encryption.
    ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Invalid argument
    ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Invalid argument
    CTRL-EVENT-TERMINATING - signal 2 received
    ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
    ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Invalid argument
    ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Invalid argument
    Failed to disable WPA in the driver.
    ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Invalid argument
    ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Invalid argument
    rt73: closed


    My /etc/wpa_supplicant.conf is:

    network={
    ssid="My LAN ID"
    #psk="My key"
    psk=[...]
    }


    My /etc/network/interfaces is:

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    #allow-hotplug eth0
    #auto eth0
    #iface eth0 inet static
    #address 192.168.0.101
    #netmask 255.255.255.0
    #gateway 192.168.0.100

    #allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet static
    address 192.168.0.151
    netmask 255.255.255.0
    gateway 192.168.0.100
    #wireless-essid MyID
    #wireless-mode managed
    #wireless-channel 7
    #wpa-proto WPA-PSK
    #wpa-driver wext
    #wpa-conf /etc/wpa_supplicant.conf
    #wpa-key-mgmt WPA-PSK
    #wpa-psk [...]


    I had tried a lot of configurations, but no one works.
    Have you some suggestion to give to me? What are these errors? And what can I do?

    I followed this guide:

    http://www.enterprisenetworkingplanet.com/netsecur/article.php/3594946

    Thanks you a lot for any suggest.

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Instead of using wpa_supplicant for WPA connections, use the NetworkManager. It should be located in the system tray, if it is installed and running.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    4
    Ehm... I've forgotten to tell that I'm running my Debian in text mode, I haven't installed xorg, this because I use it only for file server and it have old hardware. I'm configuring all by hand with mc and nano.

    Thank you anyway

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    OK, I still have my wpa_supplicant.conf file from when I needed it, so this is what it looks like:
    Code:
    # WPA AES encryption
        ctrl_interface=/var/run/wpa_supplicant
        network={
            ssid="YourLan ID"
            key_mgmt=WPA-PSK
            proto=WPA
            pairwise=CCMP TKIP
            group=CCMP TKIP WEP104 WEP40
            psk="123456passkey"
            priority=2
        }
    For the ssid you need to put the name of your lan connection. For the psk I had the password that I used, in human readable words. I made sure that my passkey was thirteen digits, as this seems to be important. So a passkey like "123456passkey" is thirteen digits, if you get what I mean. I think that this is important for wpa encryption.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    4
    nothing, it doesn't work. I'll try with a newer kernel.

    Thank you anyway

  7. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It looks from your config file that you have the line for managed mode commented out. Try setting it to managed mode, with this command:
    Code:
     iwconfig wlan0 mode managed
    Then check it using iwconfig without any options:
    Code:
    iwconfig
    You may need to first disable/enable it after making changes:
    Code:
    ifdown wlan0
    ifup wlan0
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #7
    Just Joined!
    Join Date
    Sep 2008
    Posts
    4
    rien de rien, nada de nada, niente di niente, absolutely nothing, absolut nichts. It doesn't want to works. As I have just told I'll wait for the new kernel, I'll try with Lenny when it will be stable.

    Thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •