Find the answer to your Linux question:
Results 1 to 2 of 2
ok, i go to uni, and they have wireless there... i can connect to it easily... :P (wireless is working), except i cant use apt-get install, *cough bitorrentcough* and i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    47

    Using Uni's internet for more than internet...


    ok, i go to uni, and they have wireless there... i can connect to it easily... :P (wireless is working), except i cant use apt-get install, *cough bitorrentcough* and i was wondering if there was a way to get these things to work at uni...

    now firefox only works because i have (in the options) ticked the "Automatic Proxy Configuration URL" and entered a certain proxy. I want to get apt-get to work, and everything else because i had dial up at home, and updating is like... well... you try updating ubuntu on dial up...

    There security is a WPA2 - enterprise;

    do you need more info?

    thanks...

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Although this isn't really a wireless problem, I'll see if I can help any.

    It sounds like either they are blocking a port that apt uses, or apt needs special configuration to use a proxy. When I run the man apt command (see see the apt manual), it mentions an apt.conf file. I don't see a file like that on my system, but you may need to create one.

    Take a look at the manual for the apt.conf file (man apt.conf). There is some mention of proxies under the http and ftp sections. It looks like you can copy an example file, and modify it for your needs. It says to put it in /etc/apt/apt.conf.
    http
    HTTP URIs; http::Proxy is the default http proxy to use. It is in the standard form of
    http://[[user][:pass]@]host[:port]/. Per host proxies can also be specified by using the form
    http::Proxy::<host> with the special keyword DIRECT meaning to use no proxies. The http_proxy environment
    variable will override all settings.
    It still doesn't say what the default port is (80?).
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •