Find the answer to your Linux question:
Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast
Results 21 to 30 of 42
Ok, so finally a little progress for me, lol. I found the kernel on that list you told me about, i installed it, and then tried installing the driver again. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28

    Ok, so finally a little progress for me, lol. I found the kernel on that list you told me about, i installed it, and then tried installing the driver again. I got to the "make" part and this is what it told me:

    Code:
    [*****@localhost usb]$ make
    make -C /usr/src/kernels/2.6.23.1-42.fc8-i686 M=/home/*****/orinoco_usb/usb KERNELRELEASE=2.6.23.1-42.fc8 modules
    /usr/src/kernels/2.6.23.1-42.fc8-i686/scripts/gcc-version.sh: line 16: gcc: command not found
    /usr/src/kernels/2.6.23.1-42.fc8-i686/scripts/gcc-version.sh: line 17: gcc: command not found
    make[1]: gcc: Command not found
    make[1]: Entering directory `/usr/src/kernels/2.6.23.1-42.fc8-i686'
      CC [M]  /home/*****/orinoco_usb/usb/orinoco_usb.o
    /bin/sh: gcc: command not found
    make[2]: *** [/home/*****/orinoco_usb/usb/orinoco_usb.o] Error 127
    make[1]: *** [_module_/home/*****/orinoco_usb/usb] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.23.1-42.fc8-i686'
    make: *** [modules] Error 2
    like i said, a bit of progress. but im stuck again, lol.

  2. #22
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    A few posts back I said this:
    Quote Originally Posted by waterhead View Post
    You may need more programs installed. Gcc is one of them. Any errors you get will usually tell you what is missing. Just keep fixing the errors until it stops complaining.
    If you look at the error, it says "gcc: Command not found". This means that you should install gcc. You can do the same with any other dependency errors. I would just ask you to keep track of what you needed to install, and post it here. Then others who read this thread for help will know what to install too.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #23
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    Ahhh, ok. so, first, sorry i forgot to install that, and am working on THAT now, lol. But apparently i just have the luck for running into every error i possibly can .

    So. i extractedthe .gz file for gcc into my /home/user directory, when into the terminal, cd'd into the folder and tried running the make command. all it said was

    Code:
    make: Nothing to be done for `all'.
    So, i reserached more into the folders, and i found an "INSTALL" file, read it and it says:

    INSTALLATION

    For now, just run make at the top level.

    To try some example code, run make examples or cd into the examples directory and make there.
    and that's all it says.

    anyways, inside of the glbcc-0.1.0 are 4 different folders: CVS, glbcc, lbpp, and libLB. Since I had tried to run it from the "top level" (which i assume is the first thing i tried when it gave me the above error), I figured i'd try to run it in the other folders, thinking maybe it was in one of the other folders.

    When i run make in the glbcc folder, it says this:

    Code:
    glbcc glbcc.bas glbcc
    make: glbcc: Command not found
    make: *** [all] Error 127
    In the lbpp folder:

    Code:
    make -C src
    make[1]: Entering directory `/home/*****/glbcc-0.1.0/lbpp/src'
    gcc -c -Wall -g `gnome-config --cflags gnomeui`  -o main.o main.c
    /bin/sh: gnome-config: command not found
    /bin/sh: gcc: command not found
    make[1]: *** [main.o] Error 127
    make[1]: Leaving directory `/home/*****/glbcc-0.1.0/lbpp/src'
    make: *** [all] Error 2
    And in the libLB folder:

    Code:
    make -C src
    make[1]: Entering directory `/home/*****/glbcc-0.1.0/libLB/src'
    make -C gui
    make[2]: Entering directory `/home/*****/glbcc-0.1.0/libLB/src/gui'
    make -C gtk
    make[3]: Entering directory `/home/*****/glbcc-0.1.0/libLB/src/gui/gtk'
    gcc -Wall -g `gnome-config --cflags gnome` -I../../../include  -c -o basic_gui.
    o basic_gui.c
    /bin/sh: gnome-config: command not found
    /bin/sh: gcc: command not found
    make[3]: *** [basic_gui.o] Error 127
    make[3]: Leaving directory `/home/*****/glbcc-0.1.0/libLB/src/gui/gtk'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/home/*****/glbcc-0.1.0/libLB/src/gui'
    make[1]: *** [gui/libGUI.a] Error 2
    make[1]: Leaving directory `/home/*****/glbcc-0.1.0/libLB/src'
    make: *** [all] Error 2
    Sooo yeah. If you need more info. lemme know. Sorry if I'm alot of trouble, lol. This seems like it should be easier than it is, maybe it's just my inexperience, haha.

    Oh, and the INSTALL file that says how to install it is the lbpp folder, thought maybe that might be important?

  4. #24
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    Okay, before you start trying to figure the above post out, dont. I think i downloaded a really old version of it, so it doesnt matter. I found what i think is the recent version (Which is named gcc-4.1.2) But the problem is that it doesn't seem to have a Makefile, so when i try running make, it does nothing.

    Sooo yeah, THIS is where im stuck now, lol.

  5. #25
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Don't try installing applications from source. Stick to using the installation DVD for the needed programs. You are making this way too difficult.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #26
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    Ohh ok, sorry. I didn't know that it was in the dvd. i got it installed now.

  7. #27
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    Okay, so. I installed it, loaded it. then i got to the part to where i need to use the command:

    Code:
    ./get_ezusb_fw
    and all it tells me is:

    Code:
    bash: ./get_ezusb_fw: Permission denied
    That's where i stand now.

  8. #28
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Where you root when you downloaded that file? That's the only thing that I can think of. Try changing the ownership of the file, or delete it and download again as a regular user.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #29
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    sorry about the delay on a response, but if you remember, i download my files through windows cuz i dont have a hard connection anywhere right now to download anything through linux. so i guess ill just try redownloading the file and try it again...otherwise you have no other suggestions at all?

  10. #30
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    If you burned the file to a CD, that may make it a read-only file. Or you may also need to make it executable. You should give yourself root privileges first. I don't know your username, put that wherever I have <user>. I also see that the driver is in a folder /usb.
    Code:
     chown -R  <user>:<user> /usb
    Don't forget the semicolon between the two <user> entries. You may need the entire path to the folder IE: /home/<user>/usb.

    To make a file executable, first exit the root privileges, then cd to the folder where the file is (/usb/firmware ?) and run this command.
    Code:
    chmod 777 get_ezusb_firmware
    EDIT: I just realized that you should run this for the entire folder.
    Code:
    chmod -R 777 /home/<usr>/usb/
    Now try and run it again.
    Code:
    ./get_ezusb_firmware
    Last edited by waterhead; 09-29-2008 at 12:08 PM. Reason: added edit
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •