Find the answer to your Linux question:
Page 4 of 5 FirstFirst 1 2 3 4 5 LastLast
Results 31 to 40 of 42
OK, sorry to say, i have yet ANOTHER error. So I changed the ownership of the whole folder like you told me to do to my username. It seems that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28

    OK, sorry to say, i have yet ANOTHER error.

    So I changed the ownership of the whole folder like you told me to do to my username. It seems that it WAS owned by root for some reason. OH and by the way, it wasn't on a cd, i download these files on windows, leave it on my desktop, and then switch to linux and grab it off of my windows partition. Anyways, that seemed to have worked fine, then i tried the ./get_ezusb_fw command and it said this:

    Code:
    [*****@localhost firmware]$ ./get_ezusb_fw
    bash: ./get_ezusb_fw: /bin/sh^M: bad interpreter: No such file or directory
    So i checked to make sure that's what the file was called, made sure it was in the folder, all that stuff and it all checks out. i even used the "more" command to make sure i could even read the file, and it came up there like normal. So i decided i would use that second command you gave me to make sure that it was executable or w/e, and it did the same thing:

    Code:
    [*****@localhost firmware]$ chmod 777 -R /home/*****/orinoco_usb
    [*****@localhost firmware]$ ./get_ezusb_fw
    bash: ./get_ezusb_fw: /bin/sh^M: bad interpreter: No such file or directory
    Sooo, idk what that means.

  2. #32
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Try it this way then.
    Code:
    chmod +x get_ezusb_fw
    That should make it executable. Now run the command.
    Code:
    ./get_ezusb_fw
    There is another way to run a script by using sh instead of ./
    Code:
    sh get_ezusb_fw
    But I think that the file needs to end with .sh for this to work. Like: get_ezusb_fw.sh
    Last edited by waterhead; 10-01-2008 at 12:56 AM. Reason: bad command
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #33
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    If it still won't work, check if you have the file /bin/sh. On my system /bin/sh is actually a link to /bin/bash, so you should have that to.

    If you have /bin/bash, but not /bin/sh, maybe try and make the link. Do this as su.
    Code:
    ln /bin/bash /bin/sh
    If you don't have /bin/bash, then you need to install bash.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. #34
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    Okay, so i tried the second chmod and it seemed to have worked. and then i tried to run

    Code:
    ./get_ezusb_fw
    and it told me the same thing as before. so i tried the other command

    Code:
    sh get_ezusb_fw
    and it told me:

    Code:
    [*****@localhost firmware]$ sh get_ezusb_fw 
    : command not found2: 
    : command not found5: 
    : command not found7: 
    : command not found11: 
    : command not found15: 
    : invalid optionne 16: set: - 
    set: usage: set [--abefhkmnptuvxBCHP] [-o option] [arg ...]
    and so i went to go see if i had /bin/bash and /bin/sh and i have both of them.

    So i dont know what thats supposed to mean.

    Like i said, this seems like it should be easier than it is lol. And it seems like i run into every error possible. If you're getting sick of me, let me know, im doing everything you say though lol.

  5. #35
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Did you first "cd" to the firmware folder where that script is?
    Code:
     cd firmware
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #36
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I just ran it again, and here's what I got:
    Code:
    [paul2@localhost firmware]$ ./get_ezusb_fw
    436+0 records in
    436+0 records out
    6976 bytes (7.0 kB) copied, 0.00285288 s, 2.4 MB/s
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #37
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Here's the script that I got, in case there's something wrong with yours. Copy it to a text file and save it as get_ezusb_fw. Then make it executable with the chmod +x command.
    Code:
    #!/bin/sh
    
    # Get firmware for ezusb used in Orinoco USB cards.
    # Both the header file and the binary firmware file are produced.
    
    # Copyright (C) 2004 Pavel Roskin <proski@gnu.org>
    
    # This script is Free Software, and it can be copied, distributed and
    # modified as defined in the GNU General Public License.  A copy of
    # its license can be downloaded from http://www.gnu.org/copyleft/gpl.html
    
    # Usage: get_orinoco_fw
    # Output: orinoco_ezusb_fw
    # Needed tools: curl (or wget), unzip, dd, od, sed.
    
    set -e
    
    URL_BASE=ftp://ftp.avaya.com/incoming/Up1cku9/tsoweb/avayawireless
    DL_FILE=AV_WINXP_PC_USB_SR0201.zip
    URL="$URL_BASE/$DL_FILE"
    DL_FRAG=ezusb.zip
    DL_INT_PATH="USB/WLAGS51B.sys"
    DL_INT_OFFSET=6117483
    
    get_file_short() {
        curl --range ${DL_INT_OFFSET}- -o "$1" "$2"
    }
    
    get_file() {
        curl --remote-name "$1" || \
        wget --passive-ftp "$1" || \
        wget "$1" || \
        ftp "$1" </dev/null || \
        exit 1
    }
    
    if ! test -f $DL_FRAG; then
        get_file_short $DL_FRAG "$URL" || true
    fi
    gzip -cd <$DL_FRAG >ezusb.drv || true
    
    if ! test -s ezusb.drv; then
        if ! test -f $DL_FILE; then
            echo "WARNING: Quick download failed, fetching full file"
            get_file "$URL"
        fi
        unzip -p $DL_FILE "$DL_INT_PATH" >ezusb.drv
    fi
    
    dd if=ezusb.drv of=orinoco_ezusb_fw skip=9983 count=436 bs=16
    
    rm -f ezusb.drv
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #38
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    Ok so, I finally have some good news...i think. I found a hard connection and so...that's just an fyi I guess. and i guess there was something wrong with the coding in the get_ezusb_fw i had, I just copied what you gave me here and put it in there and the ./get_ezusb_fw command worked, downloaded the firmware, i then moved it to the /lib/firmware folder, and now when i press the buttons to turn on my adapter (Fn+F2) the little green light turns on on the top of my adapter.

    Now i think this is just a quick fix thing, correct me if im wrong, but the internet doesnt seem to connect through my adpater just yet, you told me a while back right after the part about installing the firmware and restarting my computer that I have to add my adapter as new hardware or something, how would I go by doing that? is there a wizard somewhere? because i can't seem to find it.

  9. #39
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    On my system, with the KDE desktop, I run the Network application from the menu. If you use Gnome, it may be under the Administration menu. Or you can run it from the terminal:
    Code:
    /usr/bin/system-config-network
    Give the root password, as you need root privileges to make system changes.

    You should see the wireless on the first tab. Put a check in the box next to it, and click on the "Edit" icon at the top. Here you can give settings that are device specific. Put checks next to "Controlled by NetworkManager" and "Allow all users to enable and disable this device"

    Also select "Automatically obtain IP address with dhcp" And check the box "Automatically obtain DNS information from provider". You can enter the wireless connection info too, put NetwrkManager is going to now handle this.

    Exit that, and go to the DNS tab. Here you would enter the IP address of the router. This would be the one that is connected to the internet.

    Save the new configuration File --> Save and do another reboot.

    Hope it works this time.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #40
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    oh my lord hallelujah! haha.

    It works! I'm on the wireless right now, lol. Thank you sooo much for your help. Sorry if it was alot of trouble/work dealing with all my errors n **** lol. but thanks, i appreciate it ALOT!

Page 4 of 5 FirstFirst 1 2 3 4 5 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •