Find the answer to your Linux question:
Page 1 of 5 1 2 3 4 5 LastLast
Results 1 to 10 of 42
Okay, so my problem is that I don't have wireless internet set up on my laptop and I would REALLY like it if I could get this fixed, lol. And ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28

    Problem installing orinoco-0.15 driver. Help please!!!


    Okay, so my problem is that I don't have wireless internet set up on my laptop and I would REALLY like it if I could get this fixed, lol. And a head's up, im a newbie to linux so bare with me if I don't get all the lingo and whatnot. First things first, I'm running on Fedora 8 and my laptop is a Compaq Evo N610c. I found out, after installing linux on my computer, that wireless adapters don't seem to run without installing specific drivers and whatnot. So, I switched over to Windows (where I'm able to have internet...) and found that a driver called (correct me if I'm missing part of the title..) Orinoco. I downloaded it to my laptop, read the README and it doesn't seem to really tell me much about installing it. it just says

    "The easiest way to install is to use the version included in the kernel source. Enable CONFIG_NET_RADIO, CONFIG_HERMES, and the driver for your hardware"

    Then it talks about using a "standalone version"...which...i dont even know if that matters to me, i just wanna install this thing and get my net working right, lol.

    So i put it on hold for a bit until today when i decided i wanted to get it done, so i found this site and started searching. I found a sticky on installing things and i read up to the actual installing part and it won't work. It told me to make an "src" directory, which i did what it said.

    "mkdir /home/user/src"

    and then it said it assumed that I downloaded the file into there, so i put the orinoco-0.15.tar.gz file in there. (By the way, i forgot to mention that i downloaded the file on windows, booted into fedora, and then grabbed it from my windows partition...that might be a given, just a heads up.)

    Then it said to unzip the tar.gz file, to change directory to the file after its been unzipped, and then it said i needed to check for a readme or install file to read. and it said if there is one, to type "more README" which i found a readme file but, like i said already, nothing in there really tells me how to do it. at least as far as i know.

    After that, it told me to type in "make" and when i do it, it just tells me:

    "Makefile:8 *** Kernel tree not found - please set KERNEL_PATH. Stop."

    This is where I'm stuck. I've tried googling this message as far as i could, and I could not for the life of god find much on it. I've found that I need to download some kernel stuff...idk. Like i said, I'm new to the linux world, but i really like the operating system 'cause it seems to run a lot smoother than Windows.

    If someone could PLEASEPLEASEPLEASE help me out, I'd REALLY appreciate it!!!!! If you need anymore info, just ask. I'll see if I can answer it, lol.

    Thanks in advance!

  2. #2
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    ohh sorry, I forgot to include that my wireless adapter is a Compaq Wireless Lan W200. I'm not sure if that's an important factor, but I read that the orinoco driver supports it.

    Again, Thanks in advance for any advice left!!!

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    First, you have to be positive that you are trying to use the correct driver. For PCI hardware info, use this command.
    Code:
    lspci -nn
    For USB devices, use this command.
    Code:
    lsusb
    Post the output of these commands, so I can be sure of the wireless cards chipsets.

    I think that the reference to the driver in the kernel source means the driver that is compiled into the kernel, as a module. Linux is pretty good as determining the correct drivers to use, and it then loads them. Sometimes more configuration is still needed before the wireless will work.

    To see a list of all driver modules, enter this command into a terminal.
    Code:
    lsmod
    Go ahead and post this output too. According to the Orinoco driver README (yes, I downloaded it) these are the orinoco drivers:
    Code:
    orinoco_cs      PCMCIA/CompactFlash cards in sockets supported by the
                    Linux PCMCIA driver, except Symbol Spectrum Trilogy V3
    spectrum_cs     PCMCIA/CompactFlash cards using Symbol Spectrum
                    Trilogy chipset, version 3
    orinoco_plx     PCMCIA cards in PLX9052 based PCI adaptors
    orinoco_tmd     PCMCIA cards in TMD7160 based PCI adaptors
    orinoco_nortel  PCMCIA cards in Nortel and Symbol PCI adaptors
    orinoco_pci     Prism 2.5 based PCI/MiniPCI cards
    There may be one of these driver modules already loaded.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    Um, maybe I'm not doing something right but for each one it's said:

    "bash: command: command not found"

  6. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Sorry about that. In Fedora, you need to add the location of the program to the command. In this case, it is in the /sbin folder.
    Code:
    /sbin/lspci -nn
    Code:
    /sbin/lsusb
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #6
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    Okay, that worked better lol.

    For the first command it said:

    Code:
    00:00.0 Host bridge [0600]: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge [8086:1a30] (rev 04) 
    00:01.0 PCI bridge [0604]: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge [8086:1a31] (rev 04) 
    00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 42) 
    00:1f.0 ISA bridge [0601]: Intel Corporation 82801CAM ISA Bridge (LPC) [8086:248c] (rev 02) 
    00:1f.1 IDE interface [0101]: Intel Corporation 82801CAM IDE U100 Controller [8086:248a] (rev 02) 
    00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801CA/CAM AC'97 Audio Controller [8086:2485] (rev 02) 
    01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] [1002:4c57] 
    02:04.0 Communication controller [0780]: Agere Systems LT WinModem [11c1:0450] (rev 02) 
    02:06.0 CardBus bridge [0607]: Texas Instruments PCI1420 PC card Cardbus Controller [104c:ac51] 
    02:06.1 CardBus bridge [0607]: Texas Instruments PCI1420 PC card Cardbus Controller [104c:ac51] 
    02:08.0 Ethernet controller [0200]: Intel Corporation 82801CAM (ICH3) PRO/100 VM (KM) Ethernet Controller [8086:1038] (rev 42) 
    02:0e.0 USB Controller [0c03]: NEC Corporation USB [1033:0035] (rev 41) 
    02:0e.1 USB Controller [0c03]: NEC Corporation USB [1033:0035] (rev 41) 
    02:0e.2 USB Controller [0c03]: NEC Corporation USB 2.0 [1033:00e0] (rev 02)
    and then for the second command it said:

    Code:
    Bus 003 Device 001: ID 0000:0000  
    Bus 002 Device 002: ID 049f:0076 Compaq Computer Corp. 
    Bus 002 Device 001: ID 0000:0000  
    Bus 001 Device 001: ID 0000:0000

  8. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Quote Originally Posted by tylihongkong View Post
    Bus 002 Device 002: ID 049f:0076 Compaq Computer Corp.
    OK, this looks to be the wireless. A quick Google of 049f:0076 seems to confirm that it is an Orinoco wireless. Please post the output of the lsmod command.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I found a SUSE How-To for this driver. There is one for SUSE 10.3 and one for 11.0
    Lucid Tips Wireless using W200 on openSUSE 10.3
    Lucid Tips Wireless using W200 on openSUSE 11.0

    It says that the driver is called orinoco_usb. I don't see it in the list from the downloaded driver. It looks like you need to get the latest version from the CVS repository.
    Code:
    svn co -r 1300 https://orinoco.svn.sourceforge.net/svnroot/orinoco/branches/usb/
    You should just try to compile the driver with the "make and "make install" commands. The How-To's seem overly complicated, and they want you to disable KNetworkManager. I use this for my wireless connections, because it makes it so much easier.

    If it won't work, then follow the directions.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    OK.

    I just downloaded and compiled the driver, and loaded it with no problem. I am using a 2.6.26 kernel that I compiled from source. Here is what I did:

    Create a folder for the driver:
    Code:
    mkdir ~/orinoco_usb
    Go to that folder:
    Code:
    cd ~/orinoco_usb
    Download the driver source:
    Code:
    svn co -r 1300 https://orinoco.svn.sourceforge.net/svnroot/orinoco/branches/usb/
    Now enter the "usb" folder:
    Code:
    cd usb
    Build the driver:
    Code:
    make
    Become root and install the driver:
    Code:
    su
    Password:<root password>
    make install
    Now load the driver:
    Code:
    modprobe orinoco_usb
    Check to see if it is loaded;
    Code:
    lsmod
    I have two orinoco modules loaded:
    Code:
    Module                  Size  Used by
    orinoco_usb            19340  0
    orinoco                38292  1 orinoco_usb
    Don't forget to install the firmware. There is a script with the driver for doing this. Don't do this as root, as then the file will be owned as root. Just type in "exit" to exit root.
    Code:
    cd firmware
     ./get_ezusb_fw
    This downloads a zipped file "ezusb.zip". It also unzips it and extracts the orinoco_ezusb_fw file.

    Now become root again, and copy the firmware to the /lib/firmware folder.
    Code:
    su
    Password:
    cp orinoco_usb_fw /lib/firmware
    It may be best to reboot the system. Then configure the wireless as a new network card.

    I hope this works for you.
    Last edited by waterhead; 09-23-2008 at 12:49 AM. Reason: removed unzip command
    Please do not send Private Messages to me with requests for help. I will not reply.

  11. #10
    Just Joined!
    Join Date
    Sep 2008
    Posts
    28
    Okay, the problem is that I don't have internet while im on linux, is there any way i can download the files on that site through windows? i'm not sure how id do that, lol. sorry if this is a dumb question.

Page 1 of 5 1 2 3 4 5 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •