Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
After I finally figured out how to get into our belkin router to set up a password, I had found that there were some other computers that were connected to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Location
    Southwest Kansas
    Posts
    57

    Wireless security problems...


    After I finally figured out how to get into our belkin router to set up a password, I had found that there were some other computers that were connected to our network.
    Anyway, I tried to set up the password, keyword, etc, but only got it to work once, and when I did get it to work, the internet seemed like it wouldn't connect. It would just keep loading loading loading loading...

    I've read somewhere that when you use a password/key the internet runs slower than if you don't use it...So could that be part of the problem, also?

    Router: Belkin F5D7230
    Adapters: Belkin F5D7050

    Here's the password specifications of the router...

    WPA/WPA2-Personal(PSK)
    1) WPA-PSK + WPA2-PSK with TKIP + AES
    2) WPA2-PSK with AES
    3) WPA-PSK with TKIP
    I've tried all of these, and none worked...

    128 WEP
    Truefully, I haven't tried this one yet...

    64 WEP
    This one was the one that did work, but didn't seem like it would connect to the internet.


    This is what Zenwalk has for connnecting to a wireless router with passwords/phrases/etc...

    WPA 1/2 (Enter password key)
    WEP Hex (Enter password key)
    WEP Passphrase (Enter password key)
    LEAP with WEP (Enter username: enter password key)
    TTLS with WEP (Username: Password: Authentication)
    EAP-FAST (Username: Password: Path to PAC file [I don't think I need this one])
    PEAP with GTC (Identity: Password)
    PEAP with TKIP (Identity: Password: Path to CA Cert [I don't think I need this one either])

    Thanks...

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I've never used Zenwalk, but for wireless in any operating system you want to use WPA.

    If you found that other computers were using your wireless connection without your permission, they may have also made changes to the router setup. Some routers have a default reset button, that you activate with a pin or tip of a pen. I would suggest that you reset everything to default, to begin with. Then change the IP address of the router so that it no longer is anything similar to the old one. Set up a network ID and passkey.

    According to the Zenwalk docs, it should now detect your router. You then give it the info that it needs to connect.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Location
    Southwest Kansas
    Posts
    57
    I might have missed something reading through the docs then. I've been using ndiswrapper...

    I have added a password to the router setup, so no one can get in now. So far everything looks alright, and I can still change things...I really don't want to change anything yet until I can figure out exactly what I'm doing...So far I think I have an idea of what to do...

    Are there any rules I should follow when changing the IP address?

    By the way, there is a section that asks "Only this IP address can remotely manage the router", If I were to set the IP to this computers address, then would that mean that only our main computer which is hooked up directly to the router and this computer would be able to make changes to it?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    For IP addresses in a private network, these are usually used:

    192.168.x.x
    10.x.x.x

    Here's a wiki entry on it ;
    IP address - Wikipedia, the free encyclopedia

    When I said to use something different, I was thinking of the 10.x.x.x series.

    I would only use NDISwrapper as a last resort. As long as you already have it installed, then use it. If there is a native Linux driver that is loading for your wireless, it will interfere, and it won't work.

    Use this command to see a list of all driver modules loaded on your computer. Please post the output of this command.
    Code:
    lsmod
    I usually can spot the wireless drivers.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Sep 2008
    Location
    Southwest Kansas
    Posts
    57
    Code:
    Module                  Size  Used by
    i915                   19584  2 
    drm                    43928  3 i915
    pcmcia                 19572  0 
    pcmcia_core            17940  1 pcmcia
    snd_seq_oss            17820  0 
    snd_seq_midi_event      3328  1 snd_seq_oss
    snd_seq                26684  4 snd_seq_oss,snd_seq_midi_event
    snd_seq_device          3468  2 snd_seq_oss,snd_seq
    snd_pcm_oss            24576  0 
    snd_mixer_oss           9216  1 snd_pcm_oss
    iptable_mangle          1536  0 
    iptable_nat             2952  0 
    nf_nat                  9112  1 iptable_nat
    nf_conntrack_ipv4       6408  3 iptable_nat,nf_nat
    nf_conntrack           26052  3 iptable_nat,nf_nat,nf_conntrack_ipv4
    iptable_filter          1408  0 
    ip_tables               6672  3 iptable_mangle,iptable_nat,iptable_filter
    x_tables                6276  2 iptable_nat,ip_tables
    video                  11152  0 
    output                  1536  1 video
    fuse                   25884  0 
    fan                     2048  0 
    ac                      2436  0 
    ndiswrapper           116756  0 
    eepro100               17040  0 
    mii                     2944  1 eepro100
    snd_intel8x0           17180  2 
    snd_ac97_codec         64928  1 snd_intel8x0
    ac97_bus                1152  1 snd_ac97_codec
    thermal                 9756  0 
    snd_pcm                34692  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
    processor              21600  1 thermal
    button                  3728  0 
    snd_timer              11144  2 snd_seq,snd_pcm
    snd                    25016  13 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
    soundcore               3016  1 snd
    snd_page_alloc          4488  2 snd_intel8x0,snd_pcm
    i2c_i810                2692  0 
    i2c_algo_bit            3844  1 i2c_i810
    intel_agp              15044  1 
    ehci_hcd               21132  0 
    agpgart                15668  3 drm,intel_agp
    i2c_core                9492  2 i2c_i810,i2c_algo_bit
    uhci_hcd               13836  0 
    evdev                   5248  3 
    sg                     17204  0
    I just tried adding the WPA password, it didn't work...Had to disable the passphrase again...

    <Edit> I keep forgetting to say what happens when I do connect. It connects me to a different IP than what it's supposed to connect to. And when I change the IP settings, it connects me to None at 0 at the correct IP...When I use the password...

  7. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Thanks.

    I don't see any conflicting drivers, so that's OK.

    You may need to use something called wpa_supplicant to enable WPA support. You should be able to install it with your distro's package management program. You set it up with a config file in the /etc folder.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #7
    Just Joined!
    Join Date
    Sep 2008
    Location
    Southwest Kansas
    Posts
    57
    Found it, it's already installed. However, I didn't see anything in the /etc folder for it though...

  9. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It may be in it's own folder.

    /etc/wpa_supplicant/
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #9
    Just Joined!
    Join Date
    Sep 2008
    Location
    Southwest Kansas
    Posts
    57
    Well, the binary's there. When I type in wpa-supplicant in the terminal, I get v0.5.10 and a list of commands...

    I also found that I do have the Linux driver for my wireless adapter, however, I can't use it...I unloaded ndiswrapper and even rebooted, and loaded the rt2500usb service...So far no go...

    <Edit> Ok, I ran Vector linux on my other computer and found the correct services to run. Now iwconfig shows it is there, but still can't find any networks or connect to anything...LSHW shows that the wireless device is disabled...

  11. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You have to configure wpa_supplicant to use your wireless. When you entered the command wpa_supplicant, it give you a list of drivers, options, and at the end an example.

    For more detailed information, use the man pages:
    Code:
    man wpa_supplicant
    Code:
    man wpa_supplicant.conf
    You run the command to tell wpa_supplicant which driver, network interface, and location of the wpa_supplicant.conf file. For example:
    Code:
    wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf
    As for the rt2500usb driver, it should have been loaded automatically. I don't know why your distro didn't, as most modern distros would. If wireless is important, I would really consider using a different distro. Ubuntu is more friendly to newer users, and easier to setup. There are other distros too, like openSUSE or Fedora.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •