Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 28
It could be an internal USB device. That is why I asked for both lspci and lsusb outputs. I don't want to go any farther until I find out, so ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    It could be an internal USB device. That is why I asked for both lspci and lsusb outputs.

    I don't want to go any farther until I find out, so please post the outputs of those commands.
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #12
    Just Joined!
    Join Date
    Sep 2008
    Posts
    14
    Sorry about that. Here you go;

    lsusb:
    Code:
    Bus 004 Device 001: ID 0000:0000  
    Bus 003 Device 003: ID 0d49:7450 Maxtor 
    Bus 003 Device 002: ID 13fe:1e21 Kingston Technology Company Inc. 
    Bus 003 Device 001: ID 0000:0000  
    Bus 002 Device 001: ID 0000:0000  
    Bus 001 Device 001: ID 0000:0000
    lspci:
    Code:
    00:00.0 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
    00:01.0 ISA bridge: nVidia Corporation MCP67 ISA Bridge (rev a2)
    00:01.1 SMBus: nVidia Corporation MCP67 SMBus (rev a2)
    00:01.2 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
    00:01.3 Co-processor: nVidia Corporation MCP67 Co-processor (rev a2)
    00:02.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
    00:02.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
    00:04.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
    00:04.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
    00:06.0 IDE interface: nVidia Corporation MCP67 IDE Controller (rev a1)
    00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
    00:08.0 PCI bridge: nVidia Corporation MCP67 PCI Bridge (rev a2)
    00:09.0 IDE interface: nVidia Corporation MCP67 AHCI Controller (rev a2)
    00:0a.0 Ethernet controller: nVidia Corporation MCP67 Ethernet (rev a2)
    00:0c.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
    00:0d.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
    00:12.0 VGA compatible controller: nVidia Corporation GeForce 7000M (rev a2) (rev a2)
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    01:04.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
    01:04.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
    01:04.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
    01:04.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
    01:04.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
    05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

  3. #13
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Hmmm......

    The more that I look into this, the deeper it seems to get. Before saying anything else, try this command:
    Code:
    sudo wlanconfig ath0 create wlandev wifi0 wlanmode sta
    Here is some info on your chip, this is what I mean about it getting deep:

    Compatibility/Atheros - madwifi.org - Trac

    If the wireless is controlled by the BIOS, it may be that it is staying switched off. You could try entering the BIOS and setting it to Wake-On-LAN. This way it won't stay switched off (hopefully). There are some other work-arounds listed here, I don't know if your laptop is listed:

    UserDocs/MiniPCI - madwifi.org - Trac

    There is mention about needing the latest developmental version of the driver to get this to work. Unless you are really adventurous, I guess it would be time to admit defeat and tell you to use NDISwrapper.

    If you use NDISwrapper, you now must remove the ath_pci module and blacklist it.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. #14
    Just Joined!
    Join Date
    Sep 2008
    Posts
    14
    I tried the
    Code:
    sudo wlanconfig ath0 create wlandev wifi0 wlanmode sta
    command, and got
    Code:
    wlanconfig: ioctl: No such device
    I'll try the changing the BIOS settings and get back to you on that.

    A honestly wouldn't mind using NDISwrapper, as i already have it installed.

  5. #15
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    If it will make the wireless work, go ahead and use NDISwrapper. You've indulged me enough on my "Let's use the native driver" crusade.

    I also say to use NDISwrapper as the last resort, so this would fit. In the end I'm all about getting the wireless to work, no matter how.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #16
    Just Joined!
    Join Date
    Sep 2008
    Posts
    14
    The thing is, that i can't get it to work with NDISwrapper (as said in my first post). I'm using NDISgtk with NDISwrapper (it's a GUI for NDISwrapper), and the windows drivers for my card. I uninstalled the default Network Manager to use wicd, so if it's any easier, i'll uninstall wicd and reinstall the default Network Manager.

  7. #17
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The only thing that I can think of, is to run NDISwrapper in a terminal instead of using the GUI. This way you could see any error messages that it might give.

    For more info on using NDISwrapper, enter these commands:
    Code:
    ndiswrapper --help
    Code:
    man ndiswrapper
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #18
    Just Joined!
    Join Date
    Sep 2008
    Posts
    14
    Once again, thanks for helping.

    I uninstalled the previously installed drivers (which were installed using NDISgtk), and tried to install them again, this time using the terminal. The result was...
    Code:
    couldn't create /etc/ndiswrapper/net5211: Permission denied at /usr/sbin/ndiswrapper-1.9 line 194

  9. #19
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You need to have root privileges to do it. So on Ubuntu precede the command with sudo.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #20
    Just Joined!
    Join Date
    Sep 2008
    Posts
    14
    Actually, before you replied, i thought about that, and went off to try it (i was on Ubuntu when you replied). I got an error message about not finding a file (I'll go try it again, and edit this post with the exact error message).

    EDIT: Disregard all that. On the second try, the installation worked fine (Although i still can't get a wireless conection).

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •