Find the answer to your Linux question:
Results 1 to 4 of 4
This is just a general forum post, when I switched to using linux from windows, I found alot of info regarding this, and after alot of reading, it seems it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    32

    Setting up the Pantech PX500 EVDO modem on Linux


    This is just a general forum post, when I switched to using linux from windows, I found alot of info regarding this, and after alot of reading, it seems it was easier then it seemed.

    My internet is through Sprint using a Pantech PX500 data card, which works on both my desktop and my laptop running PcLinux 2007 or Ubuntu 8.04, and probably McnLive, but thats not confirmed, I was having the same trouble on Ubuntu I was on McnLive, I got it on Ubuntu, and havent tried it on McnLive yet, but I will then add an edit if it works.

    My desktop is an older KTS motherboard running a AMD athlon XP 2700
    Using a pci to pcmcia adapter, I am able to put the broadband card into the desktop

    Then Open KPPP
    Accounts, add new, I name mine EVDO connection, but it doesnt matter what you name it, I just keep it simple
    Then click on the modems tab, add modem, name Pantech PX500, modem location /dev/ttyACM0
    Everything else is set already by default, username I use my sprint email address and password is user
    Thats it, it works fine on both the desktop and the laptop that way!

    I just put ubuntu 8.04 on a flash drive like yesterday, and its a little different for ubuntu because you dont have KPPP

    Now, if I can do this from memory, cause im on PCLOS at the moment, either go into network admin or left click the network icon on the task bar, then click Manual setup, you will see a telephone icon with Point to Point, click that, then properties, enable the connection...leave it on serial modem, phone number #777, no dial prefix, same username and password, on the modem tab, on Ubuntu for me, my modem location is /dev/ttyUSB3 (I found this out by running wvdialconf at the command prompt and it showed me the pantech PX500 was found at /dev/ttyUSB3

    Then under network admin on the options tab, I checked all 3 options...and then saved the connection as sprint and I was online! I think the first time I saved it, the checkbox disappeared by the connection, just recheck it, and it should stay there making the connection active!

    Hopefully, that might help someone else, I tried to be clear as possible, my laptop is a toshiba satelite, almost 2yrs old, the A105 series, and it works the same on it!

    When I started trying to configure this thing, I found some info on it, but most of it talks about writting chatscripts and other stuff that I found really didnt have to be done, I tried it, but it didnt work for me, then I found it really was easy to set it up!

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Thanks for the detailed How-To.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Mar 2009
    Posts
    2
    You can also follow the manual from Sprint.
    Write in Google:
    Sprint Software Downloads - Mobile Broadband Cards - PX-500 by Pantech

    Here is the direct link to the manual.
    http://www.sprint.com/assets/downloa..._for_Linux.pdf

  4. #4
    Just Joined!
    Join Date
    Mar 2009
    Posts
    2
    This is happening in Ubuntu Intrepid. The Pantech PX500 EVDO wireless modem is recognized immediately and the connection is established automatically. The only problem is that the connection is very very slow, in the range of the 15 KB/s in average. In the same spot but using Windows XP the speed is about 1.5 MB/s.
    There is indeed a bottleneck at some point in the serial connection.

    A Linux user had this same problem. He provided a patch for it.
    Connection manager vs dialup networking vs linux kppp speeds : EVDOforums.com
    He was running the Pantech PX-500 too, he found that the problem is because the generic drivers (usbgeneric.ko and acm-cdc.ko) have tiny buffers designed for slow-speed modems.

    I already reported this bug and the patch to the Ubuntu developers. I hope they release a fix soon.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •