Find the answer to your Linux question:
Results 1 to 6 of 6
I have the Current Damn Small Linux 2008 edition running permantly installed to hardrive on a Compaq Armada 1540DM, P 147 ghz, 80 mb ram, 2.0 gig hardrive. I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,138

    DS Linux trying to connect Netgear MA401 PCMCIA


    I have the Current Damn Small Linux 2008 edition running permantly installed to hardrive on a Compaq Armada 1540DM, P 147 ghz, 80 mb ram, 2.0 gig hardrive. I have internet access on eth1 using a Xircom CEM56-100 PCMCIA cardbus modem.

    I researched Damn Small Linux and for PCMCIA Wireless cards that work out of the box with little or no configuring, I settled on a Netgear MA401 16bit PCMCIA wireless b 11 mbps.

    During the module boot up screen Wireless is etho, Land line is eth1.

    eth0 is detected during boot up
    eth1 is detected during boot up

    Modprobe on wirelees Netgear is
    modprobe hermes
    modprobe orinco

    Then what seems to keep wireless from working is these set of errors during bootup

    hermes etho timeout error
    eth0 error -110 dISABLING Macpoint
    eth0 error -5 setting Mac Address
    eth0 error -5 configuring card.

    Cut and paste doesn't work yet on this DSL install as when I follow instructions to paste terminal screen readouts to notepad , when I press both l/h and r/h click pads at the same time nothing gets pasted on notepad. I am going to have to type out screen messages. Not *****in about problem or trying to get it fixed, just letting you know where I am at on this install. Will post about other problems later.

    If I have not given enough info like , lsmod, dmesg | grep firmware or something else or other info needed just let me know.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It is possible that it is having trouble with the firmware for this card. Check the output of dmesg for any info regarding this.

    Here is some info regarding this chipset. It is usually referred to as orinoco.
    orinoco - Linux Wireless
    You can also download the latest version of all wireless drivers at that site. But they would need to be compiled, and I don't know if you can do that on DSL.

    As for your copy/paste problems. Have you tried keyboard shortcuts? Ctrl+c will copy anything highlighted, Ctrl+v will past it. Also, Ctrl+i will change to italics, and done again will go back.

    Those are the only ones I know, and use them a lot in these forums.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,138
    Thank you waterhead. I bout this card just for DS Linux because of this:
    Verified Wireless Cards - DSL Wiki

    Your suggestion about keyboard shortcuts, I tried it but it seems to be a no go.

    For more info, the led on the card lights up and stays lit.

    I tried taking photo of dmesg readout on screen but it is unreadable and only my wifes Vista box seems to be able to read the card. My Ubuntu Box can't read it and the DS linux box has no USB ports. So if you can bear my typo's here is my dsmeg report

    <4> Unable to identify CD-ROM format
    " VFS: Can't find ext2 file system on dev ide0(3,0)
    '' FAT: bogus logical sector size 0
    " VFS: Can't find a valid FAT folesystem on dev 03:00
    <3> ide-scsi: hdb: unsupported command in request que (0)
    <4> end_request: I/O error, dev 03:40 (hdb) , sector 2
    <4> isofs_read_super: bread failed, dev=03:40, iso_blknum=16, block=32
    <3> same message as above <3>
    <4> end_ request: I/O error, dev 3:40 (hdb) ,sector 2

    water head I am going to move down the readout list as it is very long and I am not a great typer.

    <6> cs: memory probe 0xa0000000-0xa0ffffff:clean
    <6> xir2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+kvh)
    <6> Serial Driver Version 5.05c (2001-07=0 with MANY-PORTS SHARE-IRQ SERIAL-PCI ISAPNP enabled
    <6> ttyS00 at 0x03f8 (irq = 4)) is a 16550A
    <6> tty S01 at 0x02f8 (irq= 3) is a 16550A
    <6> tty S02 at 0x3e8 (irq=4 ) is a 16550A
    <6> eth0: MII link partner: 01e1
    <6> eth0: MII selected
    <6> etho: media 100BaseT, silicon revision 5
    <6> eth0: Xircom: port 0x300, irq3, hwaddr 00:80:C7:F2:FD:A2
    <6> ttyS03 at port 0x2e8 (irq =3) is a 16550A
    <6> usb-uhci.c: $Revision: 1.275 $ time 11:56:o4 Aug 29 2005
    <6> usb-uhci.c: High bandwith mode enabled
    <6> usb-uhci.c: v1.275:USB Universal Host Controller Interface Driver
    <7> hermes.c: 4 DEC 2002 David Gibson <hermes@gibson.dropbear.id.au>
    <7> orinco.c 013d (David Gibson <hermes@gibson.dropbear.id.au> and others)
    <7> orinco_cs.c 0.13d (David Gibson <hermes@gibson.dropbear.id.au> and others)
    <7> eth1: Station identity 001f:0006:0001:0003
    <7> eth1: Looks like an Intersil firmware version 1.3.6
    <7> eth1: Ad-hoc demo-mode supported
    <7> eth1: IEEE standard IBSS ad-hoc mode supported
    <7> eth1: WEP supported, 104-bit key
    <7> eth1: Mac address 00:30:AB:1B:52:18
    <7> eth1: Station name "Prism I"
    <7> eth1: ready
    <7> eth1: index 0x01:Vcc 5.0, irq 5, io 0x0140-0x017f
    <6> parport0: PC-style at 0x378 [PCSPP,TRISTATE,EPP]
    <6> Adding Swap: 177400k swap-space (priority -1)
    <6> eth0: MII link partner: 01e1
    <6> eth0: MII selected
    <6> eth0: media 100BaseT, silicon revision 5
    <3> eth1: Error -110 setting multicast list
    <3> eth1: Error -110 setting multicast list
    <4> Registering unionfs 1.0.14
    <6> eth1 New link status: Connected (0001)
    <3> hermes @ IO 0x140: Timeout waiting for command completion
    <4> eth1: Error -110 disabling MAC port
    <3> eth1: Error -5 setting MAC address
    <3> eth1: Error -5 configuring card
    <6> usb.c: registered new driver hiddev
    <6> usb.c: registered new driver hid
    <6> hid-core.c: v1.8.1 Anreas Gal, Voltech Pavlik <vojtech@suse.cz>
    <6> hid-core.c: USB HID support drivers
    <6> mice: PS/2 mouse device common for all mice
    <6> apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
    <4> hermes @ IO 0x145: Truncating LTV record from -2 to 2 bytes. (rid=0xfc06, Ien=0x0000)

    Whew, end of report, forgive me if I made a typo.
    Appreciate any info you can give in this matter.
    "
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,138
    A thought came into my head just now. I wonder, when I did the initial install the Xircom card using the landline was all I had it its designation then was eth0. I didn't get the Netgear card till a week later. Meanwhile I had svaed my changes to hda3 after shutdown while I had only the Xircom card

    Could the saved changes have affected the Netgear wireless eth0 designation when Xircom used to reside there?

    Because now with both cards inserted , xircom is eth1, and Netgear is eth0.

    The Xircom card still connects over the land line no matter which PCMCIA slot is used or whether it is eth1 or eth0

    Maybe I need to do a complete reinstall to get rid of saved changes.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Nice typing! I can't believe you copied it all that way.

    I see the first error is this:
    Code:
    eth1: Error -110 setting multicast list
    I Googled it, and came up blank. I was checking through the link I posted before, and more links from that page, and don't see anything. I was looking for a way to load new firmware or something. There a mention of extracting firmware from the windows driver, for some cards.

    I did find a firmware utility for Orinoco type cards, but I can't tell if this will help.
    SourceForge.net: Files

    Since I don't have any answers, you could try your suggestion. I would have the wireless card inserted right from the beginning.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #6
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,138
    Thanks again for the attention Waterhead. While googling myself I did a little experiment and booted up a Puppy 3.01 distro I have and it hooked up the wireless with no problem. I think that I might be on the right track with etho being screwed to the pooch with the saved changes when I just had a land line modem. Well I am playing with this Compaq for fun so its off to wiping the hardrive again, smartboot manager my way to cfdisk and start over with just the wireless card. More than likely everything will turn out ok after a clean reinstall. Appreciate the help bro and you have a good week.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •