Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Hi, this is my first post on these forums :P Anyway, I JUST downloaded ubuntu and for some reason and my intel 2200bg wireless card has been working fine. But ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    7

    Intel 2200BG wireless card not working


    Hi, this is my first post on these forums :P

    Anyway, I JUST downloaded ubuntu and for some reason and my intel 2200bg wireless card has been working fine. But I tried hibernating my laptop a couple days ago, and it went all screwy (I can only assume my laptop does not supposed hibernation mode?) and I had to go into the BIOS and reset everything to its default settings. After that, my wireless card stopped working properly, although the package is supposed to be installed already in my version. I've scanned many other forums, and here is the information one would probably need:
    IWCONFIG:

    kyrie@kyrie-laptop:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 radio off ESSID:""
    Mode:Managed Channel:0 Access Point: Not-Associated
    Bit Rate:0 kb/s Tx-Power=off Sensitivity=8/0
    Retry limit:7 RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    irda0 no wireless extensions.


    SUDO LSHW -C NETWORK

    kyrie@kyrie-laptop:~$ sudo lshw -C network
    [sudo] password for kyrie:
    *-network:0
    description: Wireless interface
    product: PRO/Wireless 2200BG Network Connection
    vendor: Intel Corporation
    physical id: 4
    bus info: pci@0000:02:04.0
    logical name: eth1
    version: 05
    serial: 00:12:f0:79:ee:2e
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG:9.0.2.6 (Mar 22 2005) latency=64 link=no maxlatency=24 mingnt=3 module=ipw2200 multicast=yes wireless=radio off
    *-network:1
    description: Ethernet interface
    product: NetXtreme BCM5705M_2 Gigabit Ethernet
    vendor: Broadcom Corporation
    physical id: e
    bus info: pci@0000:02:0e.0
    logical name: eth0
    version: 03
    serial: 00:14:38:06:29:b9
    size: 100MB/s
    capacity: 1GB/s
    width: 64 bits
    clock: 66MHz
    capabilities: pm vpd msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.86 duplex=full firmware=5705-v3.14 ip=192.168.1.102 latency=64 link=yes mingnt=64 module=tg3 multicast=yes port=twisted pair speed=100MB/s

    I have an HP compaq nc8000, the default switch doesn't work in linux (i think it's fn+f2).
    Note that I am a complete newbie to linux; please explain in detail what to do.
    Thank you.

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    If it work before changing the BIOS, then there must be a setting in the BIOS that controls the wireless.

    Go back into the BIOS and look around. See if there is anything for enabling or disabling network cards, or the wireless specifically. Otherwise, try enabling the Wake-on-LAN feature for the wireless card.

    Also take a look at the output of this command for any errors about the wireless.
    Code:
    dmesg | grep eth1
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Oct 2008
    Posts
    7
    I couldn't find anything in the BIOS that controls the wireless card, but when I highlight "Disable wireless card", it says on the bottom : "wireless : enabled/ wireless networking: off", and it seems I can't change it.

    Also, your command didn't do anything :
    kyrie@kyrie-laptop:~$ dmesg | grep eth1
    kyrie@kyrie-laptop:~$


    But when i just did dmesg, i got a long list of names of the parts for my laptop, I just picked out the ones relating to my wireless card:

    [ 44.893129] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
    [ 44.893134] ipw2200: Copyright(c) 2003-2006 Intel Corporation
    [ 44.893593] ACPI: PCI Interrupt Link [C0C6] enabled at IRQ 11
    [ 44.893597] ACPI: PCI Interrupt 0000:02:04.0[A] -> Link [C0C6] -> GSI 11 (level, low) -> IRQ 11
    [ 44.914716] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    [ 46.073463] Synaptics Touchpad, model: 1, fw: 5.9, id: 0x1b6eb1, caps: 0xa84793/0x100000
    [ 46.073469] serio: Synaptics pass-through port at isa0060/serio4/input0
    [ 46.116217] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio4/input/input7
    [ 46.774987] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A03:00/device:01/LNXVIDEO:00/input/input8
    [ 46.786603] ACPI: Video Device [C0CF] (multi-head: yes rom: no post: no)
    [ 48.055909] irda_init()
    [ 48.055927] NET: Registered protocol family 23
    [ 48.135412] Detected unconfigured HP nc8000 family SMSC IrDA chip, pre-configuring device.
    [ 48.135417] Setting up Intel 82801 controller and SMSC device
    [ 48.135433] Detected Chip id: 0x5a, setting up registers...
    [ 48.135571] found SMC SuperIO Chip (devid=0x5a rev=00 base=0x004e): LPC47N227
    [ 48.135587] smsc_superio_flat(): fir: 0x130, sir: 0x2f8, dma: 03, irq: 5, mode: 0x0e
    [ 48.135601] SMsC IrDA Controller found
    [ 48.135602] IrCC version 2.0, firport 0x130, sirport 0x2f8 dma=3, irq=5
    [ 48.135651] smsc_ircc_set_sir_speed(), Setting speed to: 9600
    [ 48.135663] No transceiver found. Defaulting to Fast pin select
    [ 48.153864] parport_pc 00:05: reported by Plug and Play ACPI
    [ 48.153914] parport0: PC-style at 0x378 (0x77, irq 7, dma 1 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
    [ 48.251548] tpm_inf_pnp 00:0c: Found C197 with ID IFX0101
    [ 48.251586] tpm_inf_pnp 00:0c: TPM found: config base 0xe0, data base 0x1400, chip version 0x0006, vendor id 0x15d1 (Infineon), product id 0x0006 (SLD 9630 TT 1.1)
    [ 49.685581] ipw2200: Radio Frequency Kill Switch is On:
    [ 49.685584] Kill switch must be turned off for wireless networking to work.
    [ 49.822281] IrDA: Registered device irda0
    [ 49.830098] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a

    The one that intrigues me the most is this part:
    [ 49.685581] ipw2200: Radio Frequency Kill Switch is On:
    [ 49.685584] Kill switch must be turned off for wireless networking to work.

    So how would I turn off the kill switch?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It looks like you have a keyboard switch to enable/disable the wireless. If this is a hardware switch, you should be able to activate the wireless no matter what operating system is installed.

    If it is a software switch, then you will need to install a Linux software switch. You can get it from here.
    SourceForge.net: Wireless Radio Software Switch

    For more info on this, check out this thread.
    [SOLVED] centrino - Radio Frequency Kill Switch - Ubuntu Forums
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    7
    Thanks. I'll install it when I get home.
    Also, I don't have a hardware switch to turn on anyone on my laptop, so I'm guessing i'll need a software one.

  7. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You don't say what kind of laptop it is, but my Dell has alternate function keys. There is a key with the blue Fn on it. Holding down that key while pressing other keys with blue functions, will perform those actions. Mine don't work in Linux, and there isn't one for the wireless either.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #7
    Just Joined!
    Join Date
    Oct 2008
    Posts
    7
    I actually stated it in the first post, it's an HP compact nc8000 (series pp2190).
    There are blue buttons (and fn), but they don't show anything relating to the wireless network card.

    edit: spelling
    Last edited by Kyrie; 10-12-2008 at 07:47 PM. Reason: spelling

  9. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I looked for the type of laptop, and didn't see it.

    Oh, now I see it, at the end of your post. Was looking at the beginning with all of the other info.

    I hope the software switch works, keep us posted.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #9
    Just Joined!
    Join Date
    Oct 2008
    Posts
    7
    Ugh...I have no idea how this is supposed to work.
    Okay, I downloaded a tar.gz file off of sourceforge, extracted it, and now I have a folder with some .c (c++?) files and some text documents.
    I read the readme, but I still have no idea what to do.
    Any tips, waterhead?

  11. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The README and ISSUES files have some commands the you can copy to a terminal and run. They are to determine if you can use this program, and which module to use.

    I also gave a link to the Ubuntu forums where a poster posted the install process, and the dependencies that they had to first install.

    Actually, you would do make clean, make, and then as root (sudo) make install.

    I tried to compile it with my 2.6.26 kernel, but it failed. I'll try it on another distro and report back. You should try it too, have you ever compiled from source before?
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •