Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
im on Ubunutu Hardy Heron 8.04 .... im using a fujistu tablet : here are the specs of my tablet - http://docs.fujitsu-siemens.com/dl.a...d-8318b48d5fe8 and this is what happens when i run ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8

    im on Ubunutu Hardy Heron 8.04 .... im using a fujistu tablet : here are the specs of my tablet -
    http://docs.fujitsu-siemens.com/dl.a...d-8318b48d5fe8
    and this is what happens when i run the commands in root terminal:
    Code:
    linux@linux-laptop:~$ sudo ifdown
    [sudo] password for linux: 
    ifdown: Use --help for help
    linux@linux-laptop:~$ sudo ifup
    ifup: Use --help for help
    linux@linux-laptop:~$

  2. #12
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You need to specify the network device, like you did before.
    Code:
    sudo ifdown wlan0
    Code:
    sudo ifup wlan0
    And you can use the --help with any command for usage information
    Code:
    $ ifdown --help
    usage: ifdown <device name>
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #13
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8
    Code:
    linux@linux-laptop:~$ sudo ifdown wlan0
    ifdown: interface wlan0 not configured
    linux@linux-laptop:~$ sudo ifup wlan0
    Ignoring unknown interface wlan0=wlan0.
    ... im not sure what you mean by network device -- is it the name of the wireless internet at my house ?? or what ?? ... but thats what happens when i put the codes in ....

  4. #14
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    In this case:
    network device = wlan0

    And you did set it up in the "Network" section? If so, then there must be a software switch that has it turned off.

    I have found a kernel module for such a switch. On my self-compiled kernel, it is not enabled, but it may be on your kernel. You can see if it loads, with this command.
    Code:
    sudo modprobe iwlwifi_rfkill
    I'm not sure how to toggle it on/off. But possibly with an option when you modprobe it. But first you need to remove it.
    Code:
    sudo modprobe -r iwlwifi_rfkill
    Code:
    sudo modprobe iwlwifi_rfkill=1
    If you get an error when trying to load the iwlwifi_rfkill module, then you don't have it compiled into the kernel.

    I am going to suggest that you download and compile the latest wireless drivers from here:
    Download - Linux Wireless
    Last edited by waterhead; 10-25-2008 at 12:25 PM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #15
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Oh, bye the way.

    I did find a Fujitsu kernel module, but it says it only is for adjusting the LCD brightness. There is no mention of a wireless switch. On my kernel, it too is not compiled. It can be found in the kernel source, at this location.

    Device Drivers --->
    Misc devices --->
    Fujitsu Laptop Extras
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #16
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    If indeed this is because of a kill switch being active, then read through this link. It may have some advice that you can try out.

    Bug 1454 &ndash; on Fedora (rawhide) iwl3945 module loads but doesn't work (RF kill switch issue)

    EDIT: The page linked to above has a link to an add-on software switch program, this could be what you need.

    http://rfswitch.sourceforge.net/
    Last edited by waterhead; 10-25-2008 at 01:36 PM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #17
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8
    Code:
    linux@linux-laptop:~$ sudo modprobe iwlwifi_rfkill
    [sudo] password for linux: 
    FATAL: Module iwlwifi_rfkill not found.
    linux@linux-laptop:~$ sudo modprobe -r iwlwifi_rfkill
    FATAL: Module iwlwifi_rfkill not found.
    linux@linux-laptop:~$ sudo modprobe iwlwifi_rfkill=1
    FATAL: Module iwlwifi_rfkill=1 not found.
    linux@linux-laptop:~$
    ... ill try reading that thing about the kill switch

  8. #18
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    OK, I'm going to suggest that you install the latest driver package from LinuxWireles.org. It isn't really a package, but the sources, that need to be compiled.

    Download - Linux Wireless

    This driver 'rollup' also appears to contain the extra modules needed for specific laptops. I think that the fujitsu_laptop module is included, but I can't tell for sure. When having problems, it is always best to get the latest drivers anyway. There may be bug fixes that solve your problems.

    Do you still have Windows on this too? Can you boot into it and check the wireless settings? You would want to set the power at full, and change any other settings that may be interfering with it working in Linux.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •