Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Hi. How can I make my wlan working. I have Fujitsu-Siemens Amilo 1718 and with Fedora 9. I also tried other systems like Ubuntu, but with the same effect. The ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Location
    Manchester UK
    Posts
    4

    Wifi on Fujitsu-Siemens (Atheros chipset) - can't make it going


    Hi. How can I make my wlan working. I have Fujitsu-Siemens Amilo 1718 and with Fedora 9. I also tried other systems like Ubuntu, but with the same effect. The wifi button nor the wifi card does not work for me.
    My other attempt was to set up wlan malually where the wifi card seemed to got recognised by Network Manager (see screenshot) however after I click Activate, there was this error message:

    Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; Invalid argument.

    Determining IP information for wlan0... failed.

    I am complete novice to Linux environment, but one has to start somewhere.

    Thnx.
    Attached Images Attached Images

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hi lopata, Welcome to Linux Forums.
    Getting your wireless card working in Linux can be confusing sometimes but be strong and patient.
    Take a look at this thread and post the output from those commands here, hopefully we can get you up and running.
    http://www.linuxforums.org/forum/wir...tup-linux.html
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Oct 2008
    Location
    Manchester UK
    Posts
    4
    I believe my wifi card is PCI Atheros. Ndiswrapper did not work. In fact I am not sure about the driver for this card as the laptop model I bought was designed for Vista only and even run XP was not easy to do and loads of additional tweaks of 300MB in size in total had to be installed.
    Anyway the output from
    /sbin/lspci -nn
    is below:

    [root@localhost ~]# /sbin/lspci -nn
    00:00.0 Host bridge [0600]: ATI Technologies Inc Unknown device [1002:5a31] (rev 01)
    00:01.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a3f]
    00:04.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a36]
    00:12.0 IDE interface [0101]: ATI Technologies Inc IXP SB400 Serial ATA Controller [1002:4379] (rev 80)
    00:13.0 USB Controller [0c03]: ATI Technologies Inc IXP SB400 USB Host Controller [1002:4374] (rev 80)
    00:13.1 USB Controller [0c03]: ATI Technologies Inc IXP SB400 USB Host Controller [1002:4375] (rev 80)
    00:13.2 USB Controller [0c03]: ATI Technologies Inc IXP SB400 USB2 Host Controller [1002:4373] (rev 80)
    00:14.0 SMBus [0c05]: ATI Technologies Inc IXP SB400 SMBus Controller [1002:4372] (rev 83)
    00:14.1 IDE interface [0101]: ATI Technologies Inc IXP SB400 IDE Controller [1002:4376] (rev 80)
    00:14.2 Audio device [0403]: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller [1002:437b] (rev 01)
    00:14.3 ISA bridge [0601]: ATI Technologies Inc IXP SB400 PCI-ISA Bridge [1002:4377] (rev 80)
    00:14.4 PCI bridge [0604]: ATI Technologies Inc IXP SB400 PCI-PCI Bridge [1002:4371] (rev 80)
    01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RC410 [Radeon Xpress 200M] [1002:5a62]
    02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter [168c:001c] (rev 01)
    0a:07.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)
    [root@localhost ~]#

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    It's an Atheros alright. The screen shot that you posted.......your card has the drivers installed already or you wouldn't see the device listed in the Network tool. Have you tried clicking on the Hardware tab (in the screen shot) and try to create a new connection? Also keep in mind that you must shutdown the Ethernet to get the wifi working, you can't have two cards working at the same time.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #5
    Just Joined!
    Join Date
    Oct 2008
    Location
    Manchester UK
    Posts
    4
    I tried to set up the wireless connection from top bar on my screen, I also used System--> Administration--> Network manager. No success. While I was duing that, the cable from wired connection was unplugged (good point).
    Picked from other linux forums: Is it possible that the button on my laptop usually in Windows enabling wifi, needs to be activated somehow before I can progress any further?
    Thank you.
    Attached Images Attached Images

  7. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I am having a hard time viewing the screenshots, they are so small on my monitor.
    Is it possible that the button on my laptop usually in Windows enabling wifi, needs to be activated somehow before I can progress any further?
    anything is possible, does the button not work in Linux?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I have been trying to gather some info on the wireless kill switches. I don't have a specific method for this, yet, but it usually involves a module called rfkill or rf_kill.

    Post the output of this command:
    Code:
    lsmod
    That wireless is the same as the one in my Eee Pc, so it works. And those screenshots are REAL TINY on an Eee Pc screen!

    OT
    Also, there is a kernel module for Fujitsu lifebooks. I believe that it is only for LCD brightness control. It is not compiled on my system, but it may be on yours. You can try and load it:
    Code:
    modprobe fujistu_laptop

    /OT

    I have gathered a few commands on checking the status of the kill switch. If the module is loaded, we can try them.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #8
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    So some kill/enable switches do not work with Linux? What a major disaster that would be........that would be enough to stop most people from trying Linux.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  10. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I know, it sucks!

    There are two types of switches, hardware and software. Sometimes they have both. Some of the wireless drivers have a rfkill module included with them. I know that the b43 driver does, because I manually loaded it once. Now it automatically loads every time, and I don't even have a wireless switch on my laptop.

    The b43 driver has two parts to the rfkill module:
    rfkill
    rfkill_input

    I think the rfkill_input is for setting the state of the rfkill module. Something like this:
    Code:
    modprobe rfkill_input=0
    Or something like that, I'm not really sure. Here's an example of checking the state of the kill switch:
    Code:
    cat /sys/bus/pci/devices/0000\:03\:00.0/rf_kill
    The command should be modified for your system and devices. Here is one for a iwl3945 driver:
    Code:
    cat /sys/bus/pci/drivers/iwl3945/module/drivers/pci\:iwl3945/0000\:10\:00.0/rf_kill
    To change the state of it, a command like this is used:
    Code:
    echo "1" >> /sys/bus/pci/drivers/iwl3945/module/drivers/pci\:iwl3945/0000\:10\:00.0/rf_kill
    I poked around in my laptop, and came up with the location of the kill switch state for my b43 driver:
    Code:
    $ cat /sys/bus/ssb/drivers/b43/module/drivers/ssb\:b43/ssb0\:0/rfkill:rfkill0/state
    1
    I haven't tried to change mine, because it works and I don't want to screw it up! As you can see in my example, the state is "1".
    Please do not send Private Messages to me with requests for help. I will not reply.

  11. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I just booted into Linux Mint (Ubuntu) on the same laptop. Here's the command to find the rfkill state on that, and the results.
    Code:
    paul@laptop ~ $ cat /sys/bus/pci/drivers/b43-pci-bridge/0000:02:02.0/ssb0:0/rfkill/rfkill0/state
    1
    I tried the command from my previous post, and that worked in Mint too. There are a lot of links in these folders.

    EDIT: I found the direct route, without all of the links, in case anyone is following this side-track of mine.
    Code:
     cat /sys/devices/pci0000:00/0000:00:1e.0/0000:02:02.0/ssb0:0/rfkill/rfkill0/state
    Last edited by waterhead; 11-03-2008 at 01:32 AM. Reason: Added edit
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •