Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
I have Fedora 8 on a 500GB external flash drive and am booting my laptop (Vista) off the hard drive and using Linux. On my laptop i connect to the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie Huntsman191's Avatar
    Join Date
    Nov 2008
    Posts
    132

    Ndiswrapper Help


    I have Fedora 8 on a 500GB external flash drive and am booting my laptop (Vista) off the hard drive and using Linux. On my laptop i connect to the internet via a wireless connection but i cant connect to the internet on Linux. My wireless card is Intel Pro 3945BG. I tried installing the driver for my wireless card but received errors and due to the fact im VERY new to linux, i find it hard to work through there errors or understand the jargon. So, in a last try, ive tried Ndiswrappper. Following the installation insturctions i did:

    tar -zxvf ndiswrapper-1.44.tar.gz
    make
    make install

    This is where the commands stop working.

    The instructions tell me to use "ndiswrapper -l" then "ndiswrapper -e driver_name.inf". The first command says it should list the drivers then the second command erases the old driver. Not even the first command works. I recieve an error saying "Unable to find directory /etc/ndiswrapper".

    Can anyone tell me how to fix this? I really love Linux but without internet ill have to stick to crappy windows. Please. Help.

  2. #2
    Linux User geese's Avatar
    Join Date
    Jan 2005
    Location
    Florida / Trinidad W.I.
    Posts
    290
    Did you try using the native Linux drivers for this card?
    I would try the Linux drivers before using windows drivers and ndiswrapper.

    If you install the Linux drivers and still can't get network open a terminal and type "su" and enter your root password.
    Then enter "iwconfig" and post the result here.

  3. #3
    Linux Newbie Huntsman191's Avatar
    Join Date
    Nov 2008
    Posts
    132
    ive tried installing the Linux drivers but due to my infamilirity with Linux was unable to do so. I always get a variety of errors. The two drivers ive been trying to install are iwlwifi and mac80211. It says the iwlwifi requires the mac module however neither will install. Are these the right modules?

    and i ran iwconfig i got:

    --------------------------
    lo no wireless extensions
    --------------------------

    Did any of that help?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie Huntsman191's Avatar
    Join Date
    Nov 2008
    Posts
    132
    i just realised that prior to 'attempting' to install ndiswrapper, Fedora Network setup recognised the card but when i tried to use it it wouldnt work. If it recognised the card, does that mean the driver was pre-installed? i would just haev to change the settings? because i just selected all defaults..

  6. #5
    Linux User geese's Avatar
    Join Date
    Jan 2005
    Location
    Florida / Trinidad W.I.
    Posts
    290
    okay, yes it is possible that the drivers were already installed and all you would have need to do is configure it.

    Go to add/remove software and do a search for "3945", then check if "Firmware for intel . . .3945 . . network adaptor" is installed.
    If it is, remove it and then reinstall it.

    next, go to Network device control and check if you are seeing the wireless device.
    If you are seeing it, do "iwconfig" in a terminal and post the results here.
    If you do not see it try rebooting your machine and checking again.

    If you are still not seeing it and the firmware is installed, we will then install the windows drivers with ndiswrapper.

  7. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Before trying to use NDISwrapper, I would like to help you use the native Linux driver. Please read through the post linked to below, and post the output of the commands here in this thread.
    http://www.linuxforums.org/forum/wir...tml#post589924

    Instead of the plain dmesg command, use this command.
    Code:
    dmesg | grep firmware
    Post the output of that command too.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #7
    Linux Newbie Huntsman191's Avatar
    Join Date
    Nov 2008
    Posts
    132
    I tried to run add/remove programs but it says unable to retrieve repository and then closed down. I thought id try a standard file search and i got three files with the red symbols, were MIME applications and atleast one of them was in /lib/firmware. They were:
    iwl3945.h
    iwlwifi-3945.ucode
    iwlwifi-3945-l

    I have no idea where to go from there. It still didnt RE-recognise my wireless card. And i ran those commands, i got.

    /sbin/lspci -nn == Network Controller Intel PRO 3945 ABG Network Connection

    for lsmod i received which modules were being used? would you like me to enter these? and dmesg | grep firmware printed no visible information. It just accepted the command.

    Does any of this help?

  9. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I don't want you to edit anything. Post the entire output of the commands. You can't know what it is that I am looking for, as sometimes I don't know until I see it.

    Post the entire output of this command then.
    Code:
    dmesg
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #9
    Linux Newbie Huntsman191's Avatar
    Join Date
    Nov 2008
    Posts
    132
    when i ran the dmesg command i recieved page after page of technical information. I copied it into a txt file however since my Linux is on an external hard drive i cannot access the hard drive through windows to retrieve the txt file. I used to transfer the text file to the Windows hard drive in Linux, but since i started messing around with ndiswrapper and drivers it says "Unable to mount volume". it says that for all non-local drives. I tried a USB. Same thing. Its just since i started using ndiswrapper. If you had an idea what you were looking for i could copy it by hand? sorry for all the hassles.

  11. #10
    Linux User geese's Avatar
    Join Date
    Jan 2005
    Location
    Florida / Trinidad W.I.
    Posts
    290
    Just curious, are you able to get network if you use a LAN (hard wire) connection?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •