Find the answer to your Linux question:
Results 1 to 4 of 4
Hey all, I am not too good with all this quite yet... Here's what's up: I am running ThinkPad T23 with antix 7 (a Mepis derivative). The wireless card is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2008
    Posts
    2

    Wireless used to work... Aironet 350 running antix 7 (Mepis)


    Hey all,

    I am not too good with all this quite yet... Here's what's up: I am running ThinkPad T23 with antix 7 (a Mepis derivative). The wireless card is a Cisco Aironet 350. I have been connecting to my home's wireless network for several months. The system uses WEP encryption, and I have traditionally used dhcp to get my IP. Yet, last week, I tried moving my computer to another wireless network- one at Chicago Public Schools- where I am an after school teacher. I got this SSID and a WPA code, and I reconfigured in mnetwork. It didn't work because it needed some fancy encrytion stuff that makes things easy for Windows and hard for everyone else. So, a long story short- I gave up on trying to connect to the school wireless pretty quickly. Anyway, the problem is that when I returned home, I reset my SSID and WEP key, but I cannot get on the wireless network here. I am sure it still works and I am sure that I put in the correct terms. My roommates (running MacOS) have not had any problems. Here is where I am at...

    My wireless interfaces are eth1 and wifi0. In mnetwork, I have both of these configured with my house's SSID and WEP code. All other interfaces are not activated. Now, first, I tried to use DHCP to recieve an IP address, but I kept having trouble with this. Repeatedly, I would get an error saying that dhcp packets were not being retrieved. So, I suspected that maybe my router did not have dhcp on it? I changed my setting for both of these interfaces to have generic static IPs and typical subnet, broadcst, etc. addresses. Then, upon activation of these interfaces, I had some success. Mnetwork now indicates that the two are activated, but I still haven't any internet connection. I looked at my roommate's mac (which I am using now), and his network configuration says that his IP was assigned via dhcp. So, of course, dhcp must in fact be on our router... So, the real problem must be somewhere else. I do not know what to do at this point. What should I be looking for now?

    I know that the card works, for "iwlist scan" shows our SSID on these interfaces, so it is sending and recieving. What could be the problem? What other ends of the configuration should I be looking at? Any help would be much appreciated. My startup log now says (something like):

    Starting networking....
    * Not starting ipw3945 regulatory daemon, driver not loaded.

    So, maybe this is part of the problem. I never payed attention before to see if message was there in the past.


    Okay, I hope you all are having wonderful weekends! Thanks for the help!

    Nick

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Did you update the kernel recently?

    Another thing to check is the default gateway that the wireless is set to. It may have gotten changed when you tried to connect to the other network.

    Check the full output of this command for info and error messages concerning the wireless.
    Code:
    dmesg
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Nov 2008
    Posts
    2
    waterhead,

    Thank you much for the reply. So, I have not updated the kernel at all recently. Also, I ran 'dmesg', ad it doesn't seem to be indicating any errors. Yet, the output was pretty extensive, and I am not too sure what to be looking for. As for the gateway config, I am thinking that the problem is here...

    Running 'route' and '/sbin/route', I get completely blank tables. I suppose that there should be some routing assigned, but there are none. Thus, I tried adding a route:

    # route add default gw 192.168.1.254 eth1

    Resulted in:

    SIOCADDRT: No such process

    So, does this mean that my routing is messed up? Recommended next step? If not, I am condidering these two tacks:

    A) In looking at the problem pretty extensively online, I have begun to suspect that my network manager "mnetwork" is causing the problem... Might you (or someone else) know how to disable the program temporarily so that I can be sure it is not affecting configuration?

    B) Reloading OS. Quick and dirty.

    Thanks a ton!

    Nick

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I've never used Antix or Mepis, so I can't offer with any distro specific help.

    There is a Linux command to obtain a DHCP license, you can try it.

    dhclient eth1

    Change the network device to the one you are trying to connect with.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •