Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I want to use tl-wn422g wireless usb adapter on fedora. The device has an atheros 5007UG chipset, supported by zd1121 driver. A driver named zd1121rw was built into the kernel. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2008
    Posts
    17

    tl-wn422g wireless usb adapter


    I want to use tl-wn422g wireless usb adapter on fedora. The device has an atheros 5007UG chipset, supported by zd1121 driver. A driver named zd1121rw was built into the kernel. When I plug in the device, zd1211rw module gets automatically loaded.

    But I can't proceed any further. iwconfig output is
    Code:
    wlan0     IEEE 802.11g  ESSID:"" 
              Mode:Managed  Channel:0  Access Point: Not-Associated  
              Tx-Power=0 dBm  
              Retry min limit:7   RTS thr:off   Fragment thr=2346 B  
              Encryption key:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Trying to bring up the interface using
    Code:
    ifconfig wlan0 up
    gives error:
    Code:
    SIOCSIFFLAGS: Connection timed out
    so, nothing can be done with this device until the interface is up.

    I have also tried the new zd1211 driver from linuxwireless.org (compact- wireless) but it gives same results.

    Any Suggestions...?

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You may not have the firmware installed, needed for the wireless to work.

    zd1211rw - Linux Wireless
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Nov 2008
    Posts
    17
    I have the firmware installed. All the files from zd1211-firmware-1.4.tar.bz2 are copied into /lib/firmware/zd1211. But still the same situation.

    Kindly review the dmesg output if needed.
    Attached Files Attached Files

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Your dmesg output has no mention of wlan0 or zd1211rw, and that is odd.

    I do see that SELinux is active. This may interfere with the wireless connection, so disable it and try again.

    Also, put a copy of the firmware directly in the /lib/firmware folder, it may not be looking for it in the /zd1211 sub-directory.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Nov 2008
    Posts
    17
    Hi waterhead,

    Thanx for your support. I have disabled selinux and copied the zd1211 firmware in the lib/firmware directory. Now the dmesg output shows loading of zd1211rw driver.

    But still, when I try to bring up the interface, it is giving error of SIOCSIFFLAGS: Connection timed out.

    Any Idea....?
    Attached Files Attached Files

  7. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    In the future, just post the output of dmesg in your post. I would rather not have to download a zipped file from an unknown source.

    I still see a lot if SELinux messages, so it still is running. This may or maynot be your problem, though.

    Have you configured the device in the Network section? You can start it with this command:
    Code:
    system-config-network
    Click on the device and click Edit. Select Controlled by NetworkManager and use DHCP for the connection.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #7
    Just Joined!
    Join Date
    Nov 2008
    Posts
    17
    Sorry for attaching the zip files. I had to do so, bcoz size of text file exceeded the allowable limit.

    Anyhow, main problem is that this device DOES NOT APPEAR in the Network configuration dialog. Even I can't add it through 'New' wizard bcoz when I click 'New' and select 'Wireless Connection', my device does not appear there. (There is only one entry 'Other Wireless Card' which shows a very limited list if wireless cards)

  9. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You could try running the kudzu command. Try this to see if it lists the wireless card. (as root)
    Code:
    kudzu -p -c network
    This only probes the system and prints out what it finds. Then just run kudzu without any options. That is suppose to configure new hardware. Then run the first command again to see if it is any different.

    Is there a configuration file for it in the /etc/sysconfig/networking or networking-scripts
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #9
    Just Joined!
    Join Date
    Nov 2008
    Posts
    17
    Running kudzu without any arguments and then running kudzu -p gives info about this card. (don't recognizes it as a network interface)
    Code:
    -
    class: OTHER
    bus: USB
    detached: 0
    device: wlan0
    driver: zd1211rw
    desc: "ZyDAS USB2.0 WLAN"
    usbclass: 255
    usbsubclass: 0
    usbprotocol: 0
    usbbus: 1
    usblevel: 1
    usbport: 6
    usbdev: 3
    vendorId: 0ace
    deviceId: 1215
    usbmfr: ZyDAS
    usbprod: USB2.0 WLAN
    -
    There is no configuration file for this interface in the paths mentioned.

  11. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You may have to try manually adding it. First, open the file /etc/sysconfig/hwconf in a text editor, as root (use su). Then try changing this:
    Code:
    class: OTHER
    to this:
    Code:
    class: USB
    If that doesn't work, you may need to add it to the file that lists the other network devices. The problem is, I can't find that which file it is using. You may need to make a file for it in the /etc/sysconfig/network-scripts/ and call it ifcfg-wlan0. Here is one that I have.
    Code:
    # Please read /usr/share/doc/initscripts-*/sysconfig.txt
    # for the documentation of these parameters.
    TYPE=Wireless
    DEVICE=wlan0
    HWADDR=00:00:00:00:00:00 <change this>
    BOOTPROTO=dhcp
    NETMASK=
    DHCP_HOSTNAME=
    IPADDR=
    DOMAIN=
    ONBOOT=no
    USERCTL=yes
    PEERDNS=yes
    IPV6INIT=no
    ESSID=<change this>
    CHANNEL=1<change this?>
    MODE=Managed
    RATE=Auto
    NM_CONTROLLED=yes
    Change the ones that I indicated. You need the MAC address for the HWADDR. I removed any info related to my wlan0 setup.

    EDIT: There seems to be an identical file in the /etc/sysconfig/network folder. Maybe you need to put a copy of it in there too.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •