Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm trying to get wireless to work with an Edimax 7318UG USB adapter on PCLinuxOS 2007. From what I've read it has the either of two infamous chipsets: rt73 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    13

    Edimax 7318UG wireless USB in PCLOS 2007


    Hi, I'm trying to get wireless to work with an Edimax 7318UG USB adapter on PCLinuxOS 2007. From what I've read it has the either of two infamous chipsets: rt73 and rt2571. When I used the LiveCD and after first installing the wireless network was detected but I couldn't connect. No matter what I did I could not set security to WPA. The settings kept reverting back to Open WEP. Itried the advice on this page:
    PCLinuxOS
    And blacklisted the following:
    blacklist rt2570
    blacklist rt2500usb
    blacklist rt73usb
    blacklist rt73
    After that I downloaded and installed the rt73 drivers from serialmonkey. I can't use ndiswrapper since I can't find the driver CD. After installing the serialmonkey driver I still got the same behavior, could detect network but could not change security settings nor connect. So I changed the settings on the router. Set SSID broadcast to on and security/encryption to none. After some fiddling I finally got a connection to the router, but couldn't browse the Internet. When I typed in IP addresses it worked fine so I tried to change DNS settings. No matter what I set DNS to it wouldn't work. I tried restarting the computer but after the restart I could not connect at all, even without security. So I dragged the whole setup and connected it to the router via Ethernet. After updating the system it seems to have gotten worse, now I can't detect the wireless network. Also, when I try deleting/reinstalling the wireless, it now lists two identical devices instead of just one. I tried the serialmonkey rt2570 driver but when I type "modprobe 2570" the computer just slows down horribly and I end up restarting it. Whew. Help!

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    First, don't install NDISwrapper yet. It will just make things harder to sort out.

    When you updated your system, it most likely installed a newer kernel. Any driver module that you compiled yourself will have to be done again for the new kernel.

    Before you do that, let's see if the newer kernel has better luck with the wireless. Remove the blacklisting that you previously did, and then reboot the system. Then run these commands, and post the output.
    Code:
    lsusb
    Code:
    lsmod
    Code:
    ifconfig
    Code:
    iwconfig
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Dec 2008
    Posts
    13
    Hello, sorry for the late reply. For some reason I can't complete registration on the PCLOS Forum, so I decided to try other distros. I had video problems with Fedora 10 so I tried Mandriva 2009. Wireless worked out of the box. Isn't PCLOS based on Mandriva?

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I'm not familiar enough with those distros to comment on them. As for the video problems, you may need to install a driver from the card's manufacturer.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •