Find the answer to your Linux question:
Results 1 to 8 of 8
I've just updated my Xubuntu up from 8.04 to 8.10 Wierdly, my Belkin 54g card (BCM43xx) which has caused me so many difficulties getting working on linux is working great ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Location
    Wiltshire, UK
    Posts
    32

    no network manager after update to Xubuntu 8.10


    I've just updated my Xubuntu up from 8.04 to 8.10

    Wierdly, my Belkin 54g card (BCM43xx) which has caused me so many difficulties getting working on linux is working great and I can access the internet no probs.
    But in the network icon in the taskbar there is a small ! mark on it and when I click nothing is selectable and it says "device is unmanaged".

    Also, in preferences/settings there is no network manager like there was in 8.04.

    How do I get network manager back?

    Edit: I looked in add/remove programs and saw that "network manager" is installed but I guess it doesn't work in Xubuntu as it is a GNOME frontend thingy and Xubuntu is XFCE.
    So I removed it and installed another program called network - which works and I can see my devices and connections but the icon at the top still says "device is unmanaged"

  2. #2
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3
    I have the same problem.

    I'm able to start the metwork manager config tool using 'nm-connection-editor' in a terminal (you can put it on a launcher or in the menu), but no icon in the system tray or panel applet.

    Any help?

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3
    I'm taking it back. I was playing with another system tray app (stalonetray) and the two sys tray apps had some conflicts. After uninstalling stalonetray and rebooting I got back my regular sys tray with the network manager icon.

    miocene, 'nm-connection-editor' should solve your problem.

  4. #4
    Just Joined!
    Join Date
    Jul 2005
    Location
    Wiltshire, UK
    Posts
    32
    cool, that works - but I dont have an icon in the taskbar.
    How do I get one?

  5. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3
    Try nm-applet. You can put that in your 'Autostarted Applications' (Menu / Settings / Settings Manager / Autostarted apps)

  6. #6
    Just Joined!
    Join Date
    Jul 2005
    Location
    Wiltshire, UK
    Posts
    32
    Sorry I need to ressurect this topic as my problem isn't solved.
    I have a network connection icon in the taskbar but it has a small "!" on it.
    When I click it it says "device is unmanaged".
    When I am at home it connects to my (unsecured) network fine, but I can't seem to get it to connect to my (secured) network at uni, even when I go into nm-connection-editor.

    How do I get the connection editor to "manage" my wireless card?

    EDIT: I don't know if this matters but since the update to 8.10 I have only been able to boot into Xubuntu through recovery mode. It freezes if I let it boot normally (If anyone can help me with this that that would be appreciated - but another topic)
    Does booting through recovery mode affect network management (bearing in mind my internet (and hence my wifi card) was working at home (albeit "unmanaged"))

  7. #7
    Just Joined!
    Join Date
    Feb 2009
    Posts
    1

    i think i got what you need

    i hope that is what your looking for. i just found this, and i know alot of people are looking for it.

    vincentkong.com Blog Archive Networking Browsing with Xubuntu

  8. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The best way to manage all network connection in Xubuntu, is to install Wicd.

    wicd - home
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •