Find the answer to your Linux question:
Results 1 to 10 of 10
I have a Broadcom BCM4311 wireless card. I successfully created a dual-boot with Fedora 10 and Windows Vista. My only problem is getting the wireless card to activate in "Network ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6

    Cool Broadcom BCM4311 W/ Fedora 10


    I have a Broadcom BCM4311 wireless card. I successfully created a dual-boot with Fedora 10 and Windows Vista. My only problem is getting the wireless card to activate in "Network Config".

    I have installed the b43 driver from b43 - Linux Wireless as suggested in other posts. In "Network Config" it lists the wireless card as "wlan0 (b43)". That makes me think that the driver is recognized and installed. I have confirmed that the driver is in /lib/firmware.

    In "System-Config-Network" the following error is reported:
    Error for wireless request "Set Mode" (8B06): SET failed on device wlan0; invalid argument.
    In "SELinux" the following is reported:
    SELinux is preventing consoletype (consoletype_t) "read" to /var/lib/dhclient/dhclient-wlan0.leases (dhcpc_state_t).
    If you know what I can do to resolve this issue I would appreciate it. Thanks in advance.

    CB
    Last edited by waterhead; 01-08-2009 at 11:24 PM. Reason: fixed linuxwireless.org link

  2. #2
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6

    Turned SELinux Off - still not working

    I read some more posts and decided to disable SELinux, but I still cannot activate the wlan0 wireless card in "Network Config".

    CB

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6

    Ran iwconfig

    I ran iwconfig and this is what it said:

    lo no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11bg ESSID:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=27 dBm
    Retry min limit:7 RTS thr:off Fragment thr=2352 B
    Power Management:off
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    eth0 no wireless extensions.

    pan0 no wireless extensions.

    The light on my wireless card is lit up - suggesting that it is working, but I cannot see any networks to connect to.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The b43 driver is included in the kernel, so there is no need to install it. What you do need to install is the firmware, that is what goes in the /lib/firmware folder. Your link to LinuxWireless.org tells me that you have already done this.

    Sometimes it needs the firmware to be in it's own folder, named b43. Run this command, and post the output.
    Code:
    dmesg | grep firmware
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6
    I ran dmesg | grep firmware and here is the output:

    firmware: requesting intel-ucode/06-0f-0d
    firmware: requesting intel-ucode/06-0f-0d
    firmware: requesting b43/ucode13.fw
    firmware: requesting b43/b0g0initvals13.fw
    b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)

  7. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    That looks good.

    Open the Network GUI (/usr/bin/system-config-network in a terminal). Double click on the wireless. Check the boxes next to "Controlled by NetworkManager" and "Allow all users to enable and disable the device". Also set it to "Automatically obtain IP address settings with dhcp" and "Automatically obtain DNS information from provider".

    Exit and save the new configuration. You may need to reboot to get the new cofiguration loaded. You can then use NetworkManager to connect to wireless networks. You can access it through the icon in the system tray (taskbar). It is usually next to the date/time.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #7
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6
    I installed Knetwork Manager and I am able to see the networks available now. I am now connected wirelessly. WHOOT!

  9. #8
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6
    THANKS! I got it working!

  10. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Glad to hear it.

    I would have thought that (K)NetworkManager would be installed by default.
    Please do not send Private Messages to me with requests for help. I will not reply.

  11. #10
    Just Joined!
    Join Date
    Jan 2008
    Posts
    1
    Try the wicd utility or see this: http://billconner.com/techie/wireless_nic.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •