Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, Have been trying to get my Atheros AR242x 802.11abg wireless card to work on suse 11.0 installed on Hp laptop doing dual boot with windows vista to no avail. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3

    Atheros 242x wiereless card not working on suse 11.0


    Hi,

    Have been trying to get my Atheros AR242x 802.11abg wireless card to work on suse 11.0 installed on Hp laptop doing dual boot with windows vista to no avail. On vista all is well but on linux nothing doing. Have tried installing madwifi but still nothing. Yast says "Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details."

    output for iwconfig

    lo no wireless extensions.

    eth0 no wireless extensions.

    uname -r
    2.6.25.20-0.1-pae

    rpm -qa |grep madwifi
    madwifi-0.9.4-1
    madwifi-devel-0.9.4-1
    madwifi-kmp-pae-0.9.4_2.6.25.5_2-1

    Any idea to get my wireless on

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    There is more than one way to get this wireless working. The best way is dependent on the kernel version and the exact version of the AR242x that you have.

    The most current, and future driver, is the ath5k. It is usually available in newer kernels. So if you can upgrade to a 2.6.27 kernel, it should automatically load for the wireless. Another way is to compile it from source, using the compat-wireless package. It can be found here:

    Download - Linux Wireless

    If you want to stick with the Madwifi driver, you could first try the Madwifi Suse repository. I think that you could add it to YaST, so that it will automatically find updates.

    Index of /suse/11.1

    It is possible that the drivers in the Suse Madwifi repository won't work either. You may need to use a Madwifi driver snapshot to get it to work. Specifically the madwifi-hal snapshot, which can be found here:

    snapshots.madwifi.org

    If you had a kernel that is older than 2.6.21, then this is the only way to get it to work (madwifi-hal snapshot). The ath5k diver is incompatible with kernels older than 2.6.21. I have to use the madwifi-hal snapshot on Red Hat Enterprise Linux, because it uses a 2.6.18 kernel.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3
    Quote Originally Posted by waterhead View Post
    There is more than one way to get this wireless working. The best way is dependent on the kernel version and the exact version of the AR242x that you have.

    The most current, and future driver, is the ath5k. It is usually available in newer kernels. So if you can upgrade to a 2.6.27 kernel, it should automatically load for the wireless. Another way is to compile it from source, using the compat-wireless package. It can be found here:

    Download - Linux Wireless

    If you want to stick with the Madwifi driver, you could first try the Madwifi Suse repository. I think that you could add it to YaST, so that it will automatically find updates.

    Index of /suse/11.1

    It is possible that the drivers in the Suse Madwifi repository won't work either. You may need to use a Madwifi driver snapshot to get it to work. Specifically the madwifi-hal snapshot, which can be found here:

    snapshots.madwifi.org

    If you had a kernel that is older than 2.6.21, then this is the only way to get it to work (madwifi-hal snapshot). The ath5k diver is incompatible with kernels older than 2.6.21. I have to use the madwifi-hal snapshot on Red Hat Enterprise Linux, because it uses a 2.6.18 kernel.
    After downloading the linux wireless compatible drivers and installing , I now have Kwifi detecting a network and card recognized in Yast, module loaded is ath5k. However, there was a warning "WARNING: You are running a kernel >= 2.6.23, you should enable in it CONFIG_NETDEVICES_MULTIQUEUE for 802.11[ne] support" and then my wifi card doesn't get assigned IP via DHCP, so no connection despite network strength being very good. See below on network restart, iwconfig, ifconfig
    How do I edit and enable it on CONFIG_NETDEVICES_MULTIQUE ,

    wlan0 Link encap:Ethernet HWaddr 00:1F:3A:81:1CD
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3639 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:1310040 (1.2 Mb)

    wmaster0 Link encap:UNSPEC HWaddr 00-1F-3A-81-1C-DD-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11bg ESSID:"SGK-WiFi"
    Mode:Managed Frequency:2.412 GHz Access Point: 00:A0:C5:58:8D:34
    Bit Rate=11 Mb/s Tx-Power=27 dBm
    Retry min limit:7 RTS thr:off Fragment thr=2352 B
    Encryption key:4727-1B76-A102-74EE-80F2-88BB-3D Security mode:open
    Power Management:off
    Link Quality=67/100 Signal level:-58 dBm Noise level=-101 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0


    # service network restart
    Shutting down network interfaces:
    eth0 device: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8done+ (rev 10)
    wlan0 device: Atheros Communications Inc. AR242x 802.11abg Wirdones PCI Express Adapter (rev 01)
    Shutting down service network . . . . . . . . . . . . . done
    Setting up network interfaces:
    lo
    lo IP address: 127.0.0.1/8
    IP address: 127.0.0.2/8 done
    eth0 device: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    eth0 (DHCP) . . . IP/Netmask: '192.168.0.2' / '255.255.25done
    wlan0 device: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
    command 'iwconfig wlan0 nick foo' returned
    Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.
    wlan0 (DHCP) . . . . . . . . . . . . . . . no IP address yet..waitingrounding.
    Setting up service network . . . . . . . . . . . . . . done
    SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
    SuSEfirewall2: using default zone 'ext' for interface wlan0
    SuSEfirewall2: using default zone 'ext' for interface wmaster0
    SuSEfirewall2: batch committing...
    SuSEfirewall2: Firewall rules successfully set

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It's my understanding that the CONFIG_NETDEVICES_MULTIQUEUE message is not an error, just a message. To enable it, you would need to change the kernel configuration, and then re-compile the kernel. This would give you a non-standard kernel, and screw up automatic updating.

    If you were to compile a new kernel, there then would be no reason to stick with the 2.6.23 version. If you are going to have a non standard kernel, you may as well get the latest version!

    As for the wireless not working, is there an on/off shortcut key? It may just be disabled, and needs to be turned back on.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •