Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
Alright I'm royally confused. Please excuse my ignorance. I'm looking for a package named linux-backports-modules in what catagory when you get here: Ubuntu -- Ubuntu Packages Search ?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Feb 2009
    Posts
    11

    Alright I'm royally confused. Please excuse my ignorance. I'm looking for a package named linux-backports-modules in what catagory when you get here: Ubuntu -- Ubuntu Packages Search ?

  2. #12
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    just use apt to install it, with this command;
    Code:
    sudo apt-get install linux-backports-modules
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #13
    Just Joined!
    Join Date
    Feb 2009
    Posts
    11
    It says this:
    Reading package lists... done
    Building dependency tree
    Reading state information... done
    E: Couldn't find package linux-backports-modules

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It looks like you need to specify your kernel version. This can be done by using this command:
    Code:
    sudo apt-get install linux-backports-modules-`uname -r`
    Those are backticks around the uname -r command.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #15
    Just Joined!
    Join Date
    Feb 2009
    Posts
    11
    That seemed to work. Now what?

  7. #16
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Quote Originally Posted by amazure View Post
    That seemed to work. Now what?
    Your guess is as good as mine

    I guess that you could go back to the Hardware Drivers section and enable the wireless driver.

    Did you read the Ubuntu help page that i linked to before?

    https://help.ubuntu.com/community/Wi...Driver/Atheros
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #17
    Just Joined!
    Join Date
    Feb 2009
    Posts
    11
    I think we've made progress but it certainly isn't fixed. I have a friend who has the same computer as me, and he has done all this before, so I called him and left him a message. I'll see if he can help me. If not I'll be coming back here later so I'll let you know what happens.

  9. #18
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    There is another way to get the ath5k driver that you need. You can download the compat-wireless package from here:

    Download - Linux Wireless

    This contains the source files for many Linux wireless drivers. You would need to compile it, as it is source. First you need these applications and files installed.

    linux-source
    linux-headers
    gcc
    make

    You can install these with apt. If the source and header give an error, then use `uname -r`, like you did for the module package.

    There should be a README or INSTALL file with the compat-wireless files explaining how to install. Basically, you enter the folder with the "cd" command, and run these commands.

    make
    sudo make install
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #19
    Just Joined!
    Join Date
    Feb 2009
    Posts
    11
    I fixed it. First I installed the linux-restricted-modules because my friend said that worked for him, but it didn't work for me. Then I tried the second part of that web link you gave me - the part with adding things to the blacklist. That worked like a charm and my wireless is now up and running.

    Thanks for your help!

  11. #20
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Glad to hear that in the end it works.

    Ubuntu could make this a little easier. They make it soo easy to install nVidia drivers, but this they seem to have missed.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •