Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, I'm a noobie to the whole Linux thing and I have been reading and trying to get my wireless card to work on this laptop with no success. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2009
    Posts
    30

    WiFI With ubnutu and Netgear


    Hello,

    I'm a noobie to the whole Linux thing and I have been reading and trying to get my wireless card to work on this laptop with no success.

    I have an ancient Sony PCG-FX310 laptop with a Netgear WG511 v2 card. I have the driver installed per the windows wireless tab, but it keeps saying that there is no hardware installed. Here is a screen shot of my devices that are running:

    0000:00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 11)
    0000:00:02.0 VGA compatible controller: Intel Corporation 82815 CGC [Chipset Graphics Controller] (rev 11)
    0000:00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 03)
    0000:00:1f.0 ISA bridge: Intel Corporation 82801BAM ISA Bridge (LPC) (rev 03)
    0000:00:1f.1 IDE interface: Intel Corporation 82801BAM IDE U100 (rev 03)
    0000:00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 03)0000:00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus (rev 03)
    0000:00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 03)0000:00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio (rev 03)
    0000:00:1f.6 Modem: Intel Corporation 82801BA/BAM AC'97 Modem (rev 03)
    0000:01:00.0 FireWire (IEEE 1394): Texas Instruments TSB43AA22 IEEE-1394 Controller (PHY/Link Integrated) (rev 02)
    0000:01:02.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
    0000:01:02.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
    0000:01:08.0 Ethernet controller: Intel Corporation 82801BA/BAM/CA/CAM Ethernet Controller (rev 03)
    0000:02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless (rev 03)

    I installed the Marvell driver, but it still does not see any hardware. The netgear card is in the pcmcia slot.

    My OS is Ubnutu v. 6.06.1. I tried v. 8, but it would not work properly. My kernel version is 2.6.15-53-386

    Thanks for your help. I've tried everything that I could find in the forums, but nothing is working. Do I have to install firmware and recompile the kernel (i have no idea how to recompile)?

    THanks,

  2. #2
    Just Joined!
    Join Date
    Feb 2009
    Posts
    30
    Well, I got it working by using a different marvel driver than the one listed in the chipset. All is well.

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The version of Ubuntu that you are using is extremely old. I recommend Installing the latest version. It will have much better wireless support.
    Last edited by waterhead; 03-05-2009 at 02:49 PM. Reason: spelling
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. #4
    Just Joined!
    Join Date
    Feb 2009
    Posts
    30
    Yeah, I thought of that but when I put in a cd for v 8, it didn't really start up. It ran for a bit and then the screen stayed black and it didn't do anything. The laptop I am using is a Sony Vaio but it only has 256 meg of ram on it.

  5. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The driver for the i815 chip has been in the kernel for a while. You really shouldn't have problems with it. If you are trying to run the LiveCD, that may be the problem, 256MB isn't really enough to run a LiveCD. You may want to go straight to the installation. This may require a different CD version.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #6
    Just Joined!
    Join Date
    Feb 2009
    Posts
    30
    Updating as we type. It seems to be going ok.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •