Find the answer to your Linux question:
Page 6 of 6 FirstFirst ... 2 3 4 5 6
Results 51 to 59 of 59
OK, I was able to compile and load this driver on my Fedora 10 install. I don't know what the tftpboot file is used for, but I did find that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #51
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    OK, I was able to compile and load this driver on my Fedora 10 install.

    I don't know what the tftpboot file is used for, but I did find that you need to run theses commands.

    1) Gain root privileges. Use 'su' or 'sudo -i', or precede the commands with 'sudo'

    2) Enter these commands:

    make
    make install
    depmod -a
    /sbin/modprobe rt2860sta

    By running the make install command, it did install the module in the correct folder. It also ran the depmod command, so you may not need to do it again. The insmod command is old and depreciated, so that may be why it didn't work. I don't know why they say to use it, but they forget to tell you to run the make install command too!

    You can then check for the module in the output of lsmod. I would try to use NetworkManager to connect with it, before spending time configuring the RTA2860STA.dat file.
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #52
    Just Joined!
    Join Date
    Mar 2009
    Posts
    35
    Ok, so I ran those two commands and got a blank response. Which from what I've read is a good thing. Means it worked. But when I ran lsmod. I got this code.

    Code:
    eric@eric-desktop:/lib/modules/2.6.27-11-generic/kernel/drivers/net/wireless$ lsmod
    Module                  Size  Used by
    nls_iso8859_1          12032  1 
    nls_cp437              13696  1 
    vfat                   18816  1 
    fat                    57376  1 vfat
    binfmt_misc            16904  1 
    bridge                 56980  0 
    stp                    10628  1 bridge
    bnep                   20480  2 
    rfcomm                 44432  0 
    sco                    18308  2 
    l2cap                  30464  6 bnep,rfcomm
    bluetooth              61924  6 bnep,rfcomm,sco,l2cap
    ppdev                  15620  0 
    cpufreq_conservative    14600  0 
    cpufreq_userspace      11396  0 
    cpufreq_stats          13188  0 
    cpufreq_powersave       9856  0 
    cpufreq_ondemand       14988  0 
    freq_table             12672  2 cpufreq_stats,cpufreq_ondemand
    pci_slot               12680  0 
    wmi                    14504  0 
    video                  25232  0 
    output                 11008  1 video
    container              11520  0 
    sbs                    19464  0 
    sbshc                  13440  1 sbs
    battery                18436  0 
    iptable_filter         10752  0 
    ip_tables              19600  1 iptable_filter
    x_tables               22916  1 ip_tables
    ac                     12292  0 
    ndiswrapper           196380  0 
    lp                     17156  0 
    pcspkr                 10624  0 
    snd_usb_audio          89728  1 
    snd_usb_lib            24192  1 snd_usb_audio
    snd_hwdep              15236  1 snd_usb_audio
    snd_seq_dummy          10884  0 
    joydev                 18368  0 
    snd_via82xx            32536  3 
    snd_via82xx_modem      19464  0 
    gameport               19468  1 snd_via82xx
    evdev                  17696  8 
    snd_seq_oss            38528  0 
    snd_ac97_codec        111652  2 snd_via82xx,snd_via82xx_modem
    snd_pcm_oss            46848  0 
    snd_mixer_oss          22784  1 snd_pcm_oss
    ac97_bus                9856  1 snd_ac97_codec
    snd_mpu401_uart        15360  1 snd_via82xx
    snd_seq_midi           14336  0 
    snd_pcm                83204  5 snd_usb_audio,snd_via82xx,snd_via82xx_modem,snd_ac97_codec,snd_pcm_oss
    i2c_viapro             15764  0 
    snd_rawmidi            29824  3 snd_usb_lib,snd_mpu401_uart,snd_seq_midi
    snd_page_alloc         16136  3 snd_via82xx,snd_via82xx_modem,snd_pcm
    snd_seq_midi_event     15232  2 snd_seq_oss,snd_seq_midi
    snd_seq                57776  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
    snd_timer              29960  2 snd_pcm,snd_seq
    snd_seq_device         15116  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
    snd                    63268  22 snd_usb_audio,snd_hwdep,snd_via82xx,snd_via82xx_modem,snd_seq_oss,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_mpu401_uart,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore              15328  1 snd
    nvidia               6909268  36 
    i2c_core               31892  2 i2c_viapro,nvidia
    parport_pc             39204  1 
    parport                42604  3 ppdev,lp,parport_pc
    button                 14224  0 
    via_agp                16256  1 
    rt2860sta             520152  0 
    shpchp                 38036  0 
    pci_hotplug            34976  1 shpchp
    agpgart                42184  2 nvidia,via_agp
    ext3                  133256  1 
    jbd                    55828  1 ext3
    mbcache                16004  1 ext3
    usbhid                 35840  0 
    hid                    50560  1 usbhid
    sr_mod                 22212  0 
    cdrom                  43168  1 sr_mod
    sd_mod                 42392  5 
    crc_t10dif              9984  1 sd_mod
    ata_generic            12932  0 
    pata_acpi              12160  0 
    sg                     39732  0 
    usb_storage            82752  1 
    libusual               30356  1 usb_storage
    pata_via               16132  2 
    sata_via               15492  0 
    uhci_hcd               30736  0 
    ehci_hcd               43788  0 
    libata                178208  4 ata_generic,pata_acpi,pata_via,sata_via
    usbcore               149360  9 ndiswrapper,snd_usb_audio,snd_usb_lib,usbhid,usb_storage,libusual,uhci_hcd,ehci_hcd
    scsi_mod              155212  5 sr_mod,sd_mod,sg,usb_storage,libata
    dock                   16656  1 libata
    skge                   48144  0 
    thermal                23708  0 
    processor              42156  1 thermal
    fan                    12548  0 
    fbcon                  47648  0 
    tileblit               10880  1 fbcon
    font                   16512  1 fbcon
    bitblit                13824  1 fbcon
    softcursor              9984  1 bitblit
    fuse                   60828  3 
    eric@eric-desktop:/lib/modules/2.6.27-11-generic/kernel/drivers/net/wireless$
    I see the rt2860sta in there. I would like to use Network Manager but I haven't been able to figure out how to use it. It was one of my original problems.

  3. #53
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I also see ndiswrapper in there! You need to remove, uninstall, blacklist it and wipe it from the face of the earth!

    This will remove the module:
    Code:
     sudo modprobe -r ndiswrapper
    This will add it to the list of blacklisted modules. Make sure you use two of the greater than symbols (>>), using one will replace the file instead of adding to it.
    Code:
    sudo echo ndiswrapper >> /etc/modprobe.d/blacklist
    You should also uninstall ndiswrapper.
    Code:
    sudo apt-get remove ndiswrapper
    To use NetworkManager, access it using the icon found in the system tray (taskbar). It can be found next to the Date/Time. Right click on it and ensure that Enable Wireless is checked, then left click to see available wireless networks.

    You may first want to check if it is working, using terminal commands. To see all network cards, enter this.
    Code:
    ifconfig
    To see wireless cards, enter this:
    Code:
    iwconfig
    To see if it will scan for available wireless connections, enter this:
    Code:
    iwlist scan
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #54
    Just Joined!
    Join Date
    Mar 2009
    Posts
    35
    It is on my iwconfig list.

    Code:
    root@eric-desktop:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    ra0       RT2860 Wireless  ESSID:""  Nickname:""
              Mode:Auto  Frequency=2.412 GHz  
              Link Quality=10/100  Signal level:0 dBm  Noise level:-143 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    pan0      no wireless extensions.
    But the iwlist scan gave me this.

    Code:
    root@eric-desktop:~# iwlist scan
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    ra0       Interface doesn't support scanning : Network is down
    
    pan0      Interface doesn't support scanning.
    
    root@eric-desktop:~#

  6. #55
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Hey, at least it is showing up. I call that progress!

    Did you reboot after getting everything installed? That may be advisable, but check for the module, as it may not be automatically loading.

    Also, try the ifup/ifdown commands to activate it.
    Code:
    ifdown ra0
    Code:
    ifup ra0
    Now try to scan again.
    Code:
    iwlist ra0 scan
    Is there an on/off switch for the wireless, or a shortcut key combination to enable/disable it (Fn+Fx). Try them to enable it too.

    You didn't say if you tried NetworkManager. I think that NM will take care of enabling it.

    You also may want to follow the instructions at the bottom of the README file.
    If you want for rt2860 driver to auto-load at boot time:
    A) choose ra0 for first RT2860 WLAN card, ra1 for second RT2860 WLAN card, etc.

    B) create(edit) 'ifcfg-ra0' file in /etc/sysconfig/network-scripts/,
    edit( or add the line) in /etc/modules.conf:
    alias ra0 rt2860sta

    C) edit(create) the file /etc/sysconfig/network-scripts/ifcfg-ra0
    DEVICE='ra0'
    ONBOOT='yes'


    NOTE:
    if you use dhcp, add this line too .
    BOOTPROTO='dhcp'

    *D) To ease the Default Gateway setting,
    add the line
    GATEWAY=x.x.x.x
    in /etc/sysconfig/network
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #56
    Just Joined!
    Join Date
    Mar 2009
    Posts
    35
    ifup ra0 said "Ignoring unknown interface ra0=ra0" I tried with sudo also. I looked back into /lib/modules/2.6.27-11-generic/kernel/drivers/net/wireless and the rt2860sta.ko module is still there (I don't know if that's what you meant by check the module). There is no switch on the card, or any FN+? keys that I know of for it. Windows just turns it on after the driver loads.

    As far as I can see I don't have a /etc/sysconfig/network-scripts/ folder. I'm going to attempt to create the file though.

    When I right click what I think is the network manager I do have "Enable Networking" on. But when I left click it all my options are is to setup a VPN. Which isn't what I want. When I click "Edit Connections" the wireless section is blank. I don't see any kind of scanner or how to use the card. I'm guessing something is wrong here.

  8. #57
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You need to check if the module is loading, using the lsmod command.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #58
    Just Joined!
    Join Date
    Mar 2009
    Posts
    35
    Quote Originally Posted by waterhead View Post
    You need to check if the module is loading, using the lsmod command.
    It is. Like before, still with a 0 next to it.

  10. #59
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Ubuntu doesn't have that folder, the network information is in the /etc/network/interfaces file. On my Ubuntu PC, that file doesn't have any info about the network cards. It only has this:
    Code:
    auto lo
    iface lo inet loopback
    As I understand it, this is all that you should have. I believe that NetworkManager keeps the info somewhere. You could open the Network GUI found in the Administration menu. Make sure the device had "Enable Roaming Mode" checked.

    You could try this method:
    /etc/network/interfaces Ubuntu Linux networking example

    Here's another one:
    Ubuntu Networking Configuration Using Command Line -- Ubuntu Geek
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 6 of 6 FirstFirst ... 2 3 4 5 6

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •