Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all, I have been trying to get this card working with my laptop and Fedora 10 for about three days now, I think it's time to ask a professional ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Posts
    2

    Belkin F5D7010 and Fedora 10


    Hello all,

    I have been trying to get this card working with my laptop and Fedora 10 for about three days now, I think it's time to ask a professional at a forum, no? :P

    I tried ndiswrapper, but 'make' and 'make install' always comes up with an error (after I had to go and install it first).

    My lspci, lsmod, and dmesg are attached.
    Attached Files Attached Files

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Hello,and welcome to Linux Forums!

    There are no professionals here, just people who have figured out how to correct their mistakes.

    Thank you for the detailed info. For future reference, you can copy and post the text files directly into the post. You just surround them with quote and /quote or code and /code tags.

    HTML Code:
    Surround them like this:[code]This is the code[/code]
    This is the wireless:
    Code:
    03:00.0 Ethernet controller [0200]: Belkin Device [1799:701f] (rev 20)
    And it is loading this driver for it:
    Code:
    Module                  Size  Used by 
    rtl8180                30080  0                                      
    mac80211              173668  1 rtl8180                              
    eeprom_93cx6            5888  1 rtl8180                              
    cfg80211               23816  2 rtl8180,mac80211
    There is absolutely no mention of the wireless in dmesg, which is odd. Have you tried to configure the card using the "Network" GUI, found in the main menu? You need to highlight the wireless and click "Edit". Click the boxes to allow all users to enable it, and to allow NetworkManager to handle it. Use DHCP for the connection, then close it and save the new configuration. A reboot is a good thing to do next. When you boot up, the wireless should be controlled by NetworkManager, found next to the time in the taskbar.

    If there is no wireless listed in the "Network" setup GUI, then you don't have the correct driver. You will need to try a different or newer version. Here is some info on the driver.

    Main Page - Realtek Linux wireless driver

    EDIT: I just notice that there were two parts to your dmesg file. The second part has the wireless listed, and it seems to be trying to connect to something.
    Code:
    wlan0: authenticate with AP 00:13:46:87:6c:a4
    wlan0: authenticated
    wlan0: associate with AP 00:13:46:87:6c:a4
    wlan0: RX AssocResp from 00:13:46:87:6c:a4 (capab=0x421 status=0 aid=1)
    wlan0: associated
    ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    wlan0: disassociating by local choice (reason=3)
    wlan0: no IPv6 routers present
    wlan0: No ProbeResp from current AP 00:13:46:87:6c:a4 - assume out of range
    I think that you may have missed some more of the message. I also see that SELinux is enabled. Go into System-->Administration-->SELinux Management and completely disable it. See if that helps to make it work.
    Last edited by waterhead; 03-09-2009 at 02:03 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Mar 2009
    Posts
    2
    Thank you so much for your time!

    I guess this NetworkManager thing is exactly like the Network Connections dialog in Windows, who would have known? :P

    Anyway, yes, that worked like a charm! I was literally looking for my old Windows disk when I got your reply. I guess I can use Linux after all.

    I still have tons to learn, though...

    Thanks, once again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •